Fog 1.0.1 seems not to see snapins



  • Here we go again,
    we have several queued snapins but fog client seem not to see them, so nothing it is done and snap-ins remain in the queue.
    Is there something I need to configure anywere?

    Thanks in advance once more.

    Frank



  • Hi Tom,
    finally it seems solved. But I have had to make another action to make snap-ins work. You know that there is a change in snap-in file selection; i chose it from a select list an then click on “update” to make it efective, and then you see the file in the “sap file max size” box. But after migration to 1.0.1, in that box there is the whole path of file and that makes snap-in file download fails. It is necessary to click the “update” button i all of your snap-ins to make it work fine.

    I think that is so much important to advise users who are going to migrate. So my advise for them regarding to snap-ins will be:
    [LIST]
    []double-check that your snap-in task tables are empty, specially if you see after migration snap-in tasks in fog console which should not be there
    [
    ]apply update on all of your snap-ins
    [/LIST]
    Thank you very much for your hep Tom.
    I hope not to bother you more (at least in short ;))

    Frank
    UPC-Terrassa8Barcelona)



  • THanks Tom, you were right. Table snapinJobs was full of trash. I have emptied it and now I get a right response from the snap-in url query.
    I’m going to try now.

    Frank


  • Senior Developer

    if you’ve got a blank page, it usually indicates an error of some type. My guess is the over abundance of snapins in queue. I’d start by removing any snapins you know don’t need to be completed, maybe all of them? Then try a simple snapin deploy job and see if that get’s you anywhere.



  • I’ve got a blank page, writing the mac address in lowercase or in uppercase.
    There isn’t wireless. It’s an assigned host mac. So I guess the snap-in isn’t found in the database. Can it be?


  • Senior Developer

    [quote=“Frank, post: 28212, member: 691”]Yeah, I noticed that and I checked it global and locally. But it ignores de snap-in anyway.
    In apache logs when the fog client looks for snap-ins:

    172.16.1.104 - - [26/May/2014:17:42:35 +0200] “GET /fog/service/snapins.checkin.php?mac=00:0E:0C:5E:17:AE HTTP/1.1” 200 276 “-” “-”

    What else can it be?

    Frank[/quote]

    Frank,
    My last and final question on this matter, The snapins that are checking in are they coming from the assigned Host mac address, or is this being done wirelessly? If they’re being done wirelessly after the image task, this is likely your issue. The host probably isn’t recognized with the MAC and due to that doesn’t know what the snapin is.

    You can verify these findings by going to the following link:
    [url]http://<IP.OF.FOG.SRV>/fog/service/snapins.checkin.php?mac=00:0E:0C:5E:17:AE[/url] and what is the output of that page?



  • Yeah, I noticed that and I checked it global and locally. But it ignores de snap-in anyway.
    In apache logs when the fog client looks for snap-ins:

    172.16.1.104 - - [26/May/2014:17:42:35 +0200] “GET /fog/service/snapins.checkin.php?mac=00:0E:0C:5E:17:AE HTTP/1.1” 200 276 “-” “-”

    What else can it be?

    Frank


  • Senior Developer

    [quote=“Frank, post: 28207, member: 691”]Here we go again,
    we have several queued snapins but fog client seem not to see them, so nothing it is done and snap-ins remain in the queue.
    Is there something I need to configure anywere?

    Thanks in advance once more.

    Frank[/quote]

    When you initially install FOG 1.0.1, did you upgrade from 0.32 or did you do a fresh install?

    You will likely need to enable the service for each of the hosts on the host level. Make sure the services are enabled globally, then make sure the hosts have the services enabled as well.


Log in to reply
 

430
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.