AD Defaults not loaded when selecting Join Domain check box under group management



  • Hello,

    I have set the AD settings under Fog Configuration > Fog Settings > Active Directory Defaults, but when I go to modify a group and select the check Join Domain after image task check box, it uses the default fog/password. I had to all hosts to a group and modify it manually. Confirmed the settings are saved under Active Directory Defaults.

    Any ideas on where I should look to fix this in the php files?

    Thanks



  • No worries. I didn’t know how far you wanted to go with that. It doesn’t bother me any, and I realize it’s Apple’s fault in the end.


  • Senior Developer

    Well, I don’t think I’m going to just add label titles to the fields just for one browser that doesn’t want to behave properly. I’m sorry. At least I can get around it for most browsers. It still doesn’t make sense to me as we’re not using common names like “e-mail” or “password” We’re using names like: domain, domainuser, domainpass.



  • Don’t see it anymore on LastPass, but Safari doesn’t listen to the autocomplete tags unfortunately. [URL='http://stackoverflow.com/questions/22661977/disabling-safari-autofill-on-usernames-and-passwords’]Here’s a discussion on how to get around it[/URL], basically by adding a fake user/pass field that’s off the page.


  • Senior Developer

    Fixed in SVN 1744 I hope. I basically just turned off autocomplete on Host, Group, and within the FOG Settings inputs. If you see this anywhere else, just let me know.

    Thanks,


  • Senior Developer

    I’ll make the fields so they’re not autofilled then?



  • If you have a password manager running, it may be filling in the AD user/pass fields with whatever you use to log into the website. Safari, at least, starting doing this with 1.0.1.


  • Senior Developer

    I’ll take a look at that when I get home to my knowledge the Ajax part of it was still working.



  • This is a fresh install of 1.0.1 btw on Ubuntu 14.04 LTS.



  • Thanks,

    Just to make sure I communicated it correctly. In fog 0.32 I would go to group management, AD, and then when I clicked on that setting it would fill out the form with what I had stored in fog as the Active Directory defaults so that I only had to click Update.

    in 1.0.1 when I click on that “join…” check box, it just leaves the default fog/password there instead. I’m not talking about checking host for host. It just used to have a javascript or ajax portion that would fill it in for me when I clicked that checkbox.


  • Senior Developer

    The reason this page doesn’t load the AD Defaults for a group is because the Host’s within the group determine if they’re all enabled or not.

    It’s difficult and time consuming to check if all the hosts have the AD Information as it has to check All hosts to make sure the count of hosts all have the same information as well as compare that count back to the count of hosts within the group then allow it to display. This isn’t broken, but if you want to have a stab at it, it’s in the location lib/pages/GroupManagementPage.class.php


Log in to reply
 

420
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.