How is the user FOG interrupted by the FOG server?

  • As I posted earlier I screwed up my FOG server and did a bunch of tweaking to get it partially running again.
    ~ Key word above was partially ~
    When trying to copy and image from the DEV folder to the Image folder (Linux Image) I’m getting an error about not being able to make this move.
    Right now I’m rerunning the image after setting the FOG user to have permissions to the entire IMAGE directory. I’m in the middle of a RAW image transfer.

    My question(s)… During my tweaking above I changed the FOG user password - would this have any effect on the FOG severs request/abiliyt to move this file?


  • Ok that worked not sure why - can anyone shed any light on to why this would be the case — like to know how these systems work at a lower level. 🙂

  • It seems to be working as the images are showing up in the folders but they aren’t able to move them? So I think that TFTP issue is resolved but there seems to be a permissions issue…

    I just deleted the host, and image folder, database items, and the images themselves -re-imaging the client in RAW transfer mode - I will keep you posted figures crossed…

  • Yes the password in there would make a difference. On my FOG server my,under the config.php, my TFTP_FTP_PASSWORD is the same as it is under (WebUI) Storage Management > All Storage Nodes > DefaultMember > Management Password. These two need to match in order for FTP to work. Also, the password needs to match under (WebUI) Other Information > FOG Settings > TFTP Server > FOG_TFTP_FTP_PASSWORD. No idea though on a green folder.

  • Ok tried that command as well and still nothing getting the same result…
    I noticed in my /var/www/fog/commons/ config.php file that my password that use to be this really weir hashed out text is just ‘bos’ - I changed this when tweaking with the FTP stuff - would this make a difference?

    Also my images folder is showing up in my root directory and it’s green?
    When i push an image out it’s still working?

    Any clues on why my issue is or is this a bug related to Linux image?

  • The /images folder I think is tied directly to the FOG user account. If you selected the defaults when you installed the server, the password would be located under the storage nodes tab under with WebUI. This will be a long encrypted password. If you want a quick workaround, although not that secure, type this command “sudo chmod 777 /images” without the quotes. This will make the /images folder available to everyone on that system, but it’ll give full access so permissions wouldn’t be an issue.