Nothing is working...



  • [SIZE=3][FONT=arial]So I’m running 1.0.1 on Ubuntu 14.04 LTS on a Dell Optiplex 755 (physical server). In my network, there are three different Dell models I have attempted a PXE boot into.[/FONT][/SIZE]
    [SIZE=3][FONT=arial]1 Dell Vostros[/FONT][/SIZE]
    [SIZE=3][FONT=arial]2 Dell Optiplex 9010[/FONT][/SIZE]
    [SIZE=3][FONT=arial]3 Dell Optiplex 990[/FONT][/SIZE]

    [SIZE=3][FONT=arial]Now, I have a unique situation here. First, 1 boots perfectly, absolutely no flaws. That’s all good and well, however, 2 and 3 don’t function. 2 will hang for a while and give me an error “PXE-E[COLOR=#000000]51 No DHCP or DHCP Proxy Offers received” I don’t know why it would not receive an IP from the DHCp server, when #1 does. 3 Goes for a while, then stops and says “Could not boot: Input/ouput error ([url]http://ipxe.org/1d0c6139[/url])”[/COLOR][/FONT][/SIZE]
    [COLOR=#000000][SIZE=3][FONT=arial]Please help! I’ve been at this all week and I haven’t even uploaded my first image! :confused: [/FONT][/SIZE][/COLOR]


  • Developer

    It seems that a “Dell PowrConnet” has Spanning Tree Proticol (STP) enabled by default.
    ~[url]http://en.community.dell.com/support-forums/network-switches/f/866/p/17031843/17154977.aspx[/url]

    If you disable this feature on this switch it may allow PXE to route through.

    To quote Tom another thread…
    [QUOTE]2) Check all networking switches that can be managed have portfast enabled (cisco) and/or *STP Spanning Tree Protocol) are disabled on the switch. The and/or meaning with Cisco, portfast should be all that’s needed, but turn off Spanning Tree Protocol if you can just to ensure this is NOT a factor in blocking the DHCP from iPXE.
    ~[url]http://fogproject.org/forum/threads/040ee119-error-on-boot.10493/#post-27260[/url][/QUOTE]



  • It is a Dell PowerConnect


  • Developer

    Can you confirm the switch Make and model?



  • I think I have found the issue. I work at a bank where we have a separate building for out IT stuff. Well, our IT building is on a different switch than the bank is. Things seem to boot fine in the bank, but not in the IT building, where the FOG server is. I think I am going to move the FOG server around that switch and get it off of this switch.


  • Senior Developer

    Being a lowly intern means somebody “higher” than you can possibly lead you in the right direction.

    That being said, I don’t know what the issue is, but it almost sounds like a firewall is blocking access to the TFTP server. Have you tried simply disabling the firewall?

    [code]sudo ufw disable[/code]



  • I’m not sure what I did.

    I’m just a lowly intern, please forgive me.


  • Developer

    FWIW, my ubuntu 14.04 server is working fine.



  • [quote=“need2, post: 28143, member: 21891”]Or you could try Debian if you feel attached to a Ubuntu like ecosystem. Ubuntu’s core is Debian, and the freshest latest release of Debian works flawlessly with Fog.[/quote]

    Is there a working install I could use from a flash drive? Ubuntu didn’t seem to like the flash drive.

    Scratch that, sorry.


  • Moderator

    Or you could try Debian if you feel attached to a Ubuntu like ecosystem. Ubuntu’s core is Debian, and the freshest latest release of Debian works flawlessly with Fog.



  • [quote=“need2, post: 28136, member: 21891”]

    And honestly I would suggest using about any other Linux distro other than Ubuntu 14.04.[/quote]

    I tried putting 10.04 on, but the PC didn’t like that for some reason. I might try the x86 install


  • Moderator

    I would suggest you cleanly scrub out your current FOG install and all packages that are then no longer needed, then start again.

    And honestly I would suggest using about any other Linux distro other than Ubuntu 14.04.



  • I have done that twice, but I’m not opposed to doing it again if you think that will solve it.


  • Senior Developer

    Have you, possibly, thought of performing a reinstall of FOG?

    It sounds like, with these messages, tftpd-hpa service isn’t running properly.



  • The PXE-E51 and M0F errors both, the Vostros now looks just like the 9010s.


  • Senior Developer

    [quote=“Tom Elliott, post: 28110, member: 7271”]What is the error? The PXE-M0F error?[/quote]

    bump?



  • [quote=“Tom Elliott, post: 28111, member: 7271”]Are you able to login to the FOG GUI?[/quote]

    Yes I am. The GUI loads perfectly, but I am not able to PXE what-so-ever.


  • Senior Developer

    [quote=“Jordon Rapp, post: 28105, member: 24302”]Nothing specifically referencing boot.php. Here’s my log if you want to have a look: [URL=‘http://www.pastebin.com/BAUs2mub’]pastebin.com/BAUs2mub[/URL]

    Edit: log from today.[/quote]

    Took a look and it appears the database isn’t linking properly. Are you able to login to the FOG GUI?


  • Senior Developer

    [quote=“Jordon Rapp, post: 28109, member: 24302”]Well that’s now the case. I ran full registration on the Vostros, they stalled, I restarted them, now they return the same error as the 9010s.[/quote]

    What is the error? The PXE-M0F error?



  • [quote=“Tom Elliott, post: 28083, member: 7271”]
    How is it “Nothing is working” when right in your first statement you say it IS working?[/quote]

    Well that’s now the case. I ran full registration on the Vostros, they stalled, I restarted them, now they return the same error as the 9010s.


Log in to reply
 

393
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.