WOL and Task doesn't work



  • guys need your help,

    after a busy weekend with upload our whole it infrastruktur and image upload i foud out that “wake on lan” and the task function didn’t work! :eek:

    i’m shocked…

    i tried almost all WOL work arrounds but still no clue! i changed the switch, disable spanning tree, new installation and configuration of etherwake and so on and on…

    wol.php
    [CODE]
    <?php
    // Require FOG Base
    require(’…/commons/base.inc.php’);
    try
    {
    $MACAddress = new MACAddress($REQUEST[‘wakeonlan’]);
    if ($MACAddress->isValid())
    {
    $wol = new WakeOnLan($MACAddress->getMACWithColon());
    $wol->send();
    }
    else
    throw new Exception(
    (‘Invalid MAC Address!’));
    }
    catch (Exception $e){print $e->getMessage();}
    [/CODE]

    can someone help out to indentifiy the problem?

    thanks raffa



  • was not successfully…

    my firewall settings;

    [CODE]# Generated by iptables-save v1.4.12 on Fri May 23 16:14:51 2014
    *mangle
    :PREROUTING ACCEPT [0:0]
    :INPUT ACCEPT [0:0]
    :FORWARD ACCEPT [0:0]
    :OUTPUT ACCEPT [0:0]
    :POSTROUTING ACCEPT [0:0]
    COMMIT

    Completed on Fri May 23 16:14:51 2014

    Generated by iptables-save v1.4.12 on Fri May 23 16:14:51 2014

    *nat
    :PREROUTING ACCEPT [956:91224]
    :INPUT ACCEPT [508:45734]
    :OUTPUT ACCEPT [95:7272]
    :POSTROUTING ACCEPT [6:604]
    -A POSTROUTING -o eth0 -j MASQUERADE
    COMMIT

    Completed on Fri May 23 16:14:51 2014

    Generated by iptables-save v1.4.12 on Fri May 23 16:14:51 2014

    *filter
    :INPUT ACCEPT [10284:10111083]
    :FORWARD ACCEPT [2027:2489014]
    :OUTPUT ACCEPT [6609:1081709]
    -A FORWARD -i eth1 -j ACCEPT
    -A FORWARD -i eth2 -j ACCEPT
    COMMIT

    Completed on Fri May 23 16:14:51 2014[/CODE]

    but i don’t know what eth2 is!



  • will try…:)



  • remove the gateway 192.168.1.1, leave it blank.



  • yes, i have for each network…192.168.1.1 for the eth1 and 192.168.17.1 for the eth0



  • I just thought of something else. Have you got 2 gateways configured on the server, on both eth0 and eth1 because that would cause an issue.



  • thanks for helping, i will try the WOL on eth0…cheers



  • Raffa,

    The only thing I can suggest now is to try it with a server with a single card configured to use eth0.



  • the pictures is wrong…192.168.1.1 is corrcet!



  • In your pic your fog host is 192.168.1.2 but in your configuration its 192.168.1.1, is that an error in the pic or have you changed the static IP on the server.



  • ahh, sorry mate…seems okay!

    [CODE]define(‘TFTP_HOST’, “192.168.1.1”);
    define(‘TFTP_FTP_USERNAME’, “fog”);
    define(‘TFTP_FTP_PASSWORD’, “daa6c4”);
    define(‘TFTP_PXE_KERNEL_DIR’, ‘/var/www/fog/service/ipxe/’);
    define(‘PXE_KERNEL’, ‘bzImage’);
    define(‘PXE_KERNEL_RAMDISK’,127000);
    define(‘USE_SLOPPY_NAME_LOOKUPS’,true);
    define(‘MEMTEST_KERNEL’, ‘memtest.bin’);
    define(‘PXE_IMAGE’, ‘init.xz’);
    define(‘PXE_IMAGE_DNSADDRESS’, “8.8.8.8”);
    define(‘STORAGE_HOST’, “192.168.1.1”);
    define(‘STORAGE_FTP_USERNAME’, “fog”);
    define(‘STORAGE_FTP_PASSWORD’, “daa6c4”);
    define(‘STORAGE_DATADIR’, ‘/images/’);
    define(‘STORAGE_DATADIR_UPLOAD’, ‘/images/dev/’);
    define(‘STORAGE_BANDWIDTHPATH’, ‘/fog/status/bandwidth.php’);
    define(‘UPLOADRESIZEPCT’,5);
    define(‘WEB_HOST’, “192.168.1.1”);
    define(‘WOL_HOST’, “192.168.1.1”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth1”);
    define(‘SNAPINDIR’, “/opt/fog/snapins/”);
    define(‘QUEUESIZE’, ‘10’);
    define(‘CHECKIN_TIMEOUT’,600);
    define(‘USER_MINPASSLENGTH’,4);
    define(‘USER_VALIDPASSCHARS’, ‘1234567890ABCDEFGHIJKLMNOPQRSTUVWZXYabcdefghijklm nopqrstuvwxyz_()^!#-’);
    define(‘NFS_ETH_MONITOR’, “eth1”);
    define(‘UDPCAST_INTERFACE’, “eth1”);
    define(‘UDPCAST_STARTINGPORT’, 63100 ); / / Must be an even number! recommended between 49152 to 65535
    define(‘FOG_MULTICAST_MAX_SESSIONS’,64);
    define(‘FOG_JPGRAPH_VERSION’, ‘2.3’);
    define(‘FOG_REPORT_DIR’, ‘./reports/’);
    define(‘FOG_UPLOADIGNOREPAGEHIBER’,true);
    define(‘FOG_DONATE_MINING’, “0”);[/CODE]



  • Your pic just tells us that your using connection eth1, not that you have configured fog to use eth1 for WOL in the fog settings.

    check /var/www/fog/commons/config.php or use the console

    define(‘WOL_HOST’, “1.1.1.1”);
    define(‘WOL_PATH’, ‘/fog/wol/wol.php’);
    define(‘WOL_INTERFACE’, “eth0”);



  • raff, like the pic above show --> it is on eth1

    raffa



  • Change Settings FOG_WOL_INTERFACE to eth1.



  • okay, try the testwol.php script…but the notebook still sleeps!

    i made a arp-scan on eth1 and the mac adress is not visible, because the node sleeps and is not on.

    the fog wol stettings are attached and the network schema…
    [ATTACH]804[/ATTACH][ATTACH]805[/ATTACH]

    it might be due to the 2 network interface card? miss configuration?

    damm…raffa

    [url="/_imported_xf_attachments/0/804_wol_settings.jpg?:"]wol_settings.jpg[/url][url="/_imported_xf_attachments/0/805_ict_labor_FOG_image.jpg?:"]ict_labor_FOG_image.jpg[/url]



  • thanks guys, will checked right now!

    raffa


  • Developer

    or to test independently of anything fog related, use etherwake. [url]http://manpages.ubuntu.com/manpages/quantal/man8/etherwake.8.html[/url]
    i think you will find that if fog fails to do it, so will this. because the problem is not in fog.


  • Senior Developer

    Easiest method.

    Create a file in wol called testwol.php

    Place these commands:

    [php]<?php
    require_once(’…/commons/base.inc.php’);
    $mac = ‘XX:XX:XX:XX:XX:XX’;
    $WOLtest = new WakeOnLan($mac);
    if ($WOLtest->send())
    print 'WOL Packet <b>SENT</b> to '.$mac;
    else
    print 'WOL Packet <b>NOT SENT</b> to '.$mac;
    ?>[/php]

    Replace the XX’s with that of one of the MAC’s you want to wake up.

    In your browser, go to [url]http://<FOGSERVERIP>/fog/wol/testwol.php[/url]
    You should see the output:
    [code]WOL Packet SENT to XX:XX:XX:XX:XX:XX[/code]

    With any luck, this actually wakes the system up too!



  • how can i test this? sorry for my lack of knowledge…:-/


  • Developer

    does a wol packet sent manually from the server work?


Log in to reply
 

426
Online

38951
Users

10701
Topics

101530
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.