PXE Boot Problems after install FOG 1.0.0 on Ubuntu DHCP Server



  • hey guys,

    i’m new here…i would like to say hello to you all!
    i hope you guys can help me out.

    i installed FOG on a ubuntu server with dhcp. i have two interfaces, eth0 and eth1. dhcp on eth1 works.
    my only problem is, that the pxe boot doesn’t work.

    here the error code;
    [CODE]PXE-T01: File not found
    PXE-E3B: TFTP Error - File Not found
    [/CODE]

    here are my configs;

    [CODE]# DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 192.168.1.1;

    subnet 192.168.1.0 netmask 255.255.255.0 {
    option domain-name “Stadtschulen”;
    option subnet-mask 255.255.255.0;
    range dynamic-bootp 192.168.1.10 192.168.1.254;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 8.8.8.8;
    option routers 192.168.1.1;
    filename “undionly.kpxe”;
    }

    auto lo
    iface lo inet loopback

    auto eth0
    iface eth0 inet static
    address 192.168.17.20
    netmask 255.255.255.0
    gateway 192.168.17.1
    network 192.168.17.0
    broadcast 192.168.17.255
    dns-nameservers 8.8.8.8 8.8.4.4

    auto eth1
    iface eth1 inet static
    address 192.168.1.1
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255

    /etc/default/tftpd-hpa

    FOG Modified version

    TFTP_USERNAME=“fog"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“192.168.1.1:69"
    TFTP_OPTIONS=”-s"
    [/CODE]

    tftp works
    [CODE]tftp -v 192.168.1.1 -c get undionly.kpxe
    Connected to 192.168.1.1 (192.168.1.1), port 69
    getting from 192.168.1.1:undionly.kpxe to undionly.kpxe [netascii]
    Received 96672 bytes in 0.2 seconds [3133106 bit/s][/CODE]

    what should i check for pxe boot?

    thanks in advance for your help

    cheers raffa


  • Senior Developer

    [quote=“number_one, post: 28796, member: 24434”]Tom, do you mean the documentation shown as the installer runs? Maybe I’m missing something but I don’t see much except for a changelog included with the installer files. If you mean inline documentation within the installer then I didn’t pay enough attention while it was running. Sorry about the venting; just haven’t had any experience with FOG yet and am eager to get things up and running.[/quote]

    I meant the inline installer, that’s why it’s there.



  • Tom, do you mean the documentation shown as the installer runs? Maybe I’m missing something but I don’t see much except for a changelog included with the installer files. If you mean inline documentation within the installer then I didn’t pay enough attention while it was running. Sorry about the venting; just haven’t had any experience with FOG yet and am eager to get things up and running.


  • Senior Developer

    [quote=“number_one, post: 28781, member: 24434”]Might it not be a good idea to update all the info on the wiki/guide to reflect this fact especially for new users? I spent a half hour trying figure out why PXE boot wasn’t working and just about everywhere states “pxelinux.0” as the proper file.[/quote]

    I’m slowly working on the documentation. That said, the documentation within the installer is up-to-date. So while I’m sorry the WIKI is not up to par quite yet, there IS information available.



  • Are there other changes in v1.0.x that are going to be incompatible with earlier releases? Is there a document somewhere that describes any changes? Thanks.



  • [quote]undionly.kpxe is the new filename that DHCP option 67 should point to now?[/quote]
    Might it not be a good idea to update all the info on the wiki/guide to reflect this fact especially for new users? I spent a half hour trying figure out why PXE boot wasn’t working and just about everywhere states “pxelinux.0” as the proper file.


  • Developer

    [quote=“Junkhacker, post: 28263, member: 21583”]why not just put a redirect in the root?[/quote]
    Change /var/www/fog/index.html to contain the following:

    [CODE]<meta http-equiv=Refresh content=“0;url=/fog/”>[/CODE]

    Edit:
    [U][B]IF you don’t have any other web services on this machine [/B][/U]


  • Developer

    why not just put a redirect in the root?



  • Solved my own question. I did go back and change the default files under apache2/sites-available to point to html/fog and then changed the web config on the Web UI to point to just ‘/’ instead of /fog/ and then edited /tftpboot/default.ipxe to change the path and eliminated the ‘/fog/’ section and all is good to go now. Thanks for the help, that little tip helped solve all my problems!



  • That makes sense. I did change the root directory to /var/www/html/fog in /etc/apache2/sites-available/default to redirect to x.x.x.x/fog instead so I can just type the ip in the browser and not have to do /fog after. I reverted back and everything is good to go. My next question, how would I be able to setup the server to point to x.x.x.x/fog when I type just x.x.x.x in the browser?


  • Senior Developer

    [quote=“bradburyn, post: 28243, member: 24378”]Alright I had to create an account to submit my issue. I have spent about 2 days of reading and testing but have not had any success. I am trying to setup fog 1.0.1 and have a windows dhcp server (66 and 67 are setup correctly (undionly.kpxe). I have tried on 14.04 64bit and now 12.04 32bit with the exact same issue. I pxe boot the client and it picks up dhcp and starts the boot but I get an error when the line hits “<myip>/fog/service/ipxe/boot.php no such file”. I checked the directory and the file is clearly there, I disabled firewall and even opened up all permissions with still no luck. I gave up for the night but in the morning my next try will be to download fog and try an older install to see if this continues. Any help or insight before the downgrade would be appreciated.[/quote]

    When you installed, did a symlink from /var/www/fog get created in /var/www/html/? If so, chances are this is what’s causing your particular issue. You may need to edit the configuration file to make /var/www/ the document root as opposed to /var/www/html


  • Developer

    I take it you can log in to the gui OK.
    A couple of things to try.
    point your browser at [url]http://<myip>/fog/service/ipxe/boot.php[/url] you should see an ipxe menu.
    if this fails check your apache log, on ubuntu 12.04 the above should go to /var/log/www/fog/service/ipxe/boot.php if my memory serves me right.
    There should be an entry in the log saying what it can’t find.



  • Alright I had to create an account to submit my issue. I have spent about 2 days of reading and testing but have not had any success. I am trying to setup fog 1.0.1 and have a windows dhcp server (66 and 67 are setup correctly (undionly.kpxe). I have tried on 14.04 64bit and now 12.04 32bit with the exact same issue. I pxe boot the client and it picks up dhcp and starts the boot but I get an error when the line hits “<myip>/fog/service/ipxe/boot.php no such file”. I checked the directory and the file is clearly there, I disabled firewall and even opened up all permissions with still no luck. I gave up for the night but in the morning my next try will be to download fog and try an older install to see if this continues. Any help or insight before the downgrade would be appreciated.



  • [quote=“Tom Elliott, post: 27662, member: 7271”]When you go the FOG GUI from a browser, does all operate properly?[/quote]

    solved. I have stopped vsftpd and ipxe has started properly.



  • Yes, apparently everything works well


  • Senior Developer

    When you go the FOG GUI from a browser, does all operate properly?



  • Hello,

    I have a problem after upgrading to version 1.01. At boot displays the following message:
    [IMG]http://i61.tinypic.com/2ypdcnn.jpg[/IMG]
    Tnx All!



  • finally it works! :)

    i changed the ip adress to 192.168.1.1 for all in instances.
    changed the mysql pw under /var/www/fog/commons/config.php

    et voila

    thanks for all the support!

    raffa



  • uhhh, something is running! :-)

    the tftp ip adress is wrong, in the configuration menu the ip adress is 192.168.1.1 --> how to change this?

    [url="/_imported_xf_attachments/0/770_2014-05-14 13.32.54.jpg?:"]2014-05-14 13.32.54.jpg[/url]



  • This post is deleted!

Log in to reply
 

374
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.