Install fog, load up webpage, "Unable to connect to Database"



  • I install Fog and get this sad message. I know the issue is mysql not starting, attached is the log from /var/log/mysql/errror.log

    Below is some more wonderful output.

    toast@bento-13:~/opt/fog_0.33b/bin$ sudo mysql -u root -h bento-13 fog
    ERROR 2003 (HY000): Can’t connect to MySQL server on ‘bento-13’ (111)

    Currently running 13.10 in a VM, hopefully that doesn’t matter. I get the same connection error when using my regular system as well.

    [url="/_imported_xf_attachments/0/675_error.txt?:"]error.txt[/url]


  • Senior Developer

    Toast,

    mysql appears to NOT be working in your situation.

    How do you know mysql works? The “It works!” page is not a mysql issue, that’s telling you apache is working fine. The “Unable to connect to Database” shows you that the DATABASE is actually the issue.

    Did you try the commands I gave you and it’s not working?



  • Nope still getting the same error of "Unable to connect to Database"
    I know mysql works because the “It works!” default page loads up just fine.

    Gonna try Debian 7.4 and 12.04 next, I hear great things about them and eventually, 14.04. Good thing these are on VMs. Consider this solved for now, not interested in wasting time for problems for a distro that isn’t the LTS.


  • Senior Developer

    If bento-13 is what you’re logged on as AND this is your fog server, you shouldn’t be trying to load from the hostname.

    Try logging into mysql with:
    [code]mysql -u root fog[/code]

    If you set a password, you’ll likely need:
    [code]mysql -u root -p fog[/code]


Log in to reply
 

511
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.