Fog wont load past kernal_thread_helper+0x6/0x10



  • I just recently updated my fog from 0.32 to 0.33b and I am unfortunately still stuck when I try to upload the image from an hp pro-book 450G1. I’ve tried registering both through a quick register and manually by inputting the mac address selecting the image and uploading. Both seem to stop at the 5.731830 kernel_thread_helper.


  • Developer

    we have moved to partclone for compatibility reasons. you do not want to use partimage for new images.


  • Moderator

    Partclone is the new method. Partimage is the old one. No research to back this up but it appears that partclone handles compression more efficiently. You should only have Partimage selected for legacy images from 0.32, and ideally you should replace those eventually with new images from 0.33 .



  • So i decided to go back a recheck everything including my bosses changes to the DHCP. It appears that it was only changed under server options and not scope options. So yea i’m ready to do the same to my keyboard… After making sure that it was changed on both i was able to successfully pxe boot and i am currently uploading my image to the server… Thank you all so much!! couldn’t have done it with out everyone.
    One final question it gives me the choice for part clone or part image, i selected part image but in noticed that during the imaging part clone is running , and its moving along quite slowly.
    Either way progress none the less.


  • Moderator

    I about caved my keyboard in with my face yesterday when I made the jump to 0.33 and couldn’t get TFTP transactions to work either. I checked everything, and even did a sudo clean install, but to no avail. Finally I double checked my DHCP settings, and I swear some documentation somewhere told me to use undionly.pxe, when it should be undionly.kpxe . Once I fixed that Option 67 on my DHCP, magically everything worked.

    I blame reading the wrong thing somewhere but I know it was likely my own internal processing error.


  • Senior Developer

    viper, there is nothing for FOG_TFTP_PXE_CONFIG_DIR set for 0.33b because it’s not needed or used in any way.



  • what is your value for [FONT=Ubuntu][COLOR=#555555]FOG_TFTP_PXE_CONFIG_DIR under fog settings tftp server?[/COLOR][/FONT]



  • What is different between the .032 and 0.33 it seems that the tftp only works when going to pxelinx.0



  • i checked the folder [SIZE=4][FONT=Times New Roman][COLOR=#000000][FONT=courier]/etc/xinetd.d/tftp[/FONT] and there isn’t a tftp file only chargen, daytime, discard echo and time[/COLOR][/FONT][/SIZE]



  • i ran the tftp and it gave me the following…
    timeout occurred
    connect request failed


  • Senior Developer

    [SIZE=4][B][COLOR=#000000][FONT=helvetica]Errors After Obtaining IP Address (Issue 3)[/FONT][/COLOR][/B][/SIZE]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]During a PXE boot installation, the following errors appear after obtaining the IP address:[/COLOR][/FONT][/SIZE]
    [SIZE=4][FONT=Times New Roman][COLOR=#000000]PXE-T01: File not found

    PXE-E3B: TFTP Error - File Not found

    PXE-M0F: Exiting Broadcom PXE ROM.[/COLOR][/FONT][/SIZE]
    [B][FONT=Times New Roman][COLOR=#000000]Cause[/COLOR][/FONT][/B]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]The boot file name does not exist on the PXE server.[/COLOR][/FONT][/SIZE]
    [B][FONT=Times New Roman][COLOR=#000000]Solution[/COLOR][/FONT][/B]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]In the [FONT=courier]/etc/xinetd.d/tftp[/FONT] file on the PXE server:[/COLOR][/FONT][/SIZE]
    [LIST]
    [LIST]
    [*]Check that the correct arguments are used.
    [/LIST]
    [/LIST]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]It is recommended that you use -s /tftp, and ensure that the TFTP service uses [FONT=courier]chroot(1)[/FONT] to change its top level directory to [FONT=courier]/tftp[/FONT]. This means that the [FONT=courier]dhcp filename[/FONT] argument is relative to the top level directory (and does not include the section [FONT=courier]/tftp[/FONT]).[/COLOR][/FONT][/SIZE]
    [LIST]
    [LIST]
    [*]Check that the [FONT=courier]filename[/FONT] argument has been spelled correctly.
    [/LIST]
    [/LIST]

    [LIST]
    [LIST]
    [*]Check that the [FONT=courier]next-server[/FONT] IP number has been specified correctly.
    [/LIST]
    [/LIST]

    [SIZE=4][FONT=Times New Roman][COLOR=#000000]To test the TFTP service, try installing a TFTP client on a different machine and attempt to download a file:[/COLOR][/FONT][/SIZE]
    [SIZE=4][FONT=Times New Roman][COLOR=#000000]# cd /tmp

    tftp PXE-server

    tftp> get /as-2.1/sun/pxelinux.bin

    Received 10960 bytes in 0.1 seconds

    tftp> quit[/COLOR][/FONT][/SIZE]


  • Developer

    have you tested if the file on the tftp server is accessible ?


  • Developer

    the tftp client being installed on windows is just so you can test the tftp server on the linux box



  • Ok


  • Senior Developer

    You’re only installing tftp client on one of the systems you want to try to image.

    This will let us know if the file’s even accessible.



  • Fog installed through script using the wget method from mastacontrola



  • My fog is on my ubuntu 12.04 why am I installing the tftp client on Windows?
    I have the file in the ipxe folder


  • Senior Developer

    Okay,

    So we’ve established that Option 66 is the IP of the FOG Server.
    Option 67 is set as undionly.kpxe.

    There is no DHCP Router address set in FOG, but that shouldn’t matter right now.

    There is no DNS address set in FOG, but that shouldn’t matter right now.

    Have you been able to successfully download the file via a command prompt window?
    NOTE: YOU MAY HAVE TO INSTALL TFTP CLIENT IN WINDOWS Programs and Features.
    [code]tftp -i <FOGSERVERIP> get undionly.kpxe[/code]



  • yes same information just a fresh 0.33b install instead of 0.32



  • The only thing different is that i took you advice and did a clean install, with a larger drive


Log in to reply
 

364
Online

38988
Users

10712
Topics

101691
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.