Storing images on network share



  • EDIT: See Last post for solution
    [SIZE=3][I]Original:[/I][/SIZE]
    Hello,
    [S]I am wondering if its been done. And if there is a best practice for doing this sort of thing.[/S]
    I have searched the wiki and the forums, and decided to seek help from the community.

    We have 12TB of storage on our network(NAS). My goal is to store all images on the NAS for safekeeping.
    Is it possible by default to do this?

    I thought long and hard about this, and I came up with a few ideas that may get the job done.
    1: create a symlink: This will allow linux to think its saving it on its own hard drive, but will actually save to network.
    2: setup a cron tab with bash script to just transfer the files (save and deploy from server -but then must re-locate images prior to deploying. )

    3: Attach NAS to Server via USB(not sure if it will work, but theres a chance.)

    More Details: Running fog on Dell Poweredge 2850 with ubuntu-server(no gui).

    Please share your thoughts and opinions on this matter and hopefully find a solution.



  • That error you’re having has to do with the rights. You have to give the proper rights to the user/group fog is using to write to the image directory.



  • Some progress has been made.
    To connect to my NAS, I created a storage node with the IP of the storage device and then I used /nfs/images/ to point it to the correct directory.

    What I stated above is incorrect: [S]192.168.1.244:/mnt/pools/A/A0/images[/S] this is what works: 192.168.1.244://nfs/images/

    It works, but fails to copy the images from the dev directory. :(



  • Although it looks good on paper, it still does not work… I am seeing an Permission Denied unable to mount /images/dev .

    At this point, I am trying to figure out why permission denied and how to overcome it. I have created a user named fog on my NAS device with the same auto generated password created by fog during the setup. Perhaps I will try to change the password in ubuntu and my NAS device to see if that is part of my issue. (assuming that there is an issue with the users password or perhaps the user ID is different across the devices… not sure if that matters, but theres only one way to find out.)



  • I have a Solution… as simple as it sounded, it was even simpler.
    From my initial idea, I just mounted the NFS share and pointed it to my /images directory.

    Exact command I used:
    [I] sudo mount -o soft,intr,rsize=8192,wsize=8192 192.168.1.244:/mnt/pools/A/A0/WorkstationImages /images[/I]

    my NAS device is .244 and the directory I wished to mount was /mnt/pools/A/A0/WorkstationImages

    then the /images at the end is where I wish to point to…

    and it worked. So, now when I login to the FOG web management I see all disk space under “Disk Information”. (the server previously only had 28GB… now it shows 12TB) – see screenshot
    [ATTACH=full]61[/ATTACH] [I][/I]

    [url="/_imported_xf_attachments/0/61_fogger.JPG?:"]fogger.JPG[/url]



  • A cheap and easy way to do this is copy your image files from the fog server to a external hard drive. Then you could copy those images to your NAS. You would have to remember to do this everytime you made a change to the images.



  • EDIT:
    Although it is XFS… I found an option in the settings that allowed me to enable NFS.
    Woo Hoo!.. Next, I will attempt to follow the[URL=‘http://www.fogproject.org/wiki/index.php?title=FOGUserGuide#Separate_NFS_Server’] Seperate NFS Server[/URL] tutorial that I found in the wiki/ user guide.

    It also supports FTP,TFTP and other common protocols. I may also look into the TFTP as an option.

    I would like to hear from others with similar situations.
    Thanks



  • Does your NAS support NFS?


Log in to reply
 

371
Online

38975
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.