FOG .33b PXE Boot woes



  • Hi all. Ive been a long time fog user, i think since .27 and love the heck out of the software. I am trying to get .33b setup on a machine running Ubuntu 12.04.4. It is connected on an isolated network for testing using a simple linksys home router for the DHCP server and dnsmasq. When i boot up an HP 8300 elite client it is able to connect to my fog server but when it hits TFTP it stops and exits the boot agent immediately. When i do the same with an HP8000 elite i get the following:
    TFTP.
    PXE-T01: File not found
    PXE-E3B: TFTP Error - File not found

    I have verified that the TFTP server is running on the fog server and frankly i am stumped.

    I’ve followed all of the instructions from [url]http://www.fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server[/url]
    and i have searched this forum extensively to see if i can solve my problem. Any insight would be greatly appreciated!


  • Senior Developer

    Is the tftp server correct?

    Does the file undionly.kpxe exist in /tftpboot/?

    Have you copied the contents of /tftpboot/* to /var/lib/tftp/?



  • Hi guys,

    I’ve been reading this thread and just want to report that I have the same problem.

    Here is the screenshot
    [ATTACH=full]1338[/ATTACH]

    Is there a solution?
    Thanks

    [url="/_imported_xf_attachments/1/1338_Windows7Pro.png?:"]Windows7Pro.png[/url]



  • I had to create the tftp directory in /var/lib. After running the commands and rebooting the client i have the same message on screen. I also tried creating the links to /var/lib/tftpboot since that was an existing directory, though that also had no effect.

    I also just tried with a newer client and receive the same error.


  • Senior Developer

    Try this:

    [code]sudo ln -s /tftpboot/undionly.kpxe /var/lib/tftp/undionly.kpxe
    sudo ln -s /tftpboot/default.ipxe /var/lib/tftp/default.ipxe[/code]

    Restart your client and report.



  • Not sure if this will help, but here is a screen shot of what I am getting on the client PC.

    [ATTACH=full]863[/ATTACH]

    [url="/_imported_xf_attachments/0/863_20140530_143053.jpg?:"]20140530_143053.jpg[/url]


  • Developer

    the undionly.kpxe file automatically searches for default.ipxe in the same directory as itself.
    changing that setting requires recompiling undionly.kpxe



  • Good point. Is there another config file somewhere that deals with the path to the default.ipxe? I assume it just looks for it in the /tftpboot directory but perhaps this isnt the case?


  • Developer

    so long as the file can be read anonymously, ownership doesn’t matter



  • Both files are in the /tftpboot folder and are set to 644. Still throwing the same error. I currently have fog as the owner of the /tftpboot directory, should i change this back to root?


  • Developer

    can you verify that both the undionly.kpxe and default.ipxe are in the same directory and their permissions are 644



  • Yes, I am able to retrieve undionly.kpxe and default.ipxe via TFTP.


  • Developer

    can you retrieve undionly.kpxe by tftp from another computer from command line?



  • Changed ownership of /tftpboot to fog user and group and restarted the services and no change.



  • Restarted the service and now it will boot back into iPXE. Now it stops at [I]/default.ipxe… No such file or directory ([url]http://ipxe.org/2d12603b[/url]) [/I]This reads to me like a permissions issue since the file is in the /tftpboot directory.


  • Developer

    [quote=“Paul Freeman, post: 28676, member: 23545”]Hello again all.

    I would like to thank you all for your hard work and dedication to the FOG project and all the support you offer everyone and to myself.

    After seeing that .33 was in RC status I decided to wait for the full release. Now I have a fresh install of 1.01 on linux Mint 16 running in production using Cisco router DHCP on 1 NIC.

    I have followed the instructions via the WIKI for using DNSMASQ and after completion I was able to get a PC to start to load into iPXE. It had stopped at trying to load /default.ipxe and I was not sure why, so I rebooted the server and now the machines will no longer boot to iPXE. It now stops again at [I]PXE-E32: TFTP open timeout[/I]. I have verified that both TFTPD-HPA and DNSMASQ services are running.

    I do not understand why it would stop working after a reboot when nothing else has changed.[/quote]

    What happens if you restart the services even though they are running?



  • Hello again all.

    I would like to thank you all for your hard work and dedication to the FOG project and all the support you offer everyone and to myself.

    After seeing that .33 was in RC status I decided to wait for the full release. Now I have a fresh install of 1.01 on linux Mint 16 running in production using Cisco router DHCP on 1 NIC.

    I have followed the instructions via the WIKI for using DNSMASQ and after completion I was able to get a PC to start to load into iPXE. It had stopped at trying to load /default.ipxe and I was not sure why, so I rebooted the server and now the machines will no longer boot to iPXE. It now stops again at [I]PXE-E32: TFTP open timeout[/I]. I have verified that both TFTPD-HPA and DNSMASQ services are running.

    I do not understand why it would stop working after a reboot when nothing else has changed.


  • Developer

    [quote=“Paul Freeman, post: 25459, member: 23545”]I had rebooted the server machine completely with the same result. Though when i try to restart the tftpd-hpa service it hangs and does not seem to want to start it again. And after a reboot when trying to restart the service the machine hangs at shutdown. Sounds like I may have other issues anyway. Would sorta make sense, i have been all over the place trying to get this thing to work.[/quote]

    I would definitely start fresh. I can confirm these settings work for a linksys router. But if you are in a production environment, adjustments will need to be made. This is the most basic setting a ltsp.conf can have to boot.

    I updated the wiki.

    In order to use boot commands you will need to symlink undionly.kpxe to undionly.0

    [code]
    cd /tftpboot
    sudo ln -s undionly.kpxe undionly.0
    [/code]

    Then edit your ltsp.conf edit these two lines
    [code]
    #pxe-prompt=“Press F8 for boot menu”, 3
    to
    pxe-prompt=“Press F8 for boot menu”, 3

    You may change the number value after we get it working. 0 will instantly boot your first command.

    #pxe-service=X86PC, “Boot from network”, pxelinux
    to
    pxe-service=X86PC, “Boot from network”, undionly.0
    [/code]



  • I had rebooted the server machine completely with the same result. Though when i try to restart the tftpd-hpa service it hangs and does not seem to want to start it again. And after a reboot when trying to restart the service the machine hangs at shutdown. Sounds like I may have other issues anyway. Would sorta make sense, i have been all over the place trying to get this thing to work.


  • Senior Developer

    Okay, I hope all goes well.

    I don’t know why it’s not pulling the default file, but before you start all over, maybe try restarting the tftpd-hpa service.


Log in to reply
 

398
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.