Changing FOG Server IP address - Problems arose!



  • Hi all,

    Before I begin - I am by no means an Ubuntu / Linux expert - this is my first experience of this with FOG :)

    Been running FOG 0.32 (and before that 0.31) for a few months now, and I love it, great product.

    However, I recently had a need to change the Static IP address of the FOG server (running on the latest Ubuntu). I followed the instructions found here [url]http://fogproject.org/wiki/index.php?title=Change_FOG_Server_IP_Address[/url] which although aimed at a different version of FOG, seemed to apply quite well to 0.32.

    I have managed to follow all steps apart from
    [LIST]
    [][I]DHCP server configuration file (/etc/dhcpd.conf) restart service after changes are made. [/I]
    [LIST]
    [
    ][I]Next-server 192.168.1.50 [/I]
    [/LIST]
    [][I]PXE Menu changes ( /tftpboot/pxelinux.cfg/default) [/I]
    [LIST]
    [
    ][I]Replace any previous IP addresses with new IP address [/I]
    [/LIST]
    [/LIST]
    I dont seem to be able to locate the file mentioned in the first step I, [/I]and more importantly, if I browse to the I[/I] file, I only have read permissions to this file, and cannot save the changes I make. It says the owner is the user “fog” - I am logged in to Ubuntu as “Administrator”, and when trying to switch account to the “fog” user, I dont know the password to login - as far as I am aware the default password for the user “fog” is “password” - but that doesnt work (it DOES work on the WebGUI).

    I have found the option to change the password for the “fog” user within Ubuntu, but don’t know the implications of changing that password of my images etc.

    Any help with this would be greatly appreciated - the server is now physically on the new IP address, and I can log in to the WebGUI on the new address.

    Many thanjs

    Andy[I][/I]



  • [quote=“Zardan, post: 1094, member: 185”]You probably didn’t chose to install DHCP on the fog server and should do this instead [url]http://www.fogproject.org/wiki/index.php?title=Modifying_existing_DHCP_server_to_work_with_FOG[/url]
    Type this to edit the pxe menu file: sudo nano -w /tftpboot/pxelinux.cfg/default[/quote]

    Thank you so much - the command to edit the pxe menu worked perfectly :)

    Yes I didnt choose to install DHCP on the server, so I had already modified an existing DHCP server - thanks again!



  • You probably didn’t chose to install DHCP on the fog server and should do this instead [url]http://www.fogproject.org/wiki/index.php?title=Modifying_existing_DHCP_server_to_work_with_FOG[/url]
    Type this to edit the pxe menu file: sudo nano -w /tftpboot/pxelinux.cfg/default


Log in to reply
 

786
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.