TFTP errors - NIC chipset failure?



  • Hi Developers and all,
    please take al look at the end of thread

    [url]http://fogproject.org/forum/threads/problems-for-ip-configuration-for-fog.10123/[/url]

    and give me please any hints for resolve this Problem. Thank you very much and many greetings.

    Sorry for crosspost …



  • Hi Tom,

    after I have now removed the broken network-hub and now again use the FOG Version 0.32 , everything seems to work very satisfactorily .

    I have learned over the past few days a lot about Linux and FOG.
    If, nevertheless, again if problems arise , I am back.

    Once again many thanks for the support with my first steps with FOG and friendly greetings.


  • Senior Developer

    The error you first described is probably because of the switch needing to point to the dhcp server. But you got past that from my understanding, and now you’re seeing the error in the picture?

    The error appears to be related to either something being plugged in or unplugged from the system. If that wasn’t the case maybe something on that system is failing? I don’t know the particular issues relating to this so I’m going to guess the latter is the case. Something on that system is failing.

    However, even with that error being printed to the console, can you still enter one of the options and have things work? Just wondering.

    Thank you,



  • Hi Tom,

    please excuse me, I have robbed you of the time.
    I believe the cause of the problems we have found:

    it was not the TFTP server and not a NIC, but a hub on the LAN. I have replaced the hub to a switch, and now I can at least two of the three problematic computer with PXE boot and select the menu.
    I would have found this my mistake never without the advice from you!
    Nevertheless, an error still comes up:

    Menu Compatibility:
    Error 0x040ee119
    The error is probably related to IPv6. This error will certainly be repaired.

    Another mistake is to look at the attached photo, maybe you can write something about it.
    Best regards and many thanks once again and apologize.

    [url="/_imported_xf_attachments/0/587_SAM_1962.JPG?:"]SAM_1962.JPG[/url]



  • Hi Tom,
    c&p and my answers:

    SAM_1961.JPG (You’re doing a system client check?)Yes.

    This is showing nothing about a task. It looks like you chose the boot into System information mode and chose the compatibility check which all succeeds. Is this true? Yes.

    Are this pictures from the same system? Yes.

    Which one was a tasking set for that failed? Yes.

    I testing three systems, where FOG not works. Today I must send many pictures from the another machines.

    Thank you very much and many greetings.


  • Senior Developer

    [quote=“Oma Voss, post: 24218, member: 22725”]Hi Tom,

    the picture named SAM_1957.JPG display after waiting for approx. 30 - 45 [I][U]minutes[/U][/I]; another machine I wait for 1 - 5 [U][I]seconds[/I][/U] …
    upload or deploy not works.[/quote]

    The picture in SAM_1957.JPG is trying to load one of the files. If it took that long to even get there, then something may be wrong with the network to that particular machine. From what I see in the pictures, things appear to be working properly.

    SAM_1957.JPG (loading the init.xz an bzImage) is expected. I can’t see a delay from a picture so I’m sorry if I’m not able to help out with this.

    SAM_1959.JPG (After it’s loaded the init.xz and bzImage file) The errors here happen because the kernel can’t find the device it’s trying to load the drivers for. I’ll see what I can do to remove some of those drivers, but as each system is different, I have no idea what drivers are fairly safe to remove, vs. which drivers absolutely need to be there for the systems to boot. Once again, if there’s a delay here, I can’t see it. After all, it is a picture.

    SAM_1961.JPG (You’re doing a system client check?) This is showing nothing about a task. It looks like you chose the boot into System information mode and chose the compatibility check which all succeeds. Is this true? Are this pictures from the same system? Which one was a tasking set for that failed?



  • Hi Tom,

    the picture named SAM_1957.JPG display after waiting for approx. 30 - 45 [I][U]minutes[/U][/I]; another machine I wait for 1 - 5 [U][I]seconds[/I][/U] …
    upload or deploy not works.


  • Senior Developer

    The errors you see in the picture named SAM_1959.JPG are normal messages just reporting you the information to let you know your system does not have that specific device. That said, you should be able to upload and deploy an image.



  • It´s great!

    I booting things to 192.168.115.19 and FOG works!

    But that did not work also 0.33B with my three problematic machines.
    I’ve been waiting a long time before the screen and three pictures taken, maybe you can recognize it, the cause of the delays.

    [url="/_imported_xf_attachments/0/582_SAM_1957.JPG?:"]SAM_1957.JPG[/url][url="/_imported_xf_attachments/0/583_SAM_1959.JPG?:"]SAM_1959.JPG[/url][url="/_imported_xf_attachments/0/584_SAM_1961.JPG?:"]SAM_1961.JPG[/url]


  • Senior Developer

    Go to FOG Configuration ( ? ) icon then FOG Settings

    Look for:
    FOG_TFTP_HOST and make sure it’s set to 192.168.115.20
    AND
    FOG_WEB_HOST and make sure it’s set to 192.168.115.20

    Otherwise it’s going to try booting things to 192.168.115.19, which as far as I understand it, doesn’t exist in your particular scenario.



  • The new System is Ubuntu Host 192.168.115.20 and FOG 192.168.115.20.

    But 192.168.115.20/fog/management Dashboard displays at 192.168.115.19 for web server and tftp server.


  • Senior Developer

    So, is the new system still 192.168.115.20 or 192.168.115.19?



  • Okay,

    the installation worked.
    Now continue:

    192.168.115.20/fog/management -> Home:
    Web server: 192.168.115.19
    TFTP Server: 192.168.115.19
    Disk Information: Failed to connect to

    192.168.115.19 was an attempt to circumvent the previously failed installation …

    Can you please give me more hints? Thank you.


  • Senior Developer

    You may have to try installing again. There is slight differences in how the IP is obtained which usually gets the correct information, but for whatever reason it doesn’t store it properly in the script.

    When it asks for the IP address, enter it manually rather than just hitting enter.
    [address 192.168.115.20] 192.168.115.20

    And it should install fine after that.



  • Hi Tom,

    the three problematic motherboards have no EFI BIOS, they are about 3-5 years old.
    I have now been newly started on another PC Ubuntu 12.04 and FOG 0.33B installed.
    When configuring the FOG comes right at the beginning a mistake:

    What is the IP address to be used by this FOG Server: [address 192.168.115.20]
    Invalid IP address!

    In this case, this address is the static IP address of my Ubuntu host!

    I think that the DHCP server, TFTP server, and the host must have the same IP address, in my case 192.168.115.20.
    I come here not just continue and ask for help.

    Many greetings.


  • Senior Developer

    Now are you sure EFI has been disabled on these hosts? It seems to me that something is failing to load properly. It recognizes the Menu after a delay period.

    In the BIOS make sure things are setup for Legacy style especially pertaining to networking. Disable the network UEFI stacks if at all possible as well. It isn’t the motherboard from my experience. You’re having issues with the systems in particular, but it seems it’s more related to the pxelinux.0 file for those systems. You may think about updating to a more recent version, though I couldn’t tell you which one will work. That you you could upgrade to 0.33b if you wanted and start using iPXE which appears, from my experience, to be very versatile and compatible with nearly all systems.

    If I understand your other posts correctly, your still just trying to get things into a working state after you installed FOG. So I’d highly recommend giving this a shot. It’s not a simple drop in place install though. It’s highly recommended to do a fresh install for the best results.



  • (translated with google)

    Hi Tom,
    I removed all the parameters \n from the default file, unsuccessfully. After a waiting time of about one minute, the FOG menu is visible, by selecting an item from the menu, you see the message " Loading fog / kernel / bzImage … " then sometime after an even longer wait time "Boot failed: press a key to retry , or wait for reset … " it goes no further .

    The problem only affects my PC in which an Intel dual-core processor is installed.

    PC with motherboard ASUS M3N78 -VM with AMD Athlon 64X2 FOG works

    PC with ASUS P5W DH Deluxe motherboard with an Intel Core2 Quad CPU FOG does not work
    PC with motherboard ASUS P5RD2 -VM with Intel Pentium D CPU FOG does not work
    FSC ESPRIMO E5925 PC with Intel Core2 Duo CPU E8400 FOG does not work

    I have the settings in the BIOS largely compared and adjusted , still without success in terms of FOG .

    Do you please have any advice for me ? Thank you .
    Friendly greetings .

    (German original)
    Hallo Tom,
    ich entfernte alle Parameter \n aus dem default file, erfolglos. Nach einer Wartezeit von etwa einer Minute ist das FOG-Menü zu sehen, nach Auswahl einer Option aus dem Menü sieht man die Meldung “Loading fog/kernel/bzImage…”, dann irgendwann nach noch längerer Wartezeit “Boot failed: press a key to retry, or wait for reset…” es geht nicht weiter.

    Das Problem betrifft nur meine PC, in die ein Intel DualCore-Prozessor eingebaut ist.

    PC mit Motherboard ASUS M3N78-VM mit AMD Athlon 64X2 FOG funktioniert

    PC mit Motherboard ASUS P5W DH Deluxe mit Intel Core2 Quad CPU FOG funktioniert nicht
    PC mit Motherboard ASUS P5RD2-VM mit Intel Pentium D CPU FOG funktioniert nicht
    PC FSC ESPRIMO E5925 mit Intel Core2 Duo CPU E8400 FOG funktioniert nicht

    Ich habe die Einstellungen im BIOS weitgehend verglichen und angepasst, trotzdem ohne Erfolg in Bezug auf FOG.

    Hast Du bitte noch einen Rat für mich? Vielen Dank.
    Freundliche Grüße.


  • Senior Developer

    I’m just confused where you’re coming up with the assumption it’s your motherboard and/or your NIC’s.

    The picture you’re displaying is saying Missing Parameter \n from the default file. Remove any extra white space (enter/carriage returnes) within the file and try booting again. As you haven’t, if I’m understanding the picture, even booted to the init.gz/bzImage OS layer yet.



  • (Google translated)
    Update:

    I have now tested different NIC on the motherboard ASUS P5W DH Deluxe (Realtek, D-Link, Intel, NoName), all with the same negative result.

    I now suspect that the cause of the problem is that the motherboards in question dual-core or quad-core processors are built in and there I made ​​an incompatible setting. With the motherboard ASUS M3N78-VM FOG works but, but also there is a dual core processor installed. If it is up to the BIOS settings of processor, South or North bridge - where to look?

    Each of the FOG properly registered LAPTOP IMMEDIATELY works without problems, but I have unfortunately only notebooks with a single-core processor …

    Is there still any hints please? Thank you.

    [url="/_imported_xf_attachments/0/581_SAM_1947.JPG?:"]SAM_1947.JPG[/url]


Log in to reply
 

426
Online

39.3k
Users

11.0k
Topics

104.3k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.