Not able to upload image



  • Okay, let me preface this by stating that I’ve been working on this FOG project on and off for about two weeks now. I’ve managed my way through a few issues by utilizing good ol’ Google and troubleshooting skills. However, I REALLY need this thing to work… like now… as I’m getting a batch of 20 new PCs coming in this week (and I’d REALLY like to not have to set each one up independently).

    So… I have an Ubuntu server, running 10.04.04 LTS (Lucid), hosting DHCP, PXE and FOG (v0.32) services. I have another Ubuntu server running 12.04 LTS running DNS, SAMBA and CUPS (not that it’s really relevant to my problem). I have attempted to upload an image to FOG from both a virtual PC (using VirtualBox) and physical PC (Dell OptiPlex 3020). In both cases, I’m able to pull up the PXE menu on the target PCs, I’m able to Perform Full Host Registration and Inventory successfully (and visibly confirm this success through the FOG web GUI), able to schedule the task successfully, but I’m NOT able to successfully upload an image. I go to the target PC, reboot into PXE and I just get the standard menu. No imaging takes place.

    EDIT:
    Virtual PC running XP 32bit, Dell OptiPlex 3020 running Win7 Pro 64bit.

    TL;DR version… Ubuntu/FOG can’t upload image.
    WTB help.



  • Well, went back to the drawing board. Created a new VirtualBox server running Ubuntu 10.04 and installed Fog 0.32. Having run the install again, I realized that I had to have deviated from the standard installation instructions at least twice over username/password instances. Noting this, I did a trial run and was able to successfully do everything PXE-related (Memtest, Register, etc.). I followed the instructions for Uploading an image and was able to do so on the 1st try.

    With this success in hand, I went back to the physical server and removed Fog following the instructions here:
    [url]http://www.fogproject.org/wiki/index.php/Uninstall_FOG[/url]

    Reinstalled Fog on physical server and voila! Happy image uploading. :)



  • Tom,

    thanks for the quick response. I checked the /tftpboot directory and there are two MAC address entries. FTP is running and I was able to log in. I reset the fog user password and made appropriate changes in
    Storage Management->All Storage Nodes-><YOUR STORAGE NODE>->Management Username/Password
    and
    Other Information ( ? ) Icon->FOG Settings->FOG_TFTP_FTP_PASSWORD

    Rebooted the PC, no joy.

    Thanks & Regards!


  • Senior Developer

    My guess is the FTP user is not correct. After you setup a task, and before you reboot the relevant system, check the FOG Server’s /tftpboot/pxelinux.cfg folder. Make sure it has the 01-xx-xx-xx-xx-xx-xx file (the x’s represent the system’s MAC address). If it doesn’t my guess is the file never got generated which is why you’re not seeing the system start the tasking you just setup.

    Verify that FTP is set correctly.

    Login to the FOG Server using a terminal.

    [code]sudo su - root[/code]

    Then verify the password is set correctly to something you can easily remember for the fog user:
    [code]passwd fog[/code]

    Change the password in the GUI under:
    Storage Management->All Storage Nodes-><YOUR STORAGE NODE>->Management Username/Password

    If the FOG Server is the same place as the storage node also change the FOG_TFTP_FTP_PASSWORD under:
    Other Information ( ? ) Icon->FOG Settings->FOG_TFTP_FTP_PASSWORD

    Hopefully all will work then.


Log in to reply
 

440
Online

38939
Users

10697
Topics

101495
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.