Early install issue / mirror issue?



  • Good day everyone, I was referred to this awesome tool by a friend after I saw first hand
    how easy Fog can make my life. I have setup a centOS server, and started to setup
    fog. this is the error i am receiving. I am not sure if its the mirror that’s faulty, or is it
    something i can do.

    please assist. i will do my best to give any information without sounding like a
    blithering idiot.

    Are you sure you wish to continue (Y/N) y

    Installation Started…

    Installing required packages, if this fails
    make sure you have an active internet connection.

    • Skipping package: httpd (Already Installed)
    • Skipping package: php (Already Installed)
    • Skipping package: php-gd (Already Installed)
    • Skipping package: php-cli (Already Installed)
    • Installing package: php-gettext
    • Skipping package: mysql (Already Installed)
    • Skipping package: mysql-server (Already Installed)
    • Skipping package: php-mysql (Already Installed)
    • Skipping package: tftp-server (Already Installed)
    • Skipping package: nfs-utils (Already Installed)
    • Skipping package: vsftpd (Already Installed)
    • Skipping package: net-tools (Already Installed)
    • Skipping package: wget (Already Installed)
    • Skipping package: xinetd (Already Installed)
    • Skipping package: tar (Already Installed)
    • Skipping package: gzip (Already Installed)
    • Skipping package: make (Already Installed)
    • Skipping package: m4 (Already Installed)
    • Skipping package: gcc (Already Installed)
    • Skipping package: gcc-c++ (Already Installed)
    • Installing package: htmldoc
    • Skipping package: perl (Already Installed)
    • Skipping package: perl-Crypt-PasswdMD5 (Already Installed)
    • Skipping package: lftp (Already Installed)
    • Installing package: clamav-update

    Confirming package installation.

    • Checking package: httpd…OK
    • Checking package: php…OK
    • Checking package: php-gd…OK
    • Checking package: php-cli…OK
    • Checking package: php-gettext…Failed!
      [christod@localhost bin]$

    I have tried it several times, but it gets stuck there. any ideas?


  • Senior Developer

    Agreed, worse comes to worse, also check the apache error logs during startup as it is referencing php files.



  • I am not sure if that helps. You can start the service with
    [CODE]service FOGMulticastManager start[/CODE]
    If that still fails, please take a look into the file
    [CODE]/opt/fog/log/multicast.log[/CODE]



  • i have redone all the steps, but it seems like i get the same results. Does anyone know how to get the FOG multicast management server started?

    • Installing init scripts…OK
    • Setting up FOG Services…OK
    • Starting FOG Multicast Management Server…Failed!
      [root@localhost bin]#


  • A big thank you Tom. i went step by step through the wiki, then copied your code. installed, and working ! i have access to the dashbord, and was able to log in. However once install was complete i found this:

    • Setting up storage…OK
      • Setting up and starting NFS Server…OK
      • Setting up and starting DHCP Server…Skipped
      • Setting up and starting TFTP and PXE Servers…OK
      • Setting up and starting VSFTP Server…OK
      • Setting up sudo settings…OK
      • Setting up FOG Snapins…OK
      • Setting up and building UDPCast…OK
      • Installing init scripts…OK
      • Setting up FOG Services…OK
      • Starting FOG Multicast Management Server…Failed!
        [root@localhost bin]#

    that’s going to cause a problem huh?


  • Senior Developer

    I’m going to go on a limb and believe you’re installing 0.32?

    For htmldoc to be installed, you need to have rpmforge repo installed. Follow the wiki article to install all the needed repos.
    [url]http://fogproject.org/wiki/index.php/Installation_on_CentOS_6.4[/url]

    I don’t think you need the php-gettext as that should be installed with php-common when installing on CentOS. Remove the php-gettext from the file.

    The file will be:
    {code]cd <location where you extracted the downloaded fog>/fog_0.32/lib/redhat/config.sh[/code]

    The line should contain packages= in front of it near the top of the file.

    Remove the php-gettext parts. If you want you can replace the entire line with:
    [code]packages=“httpd php php-cli php-common php-gd php-mysql mysql mysql-server dhcp tftp-server nfs-utils vsftpd net-tools wget xinetd tar gzip make m4 gcc gcc-c++ htmldoc perl perl-Crypt-PasswdMD5 lftp clamav”;[/code]


Log in to reply
 

465
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.