• Wasn’t sure which topic to post this under.

    What order does FOG join a host to the domain? Let’s say that I already have a host set up, and I want FOG to join it to the domain after imaging, but I want it to be named correctly first, as I have “*” set for ComputerName in Sysprep. Will FOG rename first, or does it join the domain, then rename, if I check the Join Domain option?

  • I may remove the need for the \ all together. I mean, you’ve already got the domain in place, so why not use that, then just have a setup like:

    domain: test
    domain username: user
    domain password:ao723597u32l4kjfldgpjdas;fjkasupiou2j5kasjfk;

    Then when the call to send it comes along send it as:

  • Ok… got it!

    Did a little research in other posts and figured it out. First off, you have to encrypt the password or it just flat fails. Secondly, you have to input the username as domain\user. So, for my domain, it’s called intranet.naylor (I didn’t name this crap…)


    I had to enter the AD info as follows:

    Domain: intranet.naylor
    OU: (Blank)
    Domain Username: intranet\user
    Domain Password: (FOGCrypt Encrypted Password)

    And that’s THAT! I’m running Zero-Touch!! 😄

  • Yes, check the host service settings.

  • No, I don’t have the hostname set during the imaging process. In my unattend.xml, I have put in “<ComputerName>*</ComputerName>”, so the imaged machine gets a randomly generated computer name. After the unattend process runs, the machine reboots, but nothing happens once it gets back to the login screen. It worked fine a few weeks ago. Also, when I check fog.log, there aren’t any entries from hostnamechanger at all. The only other thing I’m thinking is, maybe it got disabled in the client. Is there a way to check, without removing and reinstalling the client software?

  • Did the hostname change happen with the imaging process? Is the hostname set properly already? If it is, it’s not going to change the name because it’s already set.

    I believe you do need to have the username as: domain\user or user@domain.

    The password does need to be encrypted.

  • I was reading some other forum posts last night and now that you said something about the password not being encrypted… Do I have to encrypt it? Also, I read that you have to put the domain before the username (domain\username). Is this true?

    Even if I set those settings right, i’m still having the issue of “hostnamechanger” not running. At least I’m not seeing in fog.log.

  • It looks like domain joining is working, until it tries sending the data back to the host. This isn’t an issue in the hostname.php file, but rather looks to me like the password being sent isn’t encrypted, or there’s a blank username being send. Maybe the password is wrong?

  • I’m noticing that my “hostnamechanger” component isn’t running anymore. When the machine boots, the log is only showing “UserTracker”, “SnapinClient”, “DirCleaner”, “GUIWatcher”, and “MODDebug”. This is the same image i’ve been working with for a while now… I’m going to uninstall the client and reinstall to see if it helps.

    As for adding to the domain, i’ve managed to get this to run one time, but it failed and this is what the log said… [ATTACH=full]569[/ATTACH]


  • Or you can use the command on the location system with Command Prompt (as administrator) with:
    [code]net stop “FOG Service”
    net start “FOG Service”[/code]

  • Developer

    it’s not just joining after imaging - the client service will join to the domain at the next time it checks in with the server as long as domain join is set/checked under host information and the client checks in as pretty instant the first time the service starts/restarts so the easiest way without you having to mess with code is to just restart the fog service on the remote machine as long as you have admin rights to that machine just run this from command line (a windows machine):

    sc.exe \machine restart “FOG Service”

  • I’m actually looking for the command that tells the machine to add to domain. The part that would run right after imaging… It has to be fairly simple to pull that portion out and place it somewhere as it’s own callable function.

  • Which services files are you referring to? The files found in /var/www/{fogwebdir}/service/ are not the ones that I’m referring to. If you need the files that actually perform the checkin’s they’re located if you’ve checked out the trunk in trunk/FOG Service/

  • Where are these service files located? I’ll look for myself…

    Edit - Nevermind… I found it.

  • Dude, I don’t know.

    I didn’t code the service files at all. It works as it always had. I don’t know what else to tell you.

  • Is it possible to at least, create a task for joining the domain alone, instead of only joining after imaging? So, next time the client checks in, it just runs said task…

  • In FOG’s case, its based on the client and it’s refresh times to checkin with the server. We don’t have cross communication between the two as there’s no network connectivity in that regard. Maybe ghost had a client that maintained an open port on the system, but fog doesn’t so theres truly no way, for now, get have the server tell the client to check in.

  • From what I know of client/server software like this, the way around it is to just have the server tell the client to “refresh” it’s check-in timer. This causes the client to check for changes. But, you only do this when you want to make a change right then. I know that’s how Ghost Console did it. If you execute a task, it just tells the client to check in. The server isn’t initiating anything other than that.

    But, then again, I don’t really understand how that would cause any more or less traffic, than having the server side push changes to the clients…

  • No, and I don’t think there could be. It’s up to the client to checkin, not the server checkin with the client. Otherwise we’d have a heck of a mess in network traffic I’d think.

  • One more question though… Is there any manual way to add to domain through FOG? Like, an option to go to a specific host and just click a button that says “Add to Domain Now” or something like that?