Cant Get dhcpd to start after installing FOG on centOS 6.5



  • Hello All, I’m a newby as far as FOG and DHCP are concerned. After reading the install doco on FOG, I was able to install it and bring up the web interface. A bit more detail is that Fog is installed on the same server that will be be the dhcp server. In /etc/dhcp the file dhcpd.conf. Mine looks like this:

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;

    Fog’s IP address:

    next-server 10.45.60.4;

    Subnet where you are going to use Fog

    subnet 10.45.60.0 netmask 255.255.0.0 {
    option subnet-mask 255.255.0.0;
    range dynamic-bootp 10.45.60.50 10.45.60.200
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 10.24.55.1 10.24.55.10;
    filename “pxelinux.0”;
    }

    This is my present “not working” dhcpd.conf
    Let me also add that this server has 2 interfaces 10.45.60.XX and 10.45.110.XX.
    I created this file from a file I found when searching under /etc/dhcp post FOG install.
    No matter how I change it to meet several examples “other than changing my ip info…” I found on line, I’m unable to start the dhcpd daemon. My goal is to have a FOG & DHCP server providing ip’s for both the 10.45.60 and 10.45.110 subnets. I’m perplexed at this point and figured I need help from the experts… :-)
    If anyone has come across this scenario and can help, I would appreciate it. Also, if further information is needed I will provide it ASAP.
    Thanks in advance!
    Mark



  • None of the machines were able to be queued!
    [ftwlx132] Unable to connect to tftp server.



  • Made password changes, but still no luck
    from /var/log/messages on FOG server:
    Feb 20 12:08:14 ftwclonez-drbl dhcpd: DHCPOFFER on 10.45.60.66 to 00:25:90:27:3b:6d via eth0
    Feb 20 12:08:15 ftwclonez-drbl dhcpd: DHCPREQUEST for 10.45.60.66 (10.45.60.4) from 00:25:90:27:3b:6d via eth0
    Feb 20 12:08:15 ftwclonez-drbl dhcpd: DHCPACK on 10.45.60.66 to 00:25:90:27:3b:6d via eth0
    Feb 20 12:08:15 ftwclonez-drbl xinetd[2186]: START: tftp pid=4261 from=10.45.60.66
    Still getting:



  • [quote=“FOG-Newby, post: 23304, member: 22364”]I’m now getting the following error:
    None of the machines were able to be queued!
    [ftwlx132] Unable to connect to tftp server.
    Please excuse my ignorance and lack of experience with tftp and dhcp… :-( Not sure where to go next.[/quote]
    [quote=“FOG-Newby, post: 23306, member: 22364”]Adding more information related to tftp:
    ]# netstat -a|grep -i tftp
    udp 0 0 *:tftp :[/quote]



  • Adding more information related to tftp:
    ]# netstat -a|grep -i tftp
    udp 0 0 *:tftp :



  • I’m now getting the following error:
    None of the machines were able to be queued!
    [ftwlx132] Unable to connect to tftp server.
    Please excuse my ignorance and lack of experience with tftp and dhcp… :-( Not sure where to go next.



  • Thank Tom!
    I will reconfigure and give it another try. I appreciate your reply!!! :-)


  • Senior Developer

    The reason 255.255.0.0 won’t work is you’re trying have two dhcp servers within the same subnet. 255.255.0.0. Will provide dhcp to all systems with a 10.45.x.x address. To limit the address range to specific 10.45.60.x. You would need a subnet of 255.255.255.0. Same for the 10.45.110.x subnet.



  • Hello again. I have been trying to solve this on my own and was able to get dhcpd running by changing the subnetmask to 255.255.255.0. I’m not sure why 255.255.0.0 will not work. I know this is not correctMy updated dhcpd.conf is below:

    DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;

    Fog’s IP address:

    next-server 10.45.60.4;

    Subnet where you are going to use Fog

    subnet 10.45.60.0 netmask 255.255.255.0 {
    option subnet-mask 255.255.0.0;
    range dynamic-bootp 10.45.60.50 10.45.60.200;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 10.24.50.1;
    filename “pxelinux.0”;
    }

    Forgot to give the interface info, sorry:
    eth0 Link encap:Ethernet HWaddr 00:1E:0B:C6:XX:XX
    inet addr:10.45.60.4 Bcast:10.45.255.255 Mask:255.255.0.0
    inet6 addr: fe80::21e:bff:fec6:f2ca/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:267102 errors:0 dropped:0 overruns:0 frame:0
    TX packets:28602 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:63428461 (60.4 MiB) TX bytes:4334677 (4.1 MiB)
    Interrupt:17

    eth1 Link encap:Ethernet HWaddr 00:1E:0B:C6:XX:XX
    inet addr:10.45.110.200 Bcast:10.45.255.255 Mask:255.255.0.0
    inet6 addr: fe80::21e:bff:fec6:f2cb/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:237586 errors:0 dropped:0 overruns:0 frame:0
    TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:58982623 (56.2 MiB) TX bytes:670 (670.0 b)
    Interrupt:18



  • Forgot to add that the images I will take and restore are a Windows/Linux dual boot image I keep on the FOG server under a filesystem names /images. This is a 1tb filesystem due to the several images that will reside there.


Log in to reply
 

349
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.