Unbale to move /images/dev ....



  • Hi everybody ! (I’m a french student so be indulgent with my english please ;))

    I want to upload a system image (windows7 on Dell Optiplex 620); I created an upload task, and all seems good because I have blue sreen with my upload’s progress bar !
    Except that below, I have this message during my progress bar stays in 0%: “Line 1169: can’t create /images/00XXXXXXXXXX/sys.img.000”. This page stays few seconds, then, an other blue sreen appears by showing in a loop this message: “Unable to move /images/dev/00XXXXXXXXXX to /images/IMAGENAME”.

    In /images:

    • 00XXXXXXXXXX
    • dev

    My two folders are empty.

    Somebody has an idea about the problem please ?



  • I tested with:
    //10…
    \10…
    10…
    None works.

    Ideas ???


  • Senior Developer

    Try this for your /etc/fstab line:

    [code] //10.132.44.22/fog/images /images cifs defaults,username=fog,password=gof2014 0 0[/code]



  • How to know it ?


  • Senior Developer

    Is it being shared as NFS then?



  • No it doesn’t seem to me…


  • Senior Developer

    Is this being shared as a samba share?



  • Yes I have.


  • Senior Developer

    On your NAS, do you have a folder called /fog/images?



  • It returns:
    mount : le périphérique spécial 10.132.44.22:/fog@gof2014/fog/images doesn’t exist

    It’s an error in the definition of my NAS, isn’t it ?


  • Senior Developer

    What happens if you type the command:
    [code]mount /images[/code]



  • My symbolic link in /etc/fstab doesn’t work:
    XX.XX44.22:/fog@gof2014/fog/images /images auto bind,defaults 0 0
    (fog@gof2014 is the login to connect to NAS)

    It doesn’t work because when I execute a df -h ./ command, it returns always the same result:
    /dev/disk/by-uuid/7e4aba7b-9902-4068-9740-4ec3e2a90430 323M 184M 122M 61% /
    (line which corresponds:

    / was on /dev/sda1 during installation

    UUID=7e4aba7b-9902-4068-9740-4ec3e2a90430 / ext4 errors=remount-ro 0 1)



  • Okay, I’m going to test all this and I will say you results !

    Thank you Tom !


  • Senior Developer

    With the method you’re using, you wouldn’t need a symbolic link itself. Just setup /etc/fstab like you have:

    I think the syntax is slightly backward:

    Try this in the fstab:

    [code]<IP-OF-NAS>:/images /images auto bind,defaults 0 0[/code]

    The only thing you’d need to make sure of, after images is mount is make sure permissions are correct and the .mntcheck files exist.

    So reboot the system,

    Verify that the /images directory is mounted:

    [code]cd /images
    df -h ./[/code]

    You should see available space of the NAS if all worked properly.

    Then perform these steps:
    [code]chmod -R 777 /images
    mkdir /images/dev
    touch /images/.mntcheck
    touch /images/dev/.mntcheck[/code]

    Hopefully all works great for you.

    Thanks,



  • The symbolic link to a mount point seems to be easier !
    I have at my disposal a NAS server and to stock images, it would be the ideal …

    So, in /etc/fstab, I wrote:

    /images NAS-IP/images auto bind,defaults 0 0

    In some errors near, did I understand principle of symbolic link ?


  • Senior Developer

    Expanding the Drive’s capacity “might” work, but it’s no guarantee. If it’s a base install of Ubuntu, typically the expansion would go to /home not /images, unless you know how to extend that particular partition.

    If you have a network file share (NFS) somewhere that you can mount/generate in place of /images, all you’d need to do is mount it in your /etc/fstab. Or you can do the symbolic link.

    I do mine in a two step method, for security and obscurity.

    First, i mount my share as /somethingrandomImadeup

    Then I link /somethingrandomImadeup to /images.

    Verify the permissions are good and I’m off and away.


  • Developer

    This post is deleted!


  • Folder /images is on a virtual machine; maybe I can change hard drive’s capacity ?
    If not, how create a symbolic link to a mount point ?


  • Senior Developer

    Correct.

    Your /images only has 323 Megabytes available. The image you’re trying to get is probably many times LARGER than the available space, so it writes until there’s no more room on the device, but it can’t move the file.

    You may need to use a symbolic link to a mount point that has much more space available for this to work.



  • I ever did this command:
    drwxrwxrwx 4 1000 0 1024 févr. 12 09:40 images.

    I changed my password with success.
    Hum, it’s a question I ask me …
    This is the command’s result:
    Sys. fich. : /dev/disk/by-uuid/7e4aba7b-9902-4068-9740-4ec3e2a90430
    Capacity: 323M
    Used : 197M
    Available: 110M
    Used%: 65%
    Mount on: /
    It isn’t enough, isn’t it ?


Log in to reply
 

443
Online

38953
Users

10706
Topics

101571
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.