MBR on dual boot system



  • hi guys,

    I have been testing Fog for some days, and it works very well …
    Almost do what I want, but I’ll try to make it do all I want!

    My current problem is the following:

    • PC with 4 primary partition (2 windows 7, 1 swp, 1 Ubuntu 11.10)
    • I upload the image (1 disk, multipartition)
    • I deploy the image on a new PC
    • The images are correctly deployed but the system does not boot
      (I boot from a linux live, do a grub-install, and all is OK - Windows and Linux boots correctly)

    I imagine that FOG do not deploy the MBR: do I need to say it something particular to deploy the MBR too?
    Shouldn’t it deploy by default?
    And by the way, how do you troubleshoot this: FOG as a log management system to verify which operations were accomplished?

    thanks
    giammy



  • So, doing a sector-by-sector worked perfectly. However, it did take 10.5 hours to deploy the image. Being as I need to deploy this same image to 25 other laptops, this method would be pretty painful. Going to try some more testing with multi-partition, single disk today.



  • Hrm. I’m having the same issue with a multi-boot using CentOS (grub 0.97). Although, I don’t get the errors during boot. The system just sits there with a blinking cursor. I’m attempting a sector-by-sector/raw deployment of the same system now to see if that does anything. Otherwise, I’m unsure as to why the MBR won’t deploy correctly. I’ll dig into the manual dd’ing if the raw image doesn’t work.



  • Great! Glad you got it working.



  • hi!

    the update is here:
    [url]http://www.fogproject.org/wiki/index.php?title=Client_Setup#Dual_boot_Images[/url]

    It’s working: the problem was with GRUB (I installed grub-legacy instead of grub2 :-(

    bye
    giammy



  • Hi,

    an update on my tests (dual boot, Windows 7 partition 1&2, Linux Ubuntu, partition 4 swap in partition 3, all primary partitions).

    Defining my system OS as Windows & copy from the original a 512 byte MBR, and correctly deploy it (I diffed the original system with the deployed one and they are equal).

    Grub says “Invalid partition” and gives me the grub restore prompt.

    Declaring my system OS as Linux, create a 32256 MBR and deploys correctly, but the system keeps rebooting :-(

    So, my conclusions up to now are:

    • fog correctly copy and deploy the MBR (of different sizes … I haven’t understood this…)
    • looking at the script /bin/fog which do all the work, I see that there are various commands
      to create partition and set up the disk: these commands are selected based on the OS I select
      (Win7 or Linux), so all my partition are treated as linux partition or Windows partition
      (this is my hypotesys)

    Probably in a dual boot system I should fix this part, but at the moment I do not have idea on how to proceed :-(

    that’s all by now
    giammy



  • What happens if you do a deploy-debug and then manually dd the d1.mbr to the hdd? Does that work okay?



  • Hi guys,

    I update you with my discoveries :-)
    The upload part of a working dual boot installation image uploads both the partitions and the MBR, calling it d1.mbr.
    Doing a diff from my installation MBR and the d1.mbr file, shows that the files are identical, so the upload image works
    correctly.

    Looking at the source, if the image type is “mps” (multiple partition, I think, and my image is 1 disk, multiple partition),
    the scripts look for a file called d1.mbr and dd it to the harddisk … so it should recover the exact mbr of my original installation!

    It’s not doing so (I setted the os type to Wndows 7, Linux and other … no success)

    Perhaps there’s some option which enables that part of code for the recovering of the MBR?

    thanks
    giammy



  • I have imaged both Windows and Linux systems with FOG and they both work fine but have never tried a dual boot system. FOG does backup and replace the MBR but I believe it determines the type based on which OS you told FOG you are imaging. You probably would want to tell your image that it is a linux image in FOG due to the fact that you are using grub boot mgr.

    I always used the debug options when trying to troubleshoot imaging but I am unsure of whether there are logs created that would be helpful.


Log in to reply
 

444
Online

39174
Users

10821
Topics

102951
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.