Unable to determine best node for transfer



  • Hello everybody,

    First, I will ask you to be lenient with me and my english because I’m a french student …
    So I’m in course training in a University and I have to make a FOG server to deploy system image in computer room.

    All is right until today where I meet a problem: my pxe boot is good, I made a task on my FOG server and on the screen of my client, I have this error message: "Cheking Queue … Done
    Using Storage Node … TFTP
    Mounting File System …Failed

    mount: RPC: Remote system error - Connection refused
    mount: mounting 127.0.0.1:/images on /images failed: Bad file descrption

    Cheking Queue … Done
    Unable to determine best node for transfer !

    Storage node: TFTP is open, but has recently failed.
    Unable to determine best node for transfer !"

    My differents config files:

    /etc/exports:
    "/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)"

    /var/lib/fog/commons/config.php:
    "define( “STORAGE_FTP_USERNAME”, “fog” );
    define( “STORAGE_FTP_PASSWORD”, “root” );
    define( “STORAGE_DATADIR”, “/images/” );
    define( “STORAGE_DATADIR_UPLOAD”, “/images/dev/” );"
    define( “MYSQL_HOST”, “localhost” );
    define( “MYSQL_DATABASE”, “fog” );
    define( “MYSQL_USERNAME”, “root” );
    define( “MYSQL_PASSWORD”, “root” );

    My config on FOG server:

    Storage Management:
    “Storage Node Name: TFTP
    IP Address 127.0.0.1
    Is Master Node check
    Storage Group default
    Image location /images/
    Is enabled check
    Management username fog
    Management password root”

    Fog Settings, FOG Storage Nodes:
    "FOG_storagenode_mysqluser root
    FOG_storagenode_mysqlpass root"
    FOG settings, FOG TFTP server:
    FOG_TFTP_HOST 193.52.239.23
    FOG_TFTP_FTP_USERNAME fog
    FOG_TFTP_FTP_PASSWORD root
    FOG_TFTP_PXE_CONFIG_DIR /tftpboot/pxelinux.cfg/
    FOG_TFTP_PXE_KERNEL_DIR /tftpboot/fog/kernel/
    FOG_TFTP_PXE_KERNEL fog/kernel/bzImage
    FOG_KERNEL_RAMDISK_SIZE 127000
    FOG_PXE_BOOT_IMAGE fog/images/init.gz
    FOG_PXE_IMAGE_DNSADDRESS 193.52.239.1
    Thanks for every helps you could bring me



  • Thank you Tom, this problem was solved ! :D

    But I meet a new problem:
    “An error has been detected !
    Unable to locate image file for Windows 7! (sys.img.000)
    Computer will reboot in 1minute.”


  • Senior Developer

    Aha I think I see your issue directly now.

    Your STORAGE IP should [b]NOT[/b] be 127.0.0.1.

    In networking 127.0.0.1 is the localhost. How can you load an NFS on your self when you don’t have a Storage Node?

    To to the WEB GUI

    Choose Storage Management->All Storage Nodes-> Your Storage node.

    Change the IP of the storage node from:
    127.0.0.1

    To:
    193.52.239.23


Log in to reply
 

394
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.