FOG on isolated network



  • I am trying to install FOG on isolated network as described here:
    [url]http://www.fogproject.org/wiki/index.php/FOG_on_an_Isolated_Network[/url]

    I’m not allowed to have FOG’s PXE advertise DHCP inside my lan, so I figured I’d install it and cut the cord. However, instructions state that FOG needs to be connected to the internet during installation. So, I start the install while I’m connected to the network and when it reaches DHCP step - it fails. Not sure why, either becuase I’m entering FOG’s IP as 192.168.1.1, even though during installation time it is different and DHCP attempts to configure with current IP maybe? I then tried pausing installation script before DHCP step, disconnecting and manually reconfiguring my network to static 192.168.1.1 - that helped, but installation isn’t working (getting blank screen when first trying to connect to initialize database schema screen.

    Has anybody attempted anything like this? What’s the procedure?

    Also, there is a way to do what I’m trying to do via “non-intrusive” DHCP on existing network:
    [url]http://www.fogproject.org/wiki/index.php/Integrating_FOG_into_an_Existing_Network_in_non_intrusive_mode[/url]

    I understand how DHCP will only offer leases to requests which came from pre-defined MACs, however, how can I make sure those requests won’t be fulfilled quicker by our corp DCHP servers/PXEs ?


  • Senior Developer

    If you’re not allowed to have a router, but you are allowed to have a switch that you can connect your clients and the FOG server to, dhcp from the FOG Server will still work.

    The web gui should be accessible in one of two ways. As long as httpd/apache services are running, you can access the web gui by the IP address of the fog server (e.g. [url]http://192.168.1.10/fog[/url]) or by using localhost address (e.g. [url]http://127.0.0.1/fog[/url] OR [url]http://localhost/fog[/url])

    Another avenue, if your network guys will allow it, is to setup proxyDHCP. This way you don’t have to change any of the network currently setup and you wouldn’t need, if I understand it correctly, to install dhcp server on the FOG server.
    [url]http://www.fogproject.org/wiki/index.php/Setting_up_ProxyDHCP[/url]

    Basically what ProxyDHCP does is listen for clients trying PXE and if it hears a request, it sends the client the information necessary to PXE Boot without having to modify the network at all. No options 66/67, no router, no dhcp server, etc… Which sounds to me like the case you’re running into here.



  • Hi Tom,

    Thanks for your response!

    I’m not allowed to setup DHCP on FOG, so I need to be isolated. I’m following instructions outlined in the doc on how to do so (first URL in my original post), defining 192.168… IP during setup but installation fails at DHCP step. configureDCHP call attempts to configure/start DHCP and fails. Probably because I’m still on the corp net. If I tweak install script to pause before configureDHCP, allowing me disconnect from the network before proceeding - it completes, but then web console doesn’t come up.

    I thought about the router, but network security isn’t allowing those either… I might end up taking the entire setup outside and do it elsewhere… can’t think of any other way… But wondering if anybody successfully completed setup on isolated network as per documentation. Curious why it’s not working for me.


  • Senior Developer

    I guess I’m confused.

    PXE is different from DHCP.

    I’m assuming you’re saying that You’re not allowed to have FOG distribute DHCP across your network? You’re also not being allowed to use PXE on your network?

    Then you’ll need to isolate the network as you already started doing, maybe use a different router to do DHCP handling within your isolated network?

    If you don’t have a router, you can install a DHCP server on FOG. As long as you’re allowed to use the internet to install the packages. As you are going to be isolating the network, make sure when you’re setting up the server IP information that it’s set to what you’re going to be using, not the network you’re currently on, otherwise you might start seeing issues.


Log in to reply
 

406
Online

38993
Users

10713
Topics

101700
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.