Dell Vostro 5470



  • Hi,

    I was trying to use fog 0.32 with kernel 2.6.39 (default) on Dell Vostro 5470, but it was hanging in this error: “nvidiafb: unable to setup MTRR”

    After some tests, I got it works fine with kernel 2.6.35.7 PS

    Anyone could update HW List on Wiki?



  • Hello!

    No, I’m using FOG 1.1.2, but i did upgrade from 0.32.


  • Senior Developer

    I’m sorry, I forget you’re using FOG 0.32?



  • It didn’t worked with the default kernel.
    I guess this will be specific with Dell Vostro 5470. (the kernel part)


  • Senior Developer

    To be honest I don’t think you even needed to change your kernel



  • Good to know. Thanks guys. I’ll put some information here, so I think you can lock this thread.

    Situation: Dell Vostro 5470 was unable to send image to FOG server after full wipe and Windows 7 reinstalled.

    Current config:

    • Fog Version: 1.1.2
    • Image Settings:
      • Windows 7
      • Multiple Partitions Image - Single Disk (Not resizable)
    • Kernel: default from install

    Common messages:
    [CODE]Preparing backup location - DONE
    Looking for hard disks - DONE
    Using hard disk /dev/sda

    udevd[1986]: inotify_add_watch(6, /dev/sda2, 10) failed: No such file or directory
    udevd[1985]: inotify_add_watch(6, /dev/sda1, 10) failed: No such file or directory[/CODE]

    Problem: Windows Partition from Windows 7 DVD doesn’t wipe the disk properly. There is a GPT partition causing problems.
    Problem found using:
    [CODE]gdisk -l /dev/sda[/CODE]

    FIXING:

    [CODE]su -
    cd /var/www/html/fog/service/ipxe/
    wget http://downloads.sourceforge.net/project/freeghost/Kernels/Kernel-3.14.2.TomElliott/Kernel.TomElliott.3.14.2.64
    mv Kernel.TomElliott.3.14.2.64 dell5470
    [/CODE]

    • Access FOG Server via WEB
    • Edit HOST (alredy registered)
    • Change HOST KERNEL to dell5470
    • Still in hosts, go to BASIC TASK, Advanced, DEBUG
    • Start the network boot on this host

    In debug mode:
    [CODE]fixparts /dev/sda
    y
    w
    y
    [/CODE]

    • Insert new UPLOAD task on the host (make sure to remove the DEBUG task).
    • Reboot, upload image

    You can make a backup of the bzImage and make the new kernel default

    [CODE]cp bzImage bzImageBKP
    cp dell5470 bzImage[/CODE]


  • Developer

    yeah, that doesn’t wipe everything.



  • I used the partition manager from Windows Install Disk. Wiped everything. The disk was clear. Then created 1 partition to Windows (and he automatically created that 100mb partition). Thats all.


  • Developer

    i would guess that whatever method you used to re-partition didn’t wipe the boot sector, where the GPT/MBR information is stored



  • Yes!! It worked!!
    Thanks TOM and JAYMES! I owe you guys a BBQ whenever you guys come to Brazil!

    Just to know, that was being caused by that GPT partition? And why? I don’t want to do the same mistake.
    I dont remember anything related to GTP partition during the instalation or any step of the process.


  • Senior Developer

    Run these commands:
    [code]fixparts /dev/sda
    w[/code]

    Follow thru with the rest of the code, cancel the debug code and regenerate your upload task. Reboot the client and it should upload properly.



  • gdisk -l /dev/sda

    Found valid MBR and GPT. Witch do you want to use?

    Using MBR:
    2 partitions, one with 100mb, other with 465.7 Gb, both MICROSOFT BASIC DATA.

    Using GPT
    Using GPT and creating fresh protective MBR
    Disk /dev/sda: 976773168 sectors, 465.8 gb
    Logical sector size 512 bytes

    Nothing listed.


  • Senior Developer

    what is the output of:
    [code]gdisk -l /dev/sda[/code]



  • Boot with DEBUG mode:

    fdisk -l

    Device Boot Start End Blocks ID System
    /dev/sda1 * 2048 206847 102400 7 HPFS/NTFS/exFAT
    /dev/sda2 206848 976771071 488282112 7 HPFS/NTFS/exFAT



  • Just tried with latest kernel:

    Preparing backup location - DONE
    Looking for hard disks - DONE
    Using hard disk /dev/sda

    udevd[1986]: inotify_add_watch(6, /dev/sda2, 10) failed: No such file or directory
    udevd[1985]: inotify_add_watch(6, /dev/sda1, 10) failed: No such file or directory



  • Hello Jaymes!

    1st of all, thanks for the ridiculous fast reply. really appreciated. ;)
    2nd: I’ve already formated all partitions and installed a brand new Windows. it only has 2 partitions (that 100mb crap that windows generates, and the other partition wich windows is installed.).

    i was able to do a FOG Image when the disk had Windows 8.1 installed.
    My problem is with this windows 7. I did everything from scratch 5 times now.

    With 2.6.35.7 PS Kernel, i got a Kernel Panic when booting.
    And with other Kernels, it just doesnt work (sometimes appears kernel panic, sometimes “no chip?”


  • Developer

    The guide I posted doesn’t care what version of FOG you are using.



  • Oh, I’m using the last version of FOG (1.1.2)


  • Developer

    [quote=“Felipo, post: 33305, member: 25115”]Hello everyone!

    I’m trying everything that i’ve found on the web, but i cant make the Dell Vostro 5470 work with FOG when instaled with Windows 7.

    With the default kernel, goes to the “usind disk /dev/sda1” and then stop. when you hit “enter”, it says “unable to find partition” and reboots.

    Already tried a few different types of Image on fog server and i’ve tried those kernels (both of this topic). unlucky so far.

    any more tips?
    thanks![/quote]

    Give this a shot and try to image the machine again.

    You need a partition on the disk before you try to clone anything to it.

    [url]http://fogproject.org/forum/threads/quick-format-to-ntfs-with-fog-for-noobs.10349/[/url]



  • Hello everyone!

    I’m trying everything that i’ve found on the web, but i cant make the Dell Vostro 5470 work with FOG when instaled with Windows 7.

    With the default kernel, goes to the “usind disk /dev/sda1” and then stop. when you hit “enter”, it says “unable to find partition” and reboots.

    Already tried a few different types of Image on fog server and i’ve tried those kernels (both of this topic). unlucky so far.

    any more tips?
    thanks!


Log in to reply
 

347
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.