Can't search client list



  • I am working at integrating FOG into my network. I have been running FOG on a laptop and imaging separately. I created the new server (Ubuntu 13.10) and installed FOG. I then exported the clients from the database on my old server and imported them into new server. If I select “list all hosts”, It displays all the hosts imported however if I try to search specifically for one machine it tells me “Error searching, please try again…”



  • I just recently started completely over from scratch because of something else I broke. I installed a fresh copy of Ubuntu 13.10 and downloaded the latest version of FOG. I got it up and running, made no changes and went straight into nodes. I created a node and then tried to search and go the same result. I am still able to list all nodes but not search for one individually. Is there a problem with one of the packages and Ubuntu 13.10?



  • Here are the answers to the posts since I was on last.

    -PHP 5.5.3
    -I found and removed &$tmp from /var/www/fog/management/includes/tasks.confirm.include.php which resolved, before this issue, a problem creating tasks.
    -Yes, I am using Firefox
    -I am able to connect to my old FOG server and perform a search without problems.


  • Senior Developer

    That’s what’s making me wonder. Though it appears information is going to the proper place, it’s not translating appropriately. It’s more than possible javascript is disabled on that system.

    The question is, does this happen on every system AND browser, or just this one system?


  • Moderator

    And I’d be willing to do a teamviewer type session to look at your setup sometime.


  • Moderator

    Oh yeah, I see that now. I forgot how to scroll :D

    Could this be an ajax type problem on the client side rather than an error on the server side?


  • Senior Developer

    Looks like firefox to me. :) Gecko/20100101 Firefox/26.0


  • Moderator

    What browser and version are you using (Chrome, Sarfari, Firefox, IE, Opera, etc)?


  • Senior Developer

    Whats the version of php that you’re using?

    If it’s > than 5.3, chances are this is your issue.

    Try searching and removing anything referencing &$tmp and remove the &.



  • only thing in apache log is:
    [CODE]10.10.1.68 - - [29/Jan/2014:14:55:45 -0700] “GET /fog/management/ajax/host.search.php?crit=test&_=1391032548832 HTTP/1.1” 500 342 “http://10.10.1.101/fog/management/index.php?node=host&sub=newsearch” “Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0”[/CODE]

    The only thing I am seeing in dev tools is that it is throwing ‘ERROR_SEARCHING’ but don’t see why.

    I have completely removed FOG and the MYSQL database and did a fresh install without any modification or imports and still getting the same problem.


  • Moderator

    check your apache log to see if you are getting a php error. turn on your developer tools in your browser to see if you are getting a javascript/ajax type error also.



  • Yes, when I cleared the table I created a new host entry and search for the host name I entered.


  • Senior Developer

    And you’re sure, what you’re searching for, is actually in the table?



  • I cleared the host table, added a new test host and tried to search and still have the same result.


  • Senior Developer

    I haven’t a clue as to where to begin looking.



  • It appears that the search function is not working correctly being that the necessary fields are populated and also my test of a new import. Is there somewhere else I can be looking?



  • Searching through the host db it appears that it did successfully import the identifier fields.



  • just to test it, I deleted a host and then went through the procedure to register the host and I get the same result searching for the newly registered machine.


  • Senior Developer

    When you’re searching it’s attempting to find the reference data in the images, inventory, and hostOS field. If those fields are blank, I’d imaging it would be rather tough to find all that data.

    You could attempt a manual search to see if you find any data.

    Look in the file {fogwebdir}/lib/HostManager.class.php for the search function. It will display the sql you need to test first.



  • I only imported the hosts so ImageID is missing. OSID, Hostname, MAC are there. Hardware info is not.


Log in to reply
 

459
Online

38957
Users

10706
Topics

101581
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.