Task won't start, unable to connect to tftp server

  • New Fog 0.32 install on Centos 6.5. When I attempt to initiate an upload task, I get the following error:

    [CENTER][SIZE=16px][FONT=Ubuntu][COLOR=#333333]Unable to start task[/COLOR][/FONT][/SIZE][/CENTER]
    [CENTER][SIZE=16px][FONT=Ubuntu][COLOR=#333333]Unable to connect to tftp server[/COLOR][/FONT][/SIZE][/CENTER]

  • Apparently, had not re run installfog.sh after starting nfs. Tried that first and the error. So, I ran the commands above and still get the error. Just in case, I did re set the password for the Fog user to match the Fog settings in the gui. Also checked permissions of /tftpboot and it is 0755 and the owner is Fog.

  • That’s possible, though I don’t know why. If you still have the fog installer file (fog_0.32.tar.gz) run these commands to get tftpboot back:

    [code]cd /opt
    wget http://sourceforge.net/projects/freeghost/files/latest/download?source=files
    tar -xzf fog_0.32.tar.gz
    cd fog_0.32
    cp -r packages/tftp /tftpboot
    chown -R fog:root /tftpboot
    cd /opt
    rm -rf fog_0.32[/code]

    That should give you back the tftpboot folder and apply the proper permissions. However, did you rerun the installer after getting NFS to work? If you didn’t your install may not be complete.

  • AHA! There is no /TFTPBOOT. Perhaps it did not get installed.

  • Check perms on /tftpboot. They should be fog:root recursive

  • OK, set password on the server, set the gui to match, saved changes and still get the same error.

  • no you set the password, and change it in the FOG GUI

  • Well, The user name in the field referenced above was fog and the password field was populated with a seemingly random combination of letters and numbers so, logged in as root, I did a passwd fog and pasted in the contents of the field from the fog server, but that does not help.

  • Check your username and password for the FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD under: FOG Configuration (? Icon) FOG Settings

    Make sure they are FOG User on the server, not the database user.

    On the FOG Server, login as root:

    [code]passwd fog[/code]

    Enter the password, then enter in the confirmation of the password.

    Then Update these two settings and try setting up your upload task and try again.