Fog server multicast issue



  • I setup fog server for multicast support and i already modified it to bypass host registration, everything look ok until i try to deploy multicast image to several PCs,

    After pxe boot and i enter multicast session name immediately i get this error

    • unable to determinate operating system type

    This image works if i restore it on a registered PC, but i want to deploy it to several PCs at one time without registration.

    Any ideas ?



  • [quote=“Tom Elliott, post: 21449, member: 7271”]Are you looking at multicast tasks or active tasks[/quote]

    clicking on
    group management -> list all group -> click on group name -> image association -> x
    group management -> list all group -> click on group name -> os association -> x
    group management -> list all group -> click on group name -> basic task -> deploy

    starts unicast imaging.

    task management -> list all group -> deploy multicast, but don’t work giving the error in first message of this thread


  • Senior Developer

    Are you looking at multicast tasks or active tasks



  • [quote=“Tom Elliott, post: 21443, member: 7271”]create a group of the hosts you’re trying to multicast to.

    Then go into that group and set the host OS. It will apply the setting to all of the hosts within that group from one simple location.[/quote]

    i already set host OS, and image for the group, but the multicast still don’t work…

    and 19 tasks is created, not 1.

    And in this way, first 10 pc images, others wait for open slot… and there are 10 different tcp transmission, not 1 for all 19, or 10 pc.

    2 years ago i used the broadcast function, with 0.32 and was working… so there are a new bug introduced?

    another suggestions?


  • Senior Developer

    This looks, to me, to be in file:

    /var/www/{fog,html/fog}/commons/functions.include.php

    Line 2744:
    [php]append initrd=" . getSetting( $conn, “FOG_PXE_BOOT_IMAGE” ) . " root=/dev/ram0 rw ramdisk_size=" . getSetting( $conn, “FOG_KE RNEL_RAMDISK_SIZE” ) . " ip=dhcp dns=" . getSetting($conn, “FOG_PXE_IMAGE_DNSADDRESS” ) . " type=down img=$image mc=yes port=" . $port . " storageip=" . $snIP . " storage=" . $snIP . “:” . $snRoot . " mac=" . $member->getMACColon() . " ftp=" . sloppyNameLookup(getSetting( $conn, “FOG_TFTP_HOST” )) . " web=" . sloppyNameLooku p(getSetting($conn, “FOG_WEB_HOST”)) . getSetting( $conn, “FOG_WEB_ROOT” ) . " osid=" . $member->getOSID() . " $mode $imgType $keymapapp shutdown=$shutdown logleve l=4 consoleblank=0 " . getSetting( $conn, “FOG_KERNEL_ARGS” ) . " " . $member->getKernelArgs() . " " . $otherargs;[/php]

    Look for the relevant part of this line:
    [php]
    " osid=" . $member->getOSID() . "
    [/php]

    Change to:
    [php]" osid=OSID OF OS YOU WANT[/php]



  • ok, well i appreciate your help. thanks


  • Senior Developer

    No, unless you find the configuration file and basically falsify the OSID. I think maybe on the creation of the pxe file (01-$MAC) file, set the osid manually.



  • I see, so i will have to register the hosts that i want to deploy the image to right? There isn’t another solution to bypass the host registration process for a multicast?


  • Senior Developer

    create a group of the hosts you’re trying to multicast to.

    Then go into that group and set the host OS. It will apply the setting to all of the hosts within that group from one simple location.



  • Is there anything that i can do in the meantime to mitigate this problem?


  • Senior Developer

    I’m guessing you’re using FOG 0.32?

    The reason it’s not working is because the OSID is not set for each of the hosts you’re trying to send it to. In multicast group jobs like this, needs to have the same OSID. This is why you see multicast deploy from the group menu. It creates one task. It sounds like it checks that all Hosts have the same Image ID, but it doesn’t check if the OSID is set.

    This will hopefully be fixed in 0.33 (not yet though, still working on it) as the OSID is actually set by the image rather than on a per host basis.


Log in to reply
 

444
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.