FOG Server Communications Issues



  • Today I got around to installing FOG on our test machine. It runs in a Debian 7.3 virtual machine (VMware Player) with the Host OS being Windows 7. The computer is networked to two other machines via a TrendNet TEW-731BR router. One runs Windows 7 and is intended to be used as a reference machine for uploading images and the second is a Windows XP machine I am hoping to image. This mini network is totally separate from the campus network and not connected to the internet. The install seemed to go well, but I suspect I did not do something correctly because the following issues have cropped up.

    1. At the log in screen in the box below the username and password fields, which says “Number of Fog sites and version number” both report an error connecting to the server. I dared to plug the computer into the campus network for a brief instant and the issue disappeared.

    2. After entering the two other computers as hosts in FOG, the program is unable to resolve the host names of either one. I used the name of the computers for this field. Adding exemptions, turning off the Windows firewall, and disabling the access protection feature of McAfee did little. The only development was that I was able to get the Windows 7 machine to go from “unable to resolve host name” to “host down” despite it being on. These are not domain machines, but I also added “search workgroup” to the resolv.conf file to no effect. And both can be pinged from the command prompt.

    3. My understanding is that when a computer is PXE booted from a FOG server some sort of splash screen comes up. It does not for either of the test machines although the FOG client is not installed on them.

    4. I am not able to connect to the server via Filezilla from the Windows XP machine. It seems to establish a connection, but does not get a “welcome message” and returns a connection error.

    My theory is that I did not set up DHCP correctly. Since the router is essentially a DHCP server in a box I did not install one during the FOG installation, but specified its IP address. Also I did not know what to put for the DNS address field since there is no DNS server (as far as I am aware - correct me if I am wrong) in the mini-network and left that field blank. And I accidently put the wrong IP address for the FOG server. During install the fact that VMware player is set to use NAT slipped my mind.

    Any help would be much appreciated.


  • Senior Developer

    Your default file (that’s the name sorry) is located at:
    /tftpboot/pxelinux.cfg/default

    On the bottom line you should see:
    [code]TIMEOUT 30[/code]
    This means 3 seconds. Thirty seconds would be:
    [code]TIMEOUT 300[/code]
    I



  • Thank you very much Tom. You have been a great help. The firewall thread will be very useful. So far only Firstarter on the server has caused issues. I don’t see the windows firewall (or McAfee) interfering with imaging since the OS is not even loaded during that process. But remote management (turning off, pushing programs, etc) may be another story. It is the Windows Firewall and McAfee we really can’t live without since most of our computers are open to the public. But the Fog server will sit quietly in a dark room and can conceivably be left without protection. On the subject of the Boot Menu, where is the timeout value set?


  • Senior Developer

    1. Ownership of /tftpboot should be:
      [code]sudo chmod -R 755 /tftpboot
      sudo chown -R fog:root /tftpboot[/code]

    2. It doesn’t like firewalls, but there’s a writeup somewhere firewall setup and FOG. Maybe try [url]http://fogproject.org/forum/threads/firewall-config.27/#post-16286[/url]

    3. No you shouldn’t have to. There should be a value for timeout after a number of seconds.



  • [SIZE=6]Success![/SIZE]
    [SIZE=3]Turns out the server was not able to find the correct file despite it being in the system under the directory tftpboot. Not sure why although Wirehark clued me into what was going on. So I made that the default tftp directory and voila! I was able to transfer the file to the XP machine and boot into the PXE menu on the Windows 7 machine. Tomorrow I will properly register that computer and try my first image upload. Before marking this thread solved I have a few final questions.[/SIZE]

    [SIZE=3]1. I had changed the owndership of the tftproot directory to be the default user and not root. Was this of any consequence and should I change it back?[/SIZE]

    [SIZE=3]2. FOG does not seem to like firewalls. Is there a way to make it coexist with them? We cannot possibly go without firewalls at the Library although the FOG server might be able to.[/SIZE]

    [SIZE=3]3. I’m not going to have to make a menu choice at the PXE boot menu every time the computer boots am I? Having to do so would seriously confuse our patrons and staff.[/SIZE]


  • Senior Developer

    Is the next-server line in your dhcp address pointing at your FOG Server?



  • Not only am I not seeing the PXE boot menu, but tasks cannot be scheduled via the web GUI. When I try the task management screen comes up, but is blank. Also tftp is not working. Windows 7 will not recognize the command “tftp x.x.x.x get pxelinux.0” where x.x.x.x is the server’s IP address, even when the command prompt is run as an administrator. Windows XP understands the command, but can’t find the file. I’m not sure if the error is with tftp or with fog itself, but it might explain why the PXE boot menu does not come up. I also tried using F12 to boot from the network card, but after it connected to the DHCP server, did something with tftp (those letters came up and nothing else), the boot agent exited and a message came up saying the boot agent was not available. Does any of this make sense to you Tom? Also, could the router be at fault? As in perhaps tftp requests are not being passed through even though its DHCP server is disabled.



  • Well tftp seems to be working correctly. It had been erroring out this morning with PXE-E32. Turns out the servers firewall was interfering with it. Also I installed the FOG client on the Windows 7 screen. Still no splash screen or menu. It connects to the DHCP server, tests tftp, and then boots. The ultimate test of FOG is to image a machine and so I will sysprep the computer and then attempt to upload an image.



  • First the service wasn’t running so it would not connect. Then I made the changes recommended here: [url]http://www.debian-administration.org/articles/478[/url] and started the service which was when it could not find the file. It seemed to connect to the server, but not find what it was looking for.


  • Senior Developer

    tftp command wasn’t found or it reported it couldn’t find the fog server?

    Maybe make sure tftpd-hpa service is running?
    [code]sudo service tftpd-hpa restart[/code]



  • Hmmm. When I was testing out tftp between the xp machine and the fog server I tried to “tftp <fog server IP> get pxelinux.0” but that was not found. Also Filezilla would not connect. Is it possible the computer is not booting correctly into FOG? Our computers are Dell Optiplex 780s, if it makes a difference. Tomorrow I will try to set up a task remotely and see if it works.


  • Senior Developer

    That sounds like normal behavior if you don’t chose a menu option AND you don’t have a task setup for the system that’s booting.



  • Not sure. Perhaps the PXE boot did’t work correctly? The computer was able to receive an IP address and after that I think the boot agent exited (PXE-M01 Intel Boot Agent Exiting) and Windows XP started. I assumed that was normal behavior. Where is the images file located?


  • Senior Developer

    Glad I could be of some help.

    The PXE Boot screen should be displayed. It shouldn’t matter if the client is or isn’t installed on the clients. The image is a part of the system. Though my guess is your default file can’t find the image file. Maybe antivirus removed it or something?



  • Indeed I did, Tom. Turns out the service was not actually started and there was a syntax error in the config file. Both computers have PXE booted successfully. The FOG splash screen did not come up, however, possibly because the client is not installed on them. Tomorrow I will endeavor to do that, register the computers in FOG and hopefully attempt to upload my first image. Once again thank you for your help.


  • Senior Developer

    I think you need:
    [code]sudo service isc-dhcp-server restart[/code]



  • Well I’ve got all of the computers talking to one another and initialized tftp, but problems persist. I cannot PXE boot either of the other two computers. When attempting to do so, the process errors out with the code PXE-E51 No DHCP or ProxyDHCP offers were received. Curiously when I type “service dhcp restart” in terminal on the FOG server it says that service is unrecognized. But I KNOW I installed it as the configuration file above shows. Any thoughts? Perhaps the DHCP server is not installed or configured properly?



  • Ok so it seems 3 out of the 4 issues in my original post weren’t really all that serious. All that remains is to do is fix the networking issue and check to make sure I can connect to the FOG server via ftp. Then the imaging test can begin.


  • Senior Developer

    The error’s you’re seeing are because your network’s not connected to the network.

    Just the same as if you try to go to the kernel updates page. You don’t have internet access so you won’t see any of the updates available.



  • Thank you for all of your help Tom. It seems I over thought the problem with the hostnames a bit. As for the config file, none of the computers have an IP address of 192.168.10.2. The router is 192.168.10.1 and all the rest are well above 10.10 .

    What about the two fields on the login page that return an error? Do you think those are related to the DHCP server or can I ignore them?


Log in to reply
 

397
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.