HELP!!!! Fog 0.32 is unable to Connect to tftp Server after updating ubuntu to 12.04 LTS



  • Hi all,

    I am in desperate need of help to get my Fog server up and running, What my dumb**s did was I updated Ubuntu from 10 to 12.04 LTS. After the update I am no longer able to pull, push or queue a image, I keep getting the message “Unable to connect to TFTP Server.” I did find the current links and tried most of the tricks out there to get it working including. Updating the password for the fog useraccount in the Webui and in config.php found in /var/www/fog/commons. I also restart the tftp-hpa. Any help with this would be much appreciated.



  • Hi Tom,

    I wanted to give you an update on my issue… I was able to get the server back up and running by re-running the installation, as it may have seemed that I was missing some of the proper software on Ubuntu 12.04 for Fog to run properly. After re-running the installation all I had to do then was edit config.php with the proper mysql password and now get back to imaging all my machines now.

    Stay Warm, as where i am located, HELL as frozen over in ND at -26 degrees (without wind chill of course.)


  • Senior Developer

    That most definitely would be your issue.

    Check that your mysql server is running. Try:
    [code]sudo service mysql restart[/code]



  • I was looking around on my fog server and found this in the log:

    [COLOR=#333333][01-03-14 2:51:06 pm] | [01-03-14 2:51:06 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:51:16 pm] | [01-03-14 2:51:16 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:51:26 pm] | [01-03-14 2:51:26 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:51:36 pm] | [01-03-14 2:51:36 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:51:46 pm] | [01-03-14 2:51:46 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:51:56 pm] | [01-03-14 2:51:56 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:52:06 pm] | [01-03-14 2:52:06 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:52:16 pm] | [01-03-14 2:52:16 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:52:26 pm] | [01-03-14 2:52:26 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:52:36 pm] | [01-03-14 2:52:36 pm] Failed to connect to database server, will try again in next iteration.
    [01-03-14 2:52:46 pm] | [01-03-14 2:52:46 pm] Failed to connect to database server, will try again in next iteration.[/COLOR]
    [COLOR=#333333] [/COLOR]
    [COLOR=#333333]Just wondering if this is related, to my issue[/COLOR]



  • Thanks for the response Tom,

    Ok my results so far,

    Did a test tftp of pxelinux.0 and was successful at getting the file, I also did an update/upgrade, restarted the server, restarted the tftpd-hpa service, and disabled the firewall all wioth no hope in site. :mad:

    BTW I know what you are talking about with having to clear driveways as I live in Fargo ND with -10 for a high and high winds that love to cover your driveway after you shoveled. DARN MOTHER NATURE!!


  • Senior Developer

    With the FOG password changes, can you actually attempt to get the pxelinux.0 file using tftp command?

    Open a terminal
    In the terminal type
    [code]tftp -m binary 10.0.7.1 -c get pxelinux.0[/code]

    Then check if you recieved the file: (If you received, normally you won’t get any return message.)
    [code]ls |grep pxe[/code]

    Hopefully you do receive the file and we can troubleshoot further. If not, have you performed all the updates:

    [code]sudo apt-get update; sudo apt-get upgrade[/code]

    Then reboot the server; once it’s back running, you may need to restart the tftpd-hpa service: (Forgive me if the syntax is wrong)
    [code]sudo service tftpd-hpa restart[/code]

    Then check/ensure firewall is disabled. I don’t think ubuntu uses selinux, but I could be wrong.

    [code]sudo ufw disable[/code]

    Then verify the firewall is not running with:
    [code] sudo iptables -L -n[/code]

    You should receive three lines of text looking similar to:
    [code]Chain INPUT (policy ACCEPT)
    target prot opt source destination

    Chain FORWARD (policy ACCEPT)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination[/code]

    Hopefully all is well and things actually work.


  • Senior Developer

    It may be a minute before I catch right up. I live in upstate NY and have to unbury driveways.



  • Hi Tom,
    Thanks for the quick Reply, I did what you asked with the chown of tftpboot, starting the tftp-hpa service and disabling the firewall with no success so far. I am willing to backup my Fog host machine info and images and re-installing fog, if it will help.


  • Senior Developer

    Check the permissions on /tftpboot. They should be set as:
    [code]chown -R fog:root /tftpboot[/code]

    Next, verify, as you stated, that the tftp-hpa service is started and running properly.

    After you know tftp service is running, check that firewalls are disabled.


Log in to reply
 

359
Online

39.5k
Users

11.1k
Topics

105.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.