• I cannot upload an image from the web gui anymore.
    When I press the upload icon of a host from the task management I’m presented to the folowing error:
    [CENTER][B]Unable to start task[/B][/CENTER]
    [CENTER][B]Unable to upload file.[/B][/CENTER]
    I’d tried the suggestion
    chown -R fog:root /tftpboot
    from the following thread: [url]http://fogproject.org/forum/threads/uploak-tak-failed-unable-to-start-task-unable-to-upload-file.80/[/url], but is no go[B].[/B]
    [B][/B]As stated in this thread: [url]http://fogproject.org/forum/threads/unable-to-upload-file.4225/[/url]
    I’d verified that is everything ok in the server:
    an ftp client can retrieve pxelinux.0 and everything else under my images directory (/images) it can also write in that directory
    Log files didnt mention nothing btw.[B][/B]Reinstalling over the current install didnt solve the issue neither.

    I’m running fog .32 on ubuntu server.
    Does anybody have some other idea on how to solve this problem?[B][/B]Is there some other way to upload an image?[B][/B]

  • That’s because of the two methods in use.

    Tftp doesn’t use relative paths to locate the files, but the kernel and boot image consider the actual tftpboot directory (on it’s own) as the root of the file system. They’re not relative technically.

  • Thanks! It is solved.
    the issue was that i’d set both FOG_TFTP_PXE_CONFIG_DIR and FOG_TFTP_PXE_KERNEL_DIR to their relative paths instead the full one. Thats odd since FOG_TFTP_PXE_KERNEL and FOG_PXE_BOOT_IMAGE need the relative paths not the full path.

  • The upload of the file by means of ftp is not using receiving files in /images.

    The location the file needs to write the task to is at: /tftpboot/pxelinux.cfg/

    The reason anything can read/write to the /images directory is it’s default ownership permissions are 777 or in lehman’s it has full read, write, execute to everybody.

    Check your fog settings FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD are set correctly for your server. Also verify that FOG_TFTP_HOST and FOG_TFTP_PXE_CONFIG_DIR are correct as well.

    The upload error it’s giving you during task creation is that it can’t send the server the pxe file generated for the task. Because this is using the PXE settings, these should be the only fields you have to worry about.

    Hopefully this helps.