ClamAV help



  • I have done the work around to get the client to reference the fog server’s clamav’s database items. However, when the file gets about 70-80% downloaded it get the following error.

    getfile: Can’t write 1448 bytes to /usr/share/clamav/clamav-a712…
    Can’t download main.cvd from my.fog.server.ip



  • go to the end of this post,
    [url]http://fogproject.org/forum/threads/clam-av-scans-not-working.308/page-2[/url]
    this what help me to understand



  • Hi Tom, Hi Madmax,
    first of all i would like thanks FOG for invite me to the world of LINUX,
    I’m so grateful to learn so much from this amazing system!

    i want to join to this issue because the process of updating clamav stuck at the same point like Madmax
    if you can explain what file needs to be edited inside the init.gz for creating the mount the folder that include the updates files in my Linux …

    FOUND!!! :):)
    after mount the init file go to the etc/fog.av file and edit its line when you can see "size=50m"
    change it to 100m it will be enough for updating clamav with the latest signature

    thanks in advanced
    Nir



  • Tom,

    I’m editing the exports file now, however i’m not familiar with the language. I’ve just copied the *(rw,sync,no_wdelay,no_root_squash,insecure) from /images/dev

    I’m also not familiar with writing or editing the scripts as of right now. how would i go about doing that?

    Ill play with this and see if i can to work. This is for a final project due next week so if i can’t get this to work then i probably won’t be working on it much afterwards.

    Thank you for all your help.


  • Senior Developer

    No,

    Ram isn’t necessarily the issue in and of itself. It’s file space. What I’ve done to circumvent this is to forcibly mount my /usr/share/clamav directory from my fog server’s file system. In my case, it’s just a blank file, but as you’ve already stated you’re trying to use the FOG Server’s clamav database, maybe you can adjust your mounts to mount the folder directly.

    The way you’d do this is to edit your /etc/exports file and add your clamav database directory to the system. Then adjust the init.gz scripts to mount the folder on the client as /usr/share/clamav. Then you shouldn’t have to download any files as they’ll be mounted to the system. I’m currently trying to tweak the init.gz to play with partclone. While I’m doing this, I’ll take a look at the fog.av script to see how I can best approach this and try to report back. It’ll probably be a little bit as I have work to do as well. I hope this is feasible for you.



  • Still running into that same error, if my fog server only has 2 gb of ram could that be a problem?


  • Senior Developer

    FOG Configuration (Other Information)->FOG Settings->FOG_KERNEL_RAMDISK_SIZE



  • How do i do that?

    Thanks for the reply Tom


  • Senior Developer

    Increase your memory size from 127000 to maybe 250000


Log in to reply
 

452
Online

38927
Users

10692
Topics

101463
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.