Some images not showing up in "webfog", but they are located in /images

  • Hi!

    I am running Fog 0.32 on Centos 6.4
    I copied over my image files from my old fog server to this new one.
    I have also uploaded some images.

    the strange thing is, some of the images are not showing up in fog in webbrowser, while some of them do.
    If I for example try to register host, I can choose the exact same images as listed in webbrowser.

    if I go ls -l /images, I can see that some images have drwxrwxrwx, and some has drwx, and some has rwx

    but, two of my images has drwxrwxrwx, but only one is showing up in webbrowser.
    What must I do to list all my images?


  • That’s a possibility, but I think the best option for you is to chmod the /images folder.

    Normal ownership of the entire folder is:


    If you run as root user [code]chmod -R 777 /images[/code] it should work.

    There is one other thing to be aware of is that the way the files move from /images/dev to /images is through ftp.

    Make sure your GUI has the appropriate username and password under both of these options:

    Storage Management->All Storage Nodes->{YOUR STORAGE NODE (usually DefaultMember)->Management Username and Management Password
    Other Information->FOG Settings-> FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD

    The username should be set as fog

    The password should be set on the fog server as root user with:
    [code]passwd fog[/code]

    Then whatever password you set is inserted into the password fields.

  • I solved it. I did what you said, but now I have another problem, which I think I have the solution to, but I dont have the time to test it right now.
    You see, I wanted to update one of my images, so I downloaded it, updated it, and tried to upload it again, to the same image.
    But it didnt work, but I think this is the solution; when I imported my images from the old fogserver, I was logged inn as root.
    That means root is the owner of the files, so fog doesnt have the rights to change/delete it. If I delete the files from root, log in as fog user, and import the images, will that fix the problem?

  • It sounds like the image association hasn’t been imported into the database.

    All you should have to do is create a new image. Make sure the file path is the same name as what you see. Then you should be set.