Dhcp option 066 067



  • I want to use server 2012 as my DHCP. FOG is doing the rest for the PXE. So, what are the entries for the windows DHCP 066, and 067?
    066 is ‘tftp boot server hostname’ I’ve entered the ip of my FO, does that sound right?
    067 is ‘bootfile name’ What do I need here? is this ‘/tftpboot/pxelinux.cfg/default’ ???

    This mix and match of *nix, windows always drives me nuts. Semantics, terminology whatever. next-server, router
    let’s get on the same page here.
    Would be more simple to just do it all in FOG but I guess the 2012 is supposed to be DHCP and DC


  • Banned

    This post is deleted!

  • Senior Developer

    So I take it it is working beautifully with FOG as the dhcp server?



  • Another beautiful day. Cut out the microsoft dhcp and run with FOG alone.
    Booting from network straight away :)
    Now we can start adding to the the boot menu



  • IDK, this may be crazy because the 2012 is a vm and the FOG is a vm of hyper-v. And hyper-v uses .44 as a vSwitch that’s linked to physical adapter.
    This is all brand new built by me, first time seeing how hyper-v associates a virtual adapter with a physical one. Also, this hyper-v will NAT .44 adapter traffic to another adapter with a route-able address.
    Not sure of what’s going on. I hate to waste hours digging through it.
    Overall the FOG and it’s web admin page look like they can simplify the process of PXE.
    Time will tell. I’m probably about 3-4wk away from putting this into action on a totally different schema. I was hoping to get my feet wet today.
    I’m cooling off now and admittedly less pissed than if I had tried build a PXE system, sort through config files and protocols from scratch.
    I would say I’m impressed with FOG but haven’t gotten that far yet ;)
    Thanks for your advice


  • Senior Developer

    You shouldn’t need to do that.

    Where I work, we’re using (Granted 2008) Windows Server for DHCP and FOG for PXE Boot.

    Our DHCP Options for 66 and 67 just point to our FOG server and all works perfectly fine.

    We even use Subnet’s through the assistance of iphelper on our switches.

    The -i, in linux, just ensures binary transfer of the file. I don’t think you need it from Windows, but I don’t know.

    Maybe Windows Firewall isn’t passing the items?

    We don’t use DHCP on the FOG Server at all. If you want to do this, you most certainly can.

    I’m sorry I’m not the greatest of help in this.



  • I’m so goddamn pissed at this PXE system all together. They keep on telling me this is the way to do things. And here FOG comes to make the process easier.
    In the past I’ve wasted weeks building this PXE system from scratch. Now I’m in for a full day with FOG and at a wall. Probably would have worked better if windows weren’t in the mix.
    I was hoping this FOG was the ‘easy’ solution to it all.
    I believe I will reinstall all this from jump and use FOG for dhcp too. Then, when ever I need to PXE boot anything I will just turn on/off DHCP on the 2012 or FOG to suit the situation.

    I’ll repost here with my accolades once FOG is PXE booting all by itself and I’m managing systems from the web console.
    Then we can blame this on windows networking from hyper-v to dhcp, or just on over complication.



  • a bit of a restart here…

    To be clear I have not put any .iso or answerfiles or that stuff in place.
    I am under the impression the ‘default’ file that comes with FOG and the directories that are in /tftpboot will at least let me know we have this connection in order.
    Also,
    [FONT=Consolas]tftp -i <IP ADDRESS OF FOG SERVER> GET pxelinux.0[/FONT]
    [FONT=Tahoma] is giving an error. Seems this is the wrong syntax. ‘-i’ isn’t even listed as an option. I looked at the man page but, not sure what ‘-i’ was supposed to be.[/FONT]



  • No, not multiple PXE servers. I mean that multiple OSs handle the PXE process. Insomuch that 2012 is the dhcp and FOG does the other steps. Let me follow those advices


  • Senior Developer

    Just to be on the safe side, try:
    [code]sudo ufw disable[/code] and see if you get better results. If that doesn’t work, try using a tftp tool from linux or windows and see if you cat get the file:

    [code]tftp -i <IP ADDRESS OF FOG SERVER> GET pxelinux.0[/code] If this works, then there’s something else blocking the path. You did state that there’s multiple PXE in the same environment. Is one an actual PXE server or are you using VoIP?



  • Ok, from what I read ubuntu has allow-all as default on firewalls and SElinux doesn’t seem to exist.

    set the 067 option to…
    /tftpboot/pxelinux.0
    tftpboot/pxelinux.0
    /pxelinux.0
    pxelinux.0

    any of these options seems to be giving the same pxe-e32 error
    damn this multiple system PXE boot ;)



  • It will be whatever the newest fog is on Ubuntu 12.xx
    I would have hoped the install.sh would have opened a firewall and subverted the SElinux. I’ll check on those 2 options and then go to the option 067 again.


  • Senior Developer

    Also,

    I could be wrong on the 67 pointing to /tftpboot/pxelinux.0 try just: pxelinux.0


  • Senior Developer

    Have you verified that your server doesn’t have selinux or firewall running?

    What version of FOG are you using and what OS?



  • I think that might be right. Tried it and get to this error

    an arp issue I guess

    PXE-E32

    trying to wire shark it out. Might be stuck here and need advice.

    .44 is the network adapter on a hyper-v machine that all these systems treat as a gateway.
    .43 is the 2012 DHCP
    .46 is the FOG tftp

    next ips go to fresh systems

    Anyway now I guess there is a cl#sterf#ck for the new .47 system to find .46(tftp)
    same network all connected through .44, no firewalls, but tftp open timeout

    I see a whole lot of arp request and no arp acks.

    ‘who is this’, ‘who is that’ but no one wants to tell.


  • Senior Developer

    066 should be set to the FOG Server IP, this should be correct.
    067, I think, should be /tftpboot/pxelinux.0


Log in to reply
 

434
Online

38938
Users

10697
Topics

101491
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.