SubProcess -> mirror: Fatal error: max-retries exceeded



  • We’re getting an error in the Replicator log.
    [code]SubProcess -> mirror: Fatal error: max-retries exceeded[/code]
    No other errors, anywhere.
    Uploads, and uni- and multicast deployments work fine and dandy from the main, default member.
    I can ping the node from the main.
    I can ftp to the main from the node (with username:fog and password:–super-long-password-I-didn’t-create)

    Hours of Google research has helped us with our other few issues, but unfortunately has provided no help this time.
    We haven’t had a Storage Node before, this is the first time.

    I’ve never posted here before either. What other information do you need from me?


  • Senior Developer

    Glad I could be of assistance!



  • [quote]Is the IP setup to point at your storage node[?][/quote]
    Fortunately, no. We had a typo in that field. 10.10.1.110 can look so much like 10.1.10.110 even after three technicians and a hundred glance-overs!!

    Thanks! Files are transferring now and we feel sillyheaded, but that did it!


  • Senior Developer

    Is the IP setup to point at your storage node, and is the firewall/selinux disabled on the storage node?



  • Also, for kicks, I went ahead and tried to change the management username and password to ‘Something’ and ‘Bogus’, and the log is still reporting the ‘max-retries exceeded’ error… still with no login errors in the log.



  • Okay… so I updated the management username and password in the Fog GUI. I then ran:
    [code]sudo service FOGImageReplicator restart[/code]
    and the error is still the same as when I first started this thread :(
    Any other troubleshooting I can try?


  • Senior Developer

    I’m thinking it’s being misinterpreted.

    You can’t ftp using a mysql username if ftp isn’t setup to authenticate thru that method.

    I think the time you’re using the fogstorage and password is when it’s asking you for mysql username and password.



  • But the Wiki said to put there what the script spit out…
    Link: [url]http://www.fogproject.org/wiki/index.php/Managing_FOG#Adding_a_Storage_Node[/url]

    Or am I misinterpreting?


  • Senior Developer

    Under storage Management-><Choose Your Node>->Username and Password



  • We have a user account on the node, and we can perform what we need to perform in ftp via the initial system setup account, no problem, from the server. But where, in Fog, do I tell the main server what that username and password is for the node’s ftp?

    Besides which, I’m not getting any Login errors in the log files


  • Senior Developer

    You could create a fogstorage user with the fogstorage password if you so choose, but I think it’d just be easier to put the management username and password as what you setup the system with.


  • Senior Developer

    That is absolutely correct.

    To ftp, you need an actual user account on the node machine.



  • Thanks for the reply.

    I can confirm that we are able to mkdir, rmdir, get, and put multiple files to and from the server… from the node.

    However, we can only ftp from the server to the node using the account credentials we setup during the OS installation. Using the ‘fogstorage’ and ‘fsXXXX’ that the installfog.sh script gave us returns access denied. Besides, I am under the impression those are the node’s MySQL credentials, not ftp credentials, in the first place.


  • Senior Developer

    I’m guessing you then have a FOG Storage Node that is reporting back to the Main server? Though you can ftp to the node, can you actually perform any tasks, such as copy data to and from the server? It’s my guess that, even though you can log in, chances are permissions to the location are not correct, which would, seems to me, cause this issue.


Log in to reply
 

349
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.