PXE Menu issues - Dell Optiplex 790



  • Originally, I had some issues with the 790 being able to boot to the primary hard drive from the fog menu. So I attempted to follow the instructions [URL=‘http://www.fogproject.org/wiki/index.php?title=Boot_looping_and_Chainloading’]here[/URL], because all of the forum posts seem to indicate that was the problem.

    I had trouble finding any newer versions of syslinux that even had the chain.c32 file in them. So I used the version listed in that wiki article (4.04).

    Ever since making any changes to the /tftpboot/pxelinux.cfg/default file, instead of the vesa menu pulling up like it should, whenever I PXE boot, I wind up at a screen with “boot: _” that just loops.

    I have tried restoring the original file. I have rebooted the server to make sure any necessary services have restarted.

    I would prefer to get the chainloading working so that I can PXE -> hard disk in my boot order, but getting the PXE menu to work at all at this point would be my primary concern.

    I have included a copy of my pxelinux.cfg/default file

    [CODE]
    DEFAULT vesamenu.c32 MENU TITLE FOG Computer Cloning Solution MENU BACKGROUND
    fog/bg.png MENU MASTER PASSWD $1$MqHtEmUa$Q.rjvHGQ1eZ0cRfBI.OIR.

    menu color title 1;36;44 #ffffffff #00000000 std

    LABEL fog.local
    localboot 0
    MENU DEFAULT
    MENU LABEL Boot from hard disk
    TEXT HELP
    Boot from the local hard drive.
    If you are unsure, select this option.
    ENDTEXT[/CODE]

    as well as the directory output for the tftp file.

    [CODE]
    root@SCDFOG01:/tftpboot# ls -la
    total 260
    drwxr-xr-x 5 fog root 4096 Oct 10 15:48 .
    drwxr-xr-x 25 root root 4096 Oct 9 06:56 …
    -rw-r–r-- 1 fog root 828 Oct 8 15:08 boot.txt
    -rw-r–r-- 1 root root 20704 Oct 10 16:20 chain.c32
    drwxr-xr-x 5 fog root 4096 Oct 8 15:08 fog
    -rw-r–r-- 1 fog root 25340 Oct 8 15:08 memdisk
    -rw-r–r-- 1 fog root 26460 Oct 10 16:20 pxelinux.0
    drwxr-xr-x 2 fog root 4096 Oct 10 16:48 pxelinux.cfg
    drwxr-xr-x 2 fog root 4096 Oct 8 15:08 tftpboot
    -rw-r–r-- 1 fog root 155792 Oct 10 16:20 vesamenu.c32
    root@SCDFOG01:/tftpboot#
    [/CODE]

    And for clarification, the menu (as well as things like registering) were working just fine before trying to configure chainloading.


  • Senior Developer

    Correct,

    It may, but it may not as well. I don’t know for sure.



  • Are you saying localboot 0x80 may reboot the clients without installing the 4.04 syslinux kernels?


  • Senior Developer

    I ran into a similar issue when I was trying gpxelinux. The 0x80 seemed to work for both systems the most dynamically.

    0x80 fixed that issue for me, so I was hoping to get the information. I’ve since learned that this doesn’t always work, but please give that a shot as it allows the quickest fix if it works. Otherwise, you may need to chainload.



  • [quote=“Tom Elliott, post: 17948, member: 7271”]First things first. Chown the directory with sudo chown -R fog:root /tftpboot just so you know permissions are good throughout. Next, the default file can’t have extra spaces for lines. So anything with text on it should be fine. Remove the whitespace.

    Change the local boot line to read as localboot 0x80 to ensure it finds the hard drive. Next all syslinux has the .c32 files they’re just in different places. Use du piped to grep to find them. Make sure you’ve got the fogboot directory in your web server. It should just be a link back to your /tftpboot/fog directory. I’ll clarify more when I get home.[/quote]

    Tom,

    I am also having issues getting the boot from local drive option to work (on Lenovo PC’s, not Dell). I may need to start a new thread but I wanted to clarify something…why do you recommend using ‘localboot 0x80’ over the ‘KERNEL chain.c32’ as recommended in the ‘Boot looping and Chainloading’ wiki?



  • Tom, thanks for your help, but I managed to self-resolve this just as your responded.

    Two things fixed it. First, overwriting the default file by going back into the web interface and saving the pxe menu options fixed the menu for me.

    Second, I learned a very important lesson today about never using the ssh client in the web interface to edit files. As soon as I got back to my computer and used putty to ssh in and modify the default file, and configured it for chain loading. It worked just fine.

    Thank you for your quick reply!


  • Senior Developer

    First things first. Chown the directory with sudo chown -R fog:root /tftpboot just so you know permissions are good throughout. Next, the default file can’t have extra spaces for lines. So anything with text on it should be fine. Remove the whitespace.

    Change the local boot line to read as localboot 0x80 to ensure it finds the hard drive. Next all syslinux has the .c32 files they’re just in different places. Use du piped to grep to find them. Make sure you’ve got the fogboot directory in your web server. It should just be a link back to your /tftpboot/fog directory. I’ll clarify more when I get home.


Log in to reply
 

433
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.