Can't send inventory.. PLS HLP



  • I am very new to Fog, but understand this a fantastic product with a little tweeking.
    I am trying to do an initial inventory and upload of an HP Z210 with Win 7 Pro.

    Steps I have done to this point:

    1. Installed the Fog Client and win7 cleint on the machine.
    2. I have setup the image directory in the image management section of the webgui.
    3. I have rebooted the target machine and IT boots to PXE, gives me the options of what I want to do. I select “Perform Full Host Registration and Inventory”
    4. It starts the inventory process but displays some errors but passes on to the next step of doing the inventory.
    5. It displays the computer information and then just keeps scrolling at the trying to upload inventory section with no progress bar or notification that it is doing anything.

    Here are a few of the errors that I was able to catch during the process.

    1. Unable to register the host for the following reason: Inappropriate hparm ioct 0x304.
    2. unknown bios version Hewelett-Packard/HP-Z210. v01,35, please report, aborting.

    I have tried using different kernel’s but haven’t had success…

    Any help would be gratefully appreciated!

    Pls keep in mind… I am only 2 days in as a FOG user!


  • Senior Developer

    That’s some of the fun with linux. Getting to fix things on your own.

    Learning the command line can be troublesome at first, but once you start to understand, it’s so much fun.

    I’m a huge fan of all the linux’s, but debian based forms are not as easy for me to use. Maybe it’s because when I started with them, it was all the early forms of RH before they went enterprise.


  • Developer

    We re-installed the server from the ground up using Ubuntu 12.10 as a base.

    Then we started at it again.

    He actually figured out the last bits on his own before I got back to my station (damn) but I’m glad he solved it :D


  • Senior Developer

    You’re still using 0.32?

    What I would recommend is, from the GUI, delete the host. Then from the client, perform a full registration. Once the registration is complete, you can assign the image from the GUI to the client and retry the upload process. Just my recommendation.



  • I will post a detailed report once I actually complete both processes. I have completed my image upload and as soon as it says upload complete, I get an “Unable to find a valid task id based on client mac address and it just keeps scrolling.” Is this normal? I am going to try to deploy this image if that is normal


  • Senior Developer

    I’m glad that this is finally working, but at a loss as to what you did to fix the problem. Could you maybe post, as detailed as you can, what you did to troubleshoot and fix this issue so others that may run into this can find this thread?



  • Ok… Just wanted to give an update… After a lot of changes and troubleshooting and much much thanks to Jaymes and Tom… I am finally able to upload my first image. Fingers crossed I am at 17% upload… Next will be the deploy.


  • Senior Developer

    The task won’t be created if the GUI doesn’t have the information to store it to.

    Is the portmap service and nfs-kernel-server service running?

    Also, is your images folder the one FOG creates during installation or did you create it yourself?

    If you created it yourself, lets just say at /data/somewhereelse/images, make sure you add that to the storage group. If it’s within the same server, you’ll probably need to edit the /etc/exports file to serve the NFS share to the new location rather than, /image /images/dev

    Also, if you created the directory for images yourself, make sure you have the .mntcheck files within. All you have to do is run:

    [code]touch /images/.mntcheck; touch /images/dev/.mntcheck[/code]
    [b]Change the /images part to match your file structure[/b]

    Then run:
    [code]chmod -R 777 /images[/code]
    [b]Again…change the /images part to match your file structure[/b]

    I don’t know how else to help.


  • Developer

    Did you first create an image in the Web GUI before trying to upload the image?



  • Ok… After some assistance from Jaymes I am now able to do an inventory, however when it tries to uploade the image it says can’t find image store.

    I have completely rebuilt the Ubuntu and the Fog server. So I am getting closer to uploading an image…

    Pls Advise

    Thanks in advance.



  • I have done this twice… Thinking it is a configuration issue or I missed something during the setup. I am new to both Fog and Ubuntu. Both times I have blown away the system and the fog… First time I was able to get an inventory of the same machine, but it wouldn’t pull the image… This time I can’t even get it to do the inventory.


  • Developer

    Since this is a blank server with no data on it yet have you entertained the idea of re-naming the installation directory and re-installing the server again?

    I blew my server away and re-configured it about 5 times before I found the method that worked with my hardware.



  • I was able to restart the service. It went back to doing the same original issue. So I changed the files again, restarted the server, restarted the services, with changed files and still will not register the host.

    This is not working out to well. :(


  • Senior Developer

    I don’t know your system. I don’t know your particular setup.

    Unrecognized service means something is not being typed properly.

    What ever the commands where that restarted your tftp services yesterday should be the same today, unless somebody uninstalled that program.

    To find the service, open a terminal and perform:

    sudo ls /etc/init.d

    Look for a the files called tftp. I think it may be tftpd-hpa

    so maybe try:

    sudo service tftpd-hpa restart.



  • Now I am getting an unrecognized service.


  • Senior Developer

    I really can’t.

    However, try running service tftp-hpa stop; service tftp-hpa start



  • I changed it back and now it is still crapping out on the TFTP… The database name and password are correct… Can you post an image of what both of those files should look like so I have something to compare it to…

    Thanks


  • Senior Developer

    then change the host part back to localhost for both the /opt/fog/service/etc/config.php and the /var/www/fog/commons/config.php



  • This post is deleted!


  • Tom

    After I changed the MYSQL_Host variable to the IP address it now when I try to PXE boot times out at the TFTP portion of the PXE boot… It pulls but doesn’t go past that stage.

    Thanks


Log in to reply
 

370
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.