Fog acces in https



  • Hello every body,

    I’m a beginner, and i’ve got a problem

    I would to access to fog server in https mode. I know its apache2 problem, but i dont understand why when i access in http, everything is ok, but in https, firefox don’t find anything:

    “The requested URL /fog/management/index.php was not found on this server.
    Apache/2.2.22 (Ubuntu) Server at 192.168.0.14 Port 443”

    1/the hostname of the machine is: flumotion (yes, i installed flumotion packet first, in second fog)
    2/the ip adress is 192,168,0,14
    3/ i genrate ssl certificate:
    [COLOR=#4f81bd]openssl req -x509 -nodes -days 365 -newkey rsa:1024 -out /etc/ssl/mycert.crt -keyout /etc/ssl/mykey.key[/COLOR]
    4/i create a vitualhost who named fog in etc/apache2/sites-avaibles

    [B]So, this my file etc/hosts:[/B]

    [I]127.0.0.1 localhost.localdomain flumotion fog[/I]
    [I]# The following lines are desirable for IPv6 capable hosts[/I]
    [I]::1 ip6-localhost ip6-loopback[/I]
    [I]fe00::0 ip6-localnet[/I]
    [I]ff00::0 ip6-mcastprefix[/I]
    [I]ff02::1 ip6-allnodes[/I]
    [I]ff02::2 ip6-allrouters[/I]

    [B]This is my file etc/apache2/ports.conf[/B]

    GNU nano 2.2.6 Fichier : ports.conf

    NameVirtualHost *:443
    listen 80

    <IfModule mod_ssl.c>
    # If you add NameVirtualHost *:443 here, you will also have to change
    # the VirtualHost statement in /etc/apache2/sites-available/default-ssl
    # to <VirtualHost *:443>
    # Server Name Indication for SSL named virtual hosts is currently not
    # supported by MSIE on Windows XP.
    Listen 443
    </IfModule>

    <IfModule mod_gnutls.c>
    Listen 443
    </IfModule>

    [B]This my file et/apache2/sites-availables/fog[/B]

    GNU nano 2.2.6 Fichier : fog

    <VirtualHost *:443>
    ServerAdmin webmaster@flumotion
    ServerName flumotion
    ServerAlias 192.168.0.14/fog
    DocumentRoot /var/www/fog

    <Directory /var/www/fog>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
    </Directory>

    ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
    <Directory “/usr/lib/cgi-bin”>
    AllowOverride None
    Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
    Order allow,deny
    Allow from all
    </Directory>

    <Files ~"^.ht">
    </Files>
    SSLEngine on
    SSLCertificateFile /etc/ssl/mycert.crt
    SSLCertificateKeyFile /etc/ssl/mykey.key
    SSLVerifyClient none
    AccessFileName .httpdoverride

    </VirtualHost>

    ^G Aide ^O Écrire ^R Lire fich. ^Y Page préc. ^K Couper ^C Pos. cur.
    ^X Quitter ^J Justifier ^W Chercher ^V Page suiv. ^U Coller ^T Orthograp.
    Anybody have a idea?

    Thx for your help


  • Senior Developer

    no problem.



  • [quote=“Tom Elliott, post: 16448, member: 7271”]It almost sounds like your https side mod_ssl is actually looking in the wrong folder. I’m guessing your running Ubuntu so your default install file goes in /var/www/

    However, the thing it’s looking for looks to be trying to find /var/www/fog/fog

    Maybe try changing this line:
    [CODE]DocumentRoot /var/www/fog[/CODE]

    to
    [CODE]DocumentRoot /var/www[/CODE]

    [B]OR[/B] change the alias you’re calling from:

    [CODE]ServerAlias 192.168.0.14/fog[/CODE]

    to:
    [CODE]ServerAlias 192.168.0.14[/CODE][/quote]

    Hi!

    Great!!! It works!, i change:
    [FONT=Consolas]DocumentRoot /var/www/fog[/FONT]

    [FONT=Consolas]to[/FONT]

    [FONT=Consolas]DocumentRoot /var/www[/FONT]
    [FONT=Consolas]And it work![/FONT]
    [FONT=Consolas] [/FONT]
    [FONT=Consolas]Thx a lot friend :)[/FONT]


  • Senior Developer

    It almost sounds like your https side mod_ssl is actually looking in the wrong folder. I’m guessing your running Ubuntu so your default install file goes in /var/www/

    However, the thing it’s looking for looks to be trying to find /var/www/fog/fog

    Maybe try changing this line:
    [CODE]DocumentRoot /var/www/fog[/CODE]

    to
    [CODE]DocumentRoot /var/www[/CODE]

    [B]OR[/B] change the alias you’re calling from:

    [CODE]ServerAlias 192.168.0.14/fog[/CODE]

    to:
    [CODE]ServerAlias 192.168.0.14[/CODE]


Log in to reply
 

363
Online

38982
Users

10712
Topics

101678
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.