New FOG server will not start the image upload



  • I built one fog server as a “proof of concept” - Never had problems starting a task.
    Running .32 on 12.04.
    Built a new server on better hardware and the new one will not start the upload.

    I can register a new host, create an image, set the new host to upload, reboot host.

    The host goes back to the FOG menu and does not launch the task. If I use “debug” and give the fog command it launches and says “An error has been detected!” “Unable to determine operating system type!”



  • Yep, that was my problem I used the username fog on the Ubuntu box and it wrecked the whole thing. I did a clean install (for the practice) and used a different username other than fog and it worked perfectly.


  • Senior Developer

    I hope this works out for you. Sometimes it’s the only method, though you shouldn’t need to reupload the image.



  • [quote=“Tom Elliott, post: 16280, member: 7271”]I’d say delete the host from the Web GUI and perform a Full registration on it. Have it update.[/quote]

    It looks like this is the solution. I just added a brand new client. Created a brand new image in the GUI. Then set a task to upload the image and it launched fine. Must be something in the client registration that changed when I changed some settings. I will delete the hosts and re-register them.
    .


  • Senior Developer

    That’s perfectly fine, but I’d change the password to something a little more convoluted.

    It looks like the permissions are fine within /tftpboot/pxelinux.cfg

    I’d say delete the host from the Web GUI and perform a Full registration on it. Have it update with the database so we can rule out a database issue and file issue. If the problem still persists we’ll try some more things. So:

    Delete the Task from the Web GUI

    Make sure the task was deleted from the /tftpboot/pxelinux.cfg (make sure the 01-44-37-e6-a9-a8-f2 file is removed) if it’s not removed manually do so with:
    rm /tftpboot/pxelinux.cfg/01-44-37-e6-a9-a8-f2

    Then delete the host from FOG. Go under Host management, search the host name (or mac if you want) and delete it from FOG completely. Then perform a full inventory on it to have it reestablished into FOG.

    Then try to perform your tasks again.



  • I can cancel the task in the GUI and the file disappears.

    prosigna@FOGMAN:/tftpboot$ ls -l /tftpboot/pxelinux.cfg
    total 4
    -rwxr-xr-x 1 fog root 2356 Sep 16 13:16 default
    prosigna@FOGMAN:/tftpboot$



  • Changes outside the realm of instructions:

    There is a computer user named “fog” (not to be confused with the GUI user named fog). I was unable to su fog with any of the passwords I could think of (including “password”). I changed fog’s password to password. I also changed the Fog Settings FOG_TFTP_FTP_USERNAME = fog
    FOG_TFTP_FTP_PASSWORD = password


  • Senior Developer

    I’d say delete the task and the file if needed. You may even need to delete the host and perform full inventory with it, then try it again.



  • Yes, it even reacts to Wake-On-LAN.



  • This post is deleted!

  • Senior Developer

    And:

    44-37-e6-a9-a8-f2 is the correct MAC for the system you’re trying to deploy? When the system is booting from PXE, this is the MAC that shows?



  • prosigna@FOGMAN:/tftpboot$ ls -l /tftpboot/pxelinux.cfg
    total 8
    -rw-r–r-- 1 fog fog 427 Sep 16 13:24 01-44-37-e6-a9-a8-f2
    -rwxr-xr-x 1 fog root 2356 Sep 16 13:16 default


  • Senior Developer

    The reason running in debug gives you an “Unable to determine operating system type” message is because the task doesn’t exist. Although you do have the jobs, are the correlating with the proper MAC’s of the systems you’re trying to deploy the task to? With that, do they have the proper permissions? What I mean, is the files being created having the same permissions you placed on the directory. You can find out by performing :
    [CODE]ls -l /tftpboot/pxeconfig.cfg[/CODE]

    This should show the permissions of the files. The first field will look something like:
    [CODE][root@fogstorage ~]# ls -l /tftpboot/pxelinux.cfg
    total 4
    -rw-r–r-- 1 fog root 2908 Sep 2 13:03 default[/CODE]

    The -rw-r–r-- part is the actual permissions. The 1 is the number of links to the file in question. the fog root part is the owner and group.

    My system states the default file is owner: fog group: root as we discussed earlier. It sounds like whatever is actually creating the tasks may not be giving ownership of the created tasks to fog:root as we did earlier.

    When you did the install, did you install as root or another user?

    Maybe try reinstalling the server to see if this will help you out at all.


  • Senior Developer

    For now, I’d say don’t do multicast jobs. Remove the area’s of the pxelinux.cfg/default file that you added and perform a test task. Then slowly work into multicast troubleshooting.



  • Broken again. Now it will not start any task.

    I was uploading and downloading fine when I tried to multicast. The multicast task did not launch (skipped straight to the FOG menu when booting). I made the changes found here in the troubleshooting section: [url]http://www.fogproject.org/wiki/index.php/Multicasting[/url]
    then rebooted

    Now it will not launch any tasks at all. They appear in /tftpboot/pxelinux.cfg but the clients just boot straight to the FOG menu - even when you launch in Debug-Deploy

    When you select Debug from the FOG menu we are back to the “Unable to determine operating system type” stuff.


  • Senior Developer

    Glad I could be of help.



  • [quote=“Tom Elliott, post: 15998, member: 7271”]chown fog:root -R /tftpboot; chmod 755 -R /tftpboot [/quote]

    FOR THE WIN!!!

    Thanks.


  • Senior Developer

    The reason why you need to create the task with debug is it enables the output of information within a viable task.

    If you don’t, but boot into debug mode directly from the pxe menu, there is no task, therefore no OS ID sent to the system.



  • Thx. The server is at the high school. More debugging will have to wait until Monday.


  • Senior Developer

    Try running task with debug mode. This is different than booting into debug mode. I’ll explain when I get home on appropriate hardware.


Log in to reply
 

368
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.