[SOLVED] TFTP Problems



  • Hello All,

    I am running FOG on Ubuntu 12.04 LTS and my clients will not boot from PXE. TFTP doesn’t ever try to load. I have read several posts about the service starting before the interface can come up causing errors. I tried all of these fixes but it still will not boot into FOG menu.

    I have mainly followed the threads below to fix
    [url]http://fogproject.org/forum/threads/tftp-issues-but-fixable.779/[/url]
    [url]http://fogproject.org/forum/threads/tftp-stops-on-reboot-after-install.488/#post-5353[/url]

    [B]Fixes applied:[/B]
    [LIST]
    [*]In /etc/rc.local
    [/LIST]
    [CODE]/bin/sleep 30 && /etc/init.d/tftpd-hpa restart[/CODE]

    [LIST]
    [*]Created my own script to restart the service when network is up
    [/LIST]
    /etc/network/if-up.d/tftpd-hpa
    [CODE]#!/bin/sh
    restart tftpd-hpa[/CODE]

    [LIST]
    [*]In /etc/default/tftpd-hpa
    [/LIST]
    [CODE]TFTP_USERNAME=“root"
    TFTP_DIRECTORY=”/tftpboot"
    TFTP_ADDRESS=“x.x.x.x:69"
    TFTP_OPTIONS=”-s"[/CODE]
    Xs = my server’s ip address

    [LIST]
    [*]On the client (Windows 7)
    [/LIST]
    Opened cmd and ran this
    [CODE]tftp x.x.x.x get pxelinux.0[/CODE]
    and it came back as transfer successful

    [LIST]
    []Options 066 and 067 on our networks DCHP server are set correctly and 060 is unticked.
    [/LIST]
    [LIST]
    [
    ]All firewalls are turned off by default in ubuntu 12.04 but double checked this, and yes they are off
    [*]The client is on the same network as the fog server
    [/LIST]
    Is there something I’m missing here???



  • Figured it out. Our network administrator placed prelinux.0 in 067 instead of pxelinux.0. Simple typo! So glad that’s all it was. Everything is working perfectly now. Upload my first image!! :)


  • Senior Developer

    So, it sounds like what ever is providing the dhcp address isn’t forwarding the boot request to your fog server. So everything is setup and, more or less, working.

    On my router, this is done within the DNSMasq Options:
    [CODE]dhcp-boot=pxelinux.0,HOSTNAME,IPADDRESS[/CODE]

    Of course your results may vary, but you probably need something similar to this within your DHCP options.


Log in to reply
 

431
Online

38951
Users

10701
Topics

101537
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.