Error Installing Fog - FOG Multicast Management Server Failed



  • I am running CentOS 6.4 and am having issues installing FOG. I am using the link below as instructions for installing.
    [url]http://topgearit.net/index.php?title=Install_Fog_Server[/url]

    I followed these instructions very well and am stopped at this error… “Starting FOG Multicast Management Server… Failed!”

    I have rebooted and re-ran the installer several times. I know I have internet connection. What security settings should I look at to fix this issue? Or is there something else that could cause this?




  • Moderator

    If you use Ubuntu 12.04 LTS, then watch out for the tftp-hpa problem you get after rebooting where the tftpd-hpa tries to start before any interfaces have IP addresses bound to them. Many posts on this forum about this issue and how to work around it.

    Also make sure whatever OS you choose, then you do a full update after the install of the OS and before you try to install FOG, just so you don’t get anything wierd from an outdated package.



  • Okay, I appreciate all your help!


  • Senior Developer

    Then I would say do the “from scratch” method you suggested as I haven’t any clue what else to try.



  • I’m looking at /etc/fstab and all the filesystems are on default, none of them say noexec.


  • Senior Developer

    I don’t think CentOS is a problem. I run CentOS with no issues with fog. As I also performed my install with the same WIKI you did, it seems more like your system is just setup for noexec on the root filesystem which could be causing the issues you’re seeing. Essentially, the service FOGMulticastManager script is executing on a file, rather than a binary, it would cause the issues you’re seeing from what I can tell.



  • We are going to start over from scratch. My boss wanted to use CentOS instead of Ubuntu because of more stability. I’ve convinced him now that we need to use what is RECOMMENDED! lol Sorry that this a been a roller coaster. Thanks for all your help!


  • Senior Developer

    It’s almost as if you’ve got umasks turned on and/or the root filesystem is set as noexec within the fstab file.


  • Moderator

    If you are getting permission denied as root, even when using sudo, then there is something else wrong and not really a FOG problem. I don’t know where to go from here…


  • Senior Developer

    I’d, still, highly recommend just logging in as root. Or sudo up to root with the command:

    [CODE]sudo su -[/CODE]

    Then run the installer.

    You’ll be in as root and won’t need to append the sudo command to every statement.



  • I’m logged in as root. Everything I’ve done on this server has been as root


  • Moderator

    I updated my previous posts to include the sudo part just to clear up any confusion.


  • Senior Developer

    Make sure you’re installing fog as user root.

    Also, make sure you’re running the command chad’s stated as root.

    If you’re logged in as another user, who has sudo privileges:

    run the installfog.sh with:
    [CODE]sudo ./installfog.sh[/CODE]



  • When trying to start the FOGMulticastManger service using
    [CODE]service FOGMulticastManager start[/CODE]
    It comes back and says Permission Denied. The path for that service is /opt/fog/service/FOGMulticastManager/FOGMulticastManager

    I change the permissions like suggested above to rwxr-xr-x root root for the file /etc/init.d/FOGMulticastManager
    Still says permission denied. The services are enabled.

    NICs are set for bridged.


  • Moderator

    If you look at the “status” option in the /etc/init.d/FOGMulticastManager script, you’ll see the command it’s using to check the status when you call it using:
    [CODE]sudo service FOGMulticastManager status[/CODE].

    Looks to be
    [CODE]sudo status FOGMulticastManager[/CODE]

    What do those commands give you?


  • Moderator

    [B]When you run the installer, are you running it with SUDO or equivalent?[/B]

    If you are and still having the issue, continue…

    Ok. Checking through the 0.32 source code for a RedHat based install, it appears that it should be copying files to the init.d path and then trying to start those services using
    [CODE]
    service ${initdMCfullname} restart >/dev/null 2>&1;
    service ${initdMCfullname} status >/dev/null 2>&1;
    [/CODE]

    where initdMCfullname=“FOGMulticastManager”;

    the result of the “status” check is failing. Make sure in your init.d path (/etc/init.d possibly), you have a file called FOGMulticastManager, and its permissions are rwxr-xr-x root root.

    If you do, try running
    [CODE]
    sudo service FOGMulticastManager restart
    [/CODE]

    and check the output.

    If you need to, run
    [CODE]
    sudo service FOGMulticastManager status
    [/CODE] and check the output.


  • Senior Developer

    Alright,

    Is the nic you have available setup for bridged or NAT network?

    If it’s NAT, that’s probably why you’re having an issue, outside traffic is allowed, but incoming traffic is not. Even if this isn’t the direct cause of the issue, it will cause issues down the road. When I setup my VM (I already deleted it) I had it set to NAT, and although everything installed fine on mine, I use virtualbox rather than VMWare, so it may be slightly different configurations in that regard. I’d try making sure your VM is using a bridged adapter versus the VM NAT network system.



  • Everything is updated, i made sure to run the updates through yum at least three times today before starting the FOG installation. One thing I probably should mention is that i have another NIC on this VM which is disabled for now. This shouldnt interfere should it? Our plan is to run this on every vlan on our network, which will require multiples NICs.

    As far as log files, no its been a while since I have used linux. I used to know bash shell really well bc of previous programming experience. Just been a while since ive utilized it. I will get you those lines as soon as I can.


  • Senior Developer

    CentOS is:

    [CODE]tail -f /var/log/messages[/CODE]


Log in to reply
 

363
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.