PXE Menu update failed.



  • Hello everyone, first time poster and newbie to Linux. A bit of a fog issue here.

    Currently running FOG 0.32 on CentOS 6.4. At the PXE boot screen I see the quick image, which prompts for a password. I know I need to change the master password, but everytime I do in the FOG management, I get an error saying “PXE Menu updated failed! Unable to upload file.” Have tried running both virtually and on a physical machine, no dice either way.



  • Followed those steps and it is now working perfectly aside from server errors on our part. Thank you so much for the help


  • Senior Developer

    Good luck then.



  • Thank you so much for the feedback. Having a little trouble getting the laptops to boot from PXE, but that’s our server, not FOG. I did find the config file and backed it up before changing passwords. Will try when I get back to the office.


  • Senior Developer

    Also,

    When editing the default file,

    You’ll find the first PASSWD line as:
    MENU MASTER PASSWD <YOUR ENCRYPTED PASSWORD> <-This controls when somebody hits the ESC key>

    and the menu options (full host reg, quick img, etc…) as:
    MENU PASSWD <YOUR ENCRYPTED PASSWORD> <- When trying to enter a menu option.

    For your knowledge, you shouldn’t need them to be encrypted, but, if you prefer to have it encrypted fog has a utility to do that for you which is located in:

    /opt/fog/utils/

    To run the command type in a terminal:

    /opt/fog/utils/md5pass <YOUR [B]UNENCRYPTED [/B]PASSWORD>
    Then copy the line printed out which will look something like:
    $1$aobkelGl$gX3rr1kioMdm12KvCCW7N0 (this is the md5pass of password)

    Copy that line, and paste it in your desired spots.


  • Senior Developer

    The location for the file is in /tftpboot/pxelinux.cfg/default



  • I would be fine if I could update it manually even, but I cannot find the config file for FOG PXE though.


  • Senior Developer

    To my knowledge that update system has not worked. You could try by making sure the pxelinux.cfg folder and files are writable by apache just to see but I’m not 100% sure.


Log in to reply
 

352
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.