Unable to resolve names from pxe debug



  • TLDR: How do you configure the pxeboot’d clients (ie debug mode) to resolve names?

    I have successfully deployed fog and have been using it for many months now without a problem. We have only been using the standard image deploy but a new order of hundreds of identical systems prompted me to dabble in the multicasting. I’ve yet to get the multicasting to work but I have been following the fogwiki articles and forum posts to work through the issues. I think I am really close but have a simple issue. Specifically I am referencing [URL=‘http://fogproject.org/wiki/index.php?title=Troubleshooting_a_multicast’]this wiki article on troubleshooting a multicast[/URL].

    [CODE]udp-receiver --mcast-rdv-address yourfogserver[/CODE]

    The above command works if I replace yourfogserver with its IP but does not work for its actual name. In fact, I can’t ping any names at all, even by FQDNs. The correct dns server is configured in the pexelinux.cfg file on the append lines. I can ping the fogserver or any other host on my network by IP. My fog server itself can ping with names and FQDNs. From a hosts pxe debug boot, there is no /etc/resolv.conf, /etc/hostname is set to fogclient.localdomain, which is obviously not correct for my setup.


  • Senior Developer

    fogclient.localdomain is just the name the PXE file system is using. The Reason your fqdn isn’t working is probably due to DNSMASQing is not configured for domain name distribution. I could be wrong, but I think you have to use IP for the imaging process. Using hostname is easier to remember, but it also requires DNS lookups to be accurate and updated quite regularly. Remember that the loading of FOG during pxe boot is a very minimal OS and it doesn’t mean that all components work as you expect. I’d stick with setting the IP for your <yourfogserver> section.


Log in to reply
 

386
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.