TFTP Open Timeout



  • Hello,

    I’m back with a new question!

    I’m running Fog alongside my DHCP server (Windows Server 2012) and for some reason, TFTP keeps timing out at PXE boot.

    I’ve captured traffic using Wireshark and it looks something like this:

    Server sends data packet “Block 0” to client
    Client tells server “Fragemented IP protocol”

    Server sends data packet “Block 1” to client
    Client tells server “Acknowledgement, Block: 0”

    And this repeats until it times out. Just sending block 0 and 1 back and forth.

    I’m completely lost and any help would be greatly appreciated!

    Thanks!



  • Had the same problem today.
    Did this

    sudo stop tftpd-hpa
    sudo start tftpd-hpa
    

    and on ubuntu I disconnected the wired connection profile and reconnected and was fixed.


  • Senior Developer

    I think it’s something along the lines of ip-helper on the managed switches.



  • hey guys…

    could possibly be unrelated… but…
    we were having issues with TFTP Timeout when it came to subnets other than the one fog was on… it turns out the switch needed configuration to allow spanning subnets (not sure on exact terminology but 5 minutes after the network guy worked on the core switch, it was working).

    the bad descriptor problem, I resolved by making sure that .mntcheck was in both the /images and in the /images/dev folder…

    good luck… let us know how you go…



  • May Sound stupid but did you trying using

    sudo stop tftpd-hpa
    sudo start tftpd-hpa

    in the terminal



  • I reinstalled Fog and put my DHCP server as the router’s address. This got me past the bad descriptor file error.

    Now, I get: “RPC remote system error connection refused.”

    Who knows if I’ll ever get this working. It’s just one error after another.



  • Alright, somehow, I made progress today. I can now successfully PXE boot in two out of eight labs.

    I’ve been attempting to upload an image and when it gets to mounting the NFS share, I get the error: Bad descriptor file and then it restarts. Once again, I’m lost.



  • Here’s something else that is interesting:

    When I’m booting a PC on the same subnet as my Fog server (10.200.200.203) and I choose to get IP information once I’m inside Fog, it shows that DHCP gave out the correct address.

    It has to be something to do with my other PCs being outside of that subnet. We divide each lab into a different subnet so there’s no way that I can really join them all together.



  • On a Windows box in the 10.110.100.x subnet, the OS pulls this from my DHCP server:

    DHCP Enabled: Yes
    Autoconfiguration Enabled: Yes
    IPv4 Address: 10.110.100.92
    Subnet Mask: 255.255.254.0
    Default Gateway: 10.110.100.254
    DHCP Server: 10.200.200.3

    However, if I PXE boot, it never gets DHCP so it doesn’t continue into PXE.

    I use to use Alitirs and it worked just fine. We had its PXE server set to “Use the DHCP port.”



  • sorry still won’t fix it anyways
    the workstation in the pxe process isn’t being allocated an ip address but an up and running os can ?- can you post a screen shot?



  • tftp on fog ok - running confirmed
    dhcp - giving addresses options 66&67 set ok
    routing ok
    firewall rules (any,any) nothing should be blocked …ok
    try from the windows box (10.120.100.x subnet right?) command prompt tftp [I]foghost[/I] get pxelinux.0 ?



  • The pool is definitely not exhausted. If it boots to Windows, it gets its DHCP address.

    Yes (to your second post).

    In my internal network, there is no firewall whatsoever.



  • firewall rules ???



  • also check to make sure you are able to route to your fog server …



  • i was under the impression it was getting an ip address ??? you syslog post [B]“sent /tftpboot/fog/bg.png to 10.120.100.41” [/B]

    right ?[B][/B]



  • so if that subnet isn’t getting dhcp - is there a scope set on the windows box for that subnet with a pool set - is the pool exhausted ? check to see if the pool isn’t exhausted …



  • On the subnet where I have my Fog server setup, it PXE boots just fine. On any other subnet, it will not get a DHCP address which leads it to be unable to PXE boot.



  • I did. It had no effect.





  • Here is /tftpboot/pxelinux.cfg/default:

    DEFAULT vesamenu.c32
    MENU TITLE FOG Computer Cloning Solution
    MENU BACKGROUND fog/bg.png
    MENU MASTER PASSWD $1$0123456789
    \n
    menu color title 1;36;44 #ffffffff #00000000 std
    \n
    LABEL fog.local
    localboot 0
    MENU DEFAULT
    MENU LABEL Boot from hard disk
    TEXT HELP
    Boot from the local hard drive.
    If you are unsure, select this option.
    ENDTEXT
    \n
    LABEL fog.memtest
    kernel fog/memtest/memtest
    MENU LABEL Run Memtest86+
    TEXT HELP
    Run Memtest86+ on the client computer.
    ENDTEXT
    \n
    LABEL fog.reg
    MENU LABEL Quick Host Registration and Inventory
    TEXT HELP
    Automatically register the client computer,
    and perform a hardware inventory.
    ENDTEXT
    \n
    LABEL fog.reginput
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= mode$
    MENU LABEL Perform Full Host Registration and Inventory
    TEXT HELP
    Perform a full host registration on the client
    computer, perform a hardware inventory, and
    optionally image the host.
    ENDTEXT
    \n
    LABEL fog.quickimage
    MENU PASSWD $1$0123456789
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= mod$
    MENU LABEL Quick Image
    TEXT HELP
    This mode will allow you to image this host quickly with
    it’s default assigned image.
    ENDTEXT
    \n
    LABEL fog.sysinfo
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= mod$
    MENU LABEL Client System Information
    TEXT HELP
    View basic client information such as MAC address
    and FOG compatibility.
    ENDTEXT
    LABEL fog.debug
    MENU PASSWD $1$0123456789
    kernel fog/kernel/bzImage
    append initrd=fog/images/init.gz root=/dev/ram0 rw ramdisk_size=127000 ip=dhcp dns= mod$
    MENU LABEL Debug Mode
    TEXT HELP
    Debug mode will load the boot image and load a prompt so
    you can run any commands you wish.
    ENDTEXT
    \n
    PROMPT 0
    TIMEOUT 30\n


Log in to reply
 

450
Online

38716
Users

10544
Topics

99831
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.