After Sysprep Windows 7 keeps rebooting

  • Hi,

    I have here 25 ASUS M5A78LT-M/USB3 computers.
    Last year I deployed them with Windows XP. But this year we are migrating to Windows 7 Enterprise 64 bit.

    The fog upload/download process works great but after the sysprep the computer won’t boot up again and keep rebooting.

    By default I keep my drivers info in the image with the following commands in my unattend.xml file:
    <settings pass=“generalize”>
    <component name=“Microsoft-Windows-PnpSysprep” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm="[url][/url]" xmlns:xsi="[url][/url]">

    Next I tried the default sysprep of Windows 7. But again the same problem…

    The problem is that i’m not getting any blue screens so I’m not shure where to look…
    The Safe mode doesn’t work so no luck there as well :s

    Any Ideas??

    I read something about the AHCI drivers, can they create this problem?



  • I’ve had personal experience with this issue and I can confirm the fact that you HAVE to switch your HD mode from AHCI to IDE in order for your computer to boot properly

  • AHCI Drivers wouldn’t create the problem necessarily, though many people opt to keep the BIOS setup as IDE. I haven’t seen any issues with either.

    I have played with FOG and Sysprep, and I found that you can only do sysprep the first time on windows 7 for the Single Disk, Resizeable option to work with 0.32 and your system. The caveat to this is that it will not work after you’ve activated and licensed windows for the first time. Windows will let you sysprep whenever you want, but FOG does not enjoy this.

    The way I got around this is by doing the base install. Once it’s at the screen asking you for username and machine name, I do a CTRL+ALT+SHIFT+F3 (just to be safe, I never remember which is the actual combination so I do them all) to drop down into Audit mode. Then I can install all the software I need, updates, drivers etc… Then I sysprep and reboot, right after setting the machine to create upload task. I’ve not had any issues with this method.