Setting up and building UDPCast...Failed!



  • So i Setup Mint 15 and tried to use these settings for fog
    Distro: Ubuntu
    Installation Type: Normal Server
    Server IP Address: 10.10.10.10
    DHCP router Address: 10.10.10.10
    DHCP DNS Address: 10.10.10.10
    Interface: eth0
    Using FOG DHCP: 1
    Internationalization: 0

    and it gets to the subjected line and halts dies… how can I fix this?? i have done a fair amount of searching to no avail, and i’ve tried to use other Small linux distros like SliTAZ and i didn’t even get that far. Any Help would be Appricated.



  • [quote=“Tom Elliott, post: 23193, member: 7271”]You’re welcome.

    All is working then I presume?[/quote]

    I have succesfull created an image of a Windows 7 machine. I have not tried to deploy the image back to the Windows 7 machine, but I assume that this is going to work, otherwise I let it know. :)


  • Senior Developer

    You’re welcome.

    All is working then I presume?



  • Ok, I’ll leave it alone. Thank you and Tom for all the help!


  • Developer

    Hey if it’s working leave it alone. I was going to have you isolate the network to rule out problems with your network communication or things blocking traffic.

    Yes it is possible to use a NAS store.



  • [quote=“Jaymes Driver, post: 22991, member: 3582”]try removing your .mntcheck files and recreating them

    /images/.mntcheck
    /images/dev/.mntcheck

    [/quote]

    Done!

    [quote}
    edit your /etc/expotrs to look like this
    [code]
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    [/code]

    [/quote]

    Done! Only change this line from:

    /images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

    to:

    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)

    [quote]

    ALSO, if you are using the FOG server to store your images (Not a NAS or another server, or save space or something HAS TO BE STORED IN THE /images folder on the Ubuntu box) then try isolating the network with a basic router. Set up a network between the host and the server only and try to image.[/quote]

    [/quote]

    It was allready set to be stored in the /image folder, so no changes there.

    As expected I had to connect a Windows 2012 server for the DHCP-options 66 & 67. With the basic router the Windows 7 client didn’t get the right DHCP-data.

    I honestly did not had confident that it should be successful now, but at this time I see the blue screen "save partition to image file’.

    So I’m very glad, it is working, at last! :)

    Now you are talking about a NAS-server. Is it possible to store the images on a seperate NAS-server (a QNAP f.i.)?


  • Developer

    try removing your .mntcheck files and recreating them

    /images/.mntcheck
    /images/dev/.mntcheck

    edit your /etc/expotrs to look like this
    [code]
    /images *(ro,async,no_wdelay,insecure_locks,no_root_squash,insecure)
    /images/dev *(rw,async,no_wdelay,no_root_squash,insecure)
    [/code]

    ALSO, if you are using the FOG server to store your images (Not a NAS or another server, or save space or something HAS TO BE STORED IN THE /images folder on the Ubuntu box) then try isolating the network with a basic router. Set up a network between the host and the server only and try to image.


  • Developer

    Sorry I had forgotten that tid bit of information, let me beat my head against the wall a little longer and see what I can come up with.



  • My Ubuntu uses rpcbind instead of portmap by the way.

    But this didn’t help also:

    [code]
    service rpdbind restart
    service nfs-kernel-server restart
    [/code]



  • [quote=“Jaymes Driver, post: 22955, member: 3582”]Your link is missing a colon my friend

    [url]http://www.noordlaarderbos.nl/linux/fog-upload-error1.jpg[/url]

    [/quote]

    That’s a bug in this forum.

    [quote]

    try

    [code]
    service portmap restart
    service nfs-kernel-server restart
    [/code][/quote]

    I had allready tried that and even rebooted the Ubuntu machine, but I didn’t help.


  • Developer

    Your link is missing a colon my friend

    [url]http://www.noordlaarderbos.nl/linux/fog-upload-error1.jpg[/url]

    try

    [code]
    service portmap restart
    service nfs-kernel-server restart
    [/code]



  • The PXEboot on the Windows 7 client went well…until…this:

    [URL=‘http://http://www.noordlaarderbos.nl/linux/fog-upload-error1.jpg’]www.noordlaarderbos.nl/linux/fog-upload-error1.jpg[/URL]

    Maybe a new challenge for Tom?



  • It looks like it’s working on a another Windows 7 client! PXE boots up with FOG image solution!

    Before it was runing I have connected a Windows 2012 server for DHCP in the network.



  • Thanks again. But my troubles are not over yet!

    Windows 7 PXE doesn’t receive a bootfile, when booting.


  • Senior Developer

    Have a look at this site for understanding:
    [url]http://chemdroid.net/en/ubuntu/23-vsftpd-500-oops-priv-sock-get-cmd[/url]



  • Here is my output again after
    chmod -R 777 /tftpboot
    chown -R fog:root /tftpboot

    jos@leeuwerik:~$ ls -lh /tftpboot
    totaal 216K
    -rwxrwxrwx 1 fog root 828 feb 10 21:04 boot.txt
    drwxrwxrwx 5 fog root 4,0K feb 5 22:49 fog
    -rwxrwxrwx 1 fog root 25K feb 10 21:04 memdisk
    -rwxrwxrwx 1 fog root 17K feb 10 21:04 pxelinux.0
    drwxrwxrwx 3 fog root 4,0K feb 11 20:32 pxelinux.cfg
    drwxrwxrwx 2 fog root 4,0K feb 11 22:24 test
    drwxrwxrwx 2 fog root 4,0K feb 5 22:49 tftpboot
    -rwxrwxrwx 1 fog root 145K feb 10 21:04 vesamenu.c32
    jos@leeuwerik:~$ cd /tftpboot
    jos@leeuwerik:/tftpboot$ ls -lh
    totaal 216K
    -rwxrwxrwx 1 fog root 828 feb 10 21:04 boot.txt
    drwxrwxrwx 5 fog root 4,0K feb 5 22:49 fog
    -rwxrwxrwx 1 fog root 25K feb 10 21:04 memdisk
    -rwxrwxrwx 1 fog root 17K feb 10 21:04 pxelinux.0
    drwxrwxrwx 3 fog root 4,0K feb 11 20:32 pxelinux.cfg
    drwxrwxrwx 2 fog root 4,0K feb 11 22:24 test
    drwxrwxrwx 2 fog root 4,0K feb 5 22:49 tftpboot
    -rwxrwxrwx 1 fog root 145K feb 10 21:04 vesamenu.c32

    FOG says again:
    Unable to start task
    Unable to upload file.


  • Senior Developer

    Can you give a couple of outputs here:

    From the terminal type:
    [code]ls -lh /tftpboot[/code]

    Then give the output here. It should look something along the lines of:
    [code]drwxr-xr-x 1 fog root 25 Nov 28 10:16 /tftpboot[/code]

    Then cd into the /tftpboot and run
    [code]ls -lh[/code]
    Print the results here.

    It should look something like:
    [code]total 174K
    -rw-r–r-- 1 fog root 828 Jul 30 2013 boot.txt
    drwxr-xr-x 6 fog root 4.0K Nov 30 08:17 fog
    -rw-r–r-- 1 fog root 17K Feb 11 19:08 pxelinux.0
    drwxr-xr-x 2 fog root 4.0K Feb 11 22:22 pxelinux.cfg
    drwxr-xr-x 3 fog root 4.0K Jul 30 2013 tftpboot
    -rw-r–r-- 1 fog root 145K Feb 11 19:08 vesamenu.c32[/code]

    I just need to see if there’s a sticky bit set and verify the permissions.

    If you truely did perform the:
    [code]chmod -R 777 /tftpboot
    chown -R fog:root /tftpboot[/code]

    All items should have permissions similar to: {d or -}rwxrwxrwx with owner of fog and group owner of root.

    This definitely is a permissions issue, but if you did perform the commands we’ve suggested, there shouldn’t be any permissions issues, unless there’s an immutable flag on the folders or somebody’s changed the umask settings.



  • [quote=“Tom Elliott, post: 22871, member: 7271”]So that tells me that FTP is not working. From the main console can you chmod -R 777 /tftpboot and try creating task again?[/quote]

    Still the same:
    Unable to start task
    Unable to upload file.

    After “chmod -R 777 /tftpboot”

    In the FTP-shell it is possible to make a dir in /tftpboot but not in pxelinus.cfg


  • Senior Developer

    So that tells me that FTP is not working. From the main console can you chmod -R 777 /tftpboot and try creating task again?



  • Ok.

    In the FTP shell, I can cd to /tftpboot/pxelinux.cfg
    mkdir test, failed in the FTP shell.


Log in to reply
 

431
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.