SATA-related issue?



  • Hi,

    First-time user of fog, and first time posting in forum, so apologies if I’ve missed anything.

    I successfully installed fog, and after a minor mishap with mysql login details (which was quickly fixed thanks to the questions of previous posters in these forums) I was able to upload my first image (ubuntu 12.04).

    However, when trying to upload my second image (proxmox VE 3.0, which is a debian-based distro, with a kernel based on RHEL6 with openVZ patches - source: [url]http://pve.proxmox.com/wiki/FAQ#What_distribution_is_Proxmox_VE_based_on.3F[/url] ) I ran into the error below:

    [COLOR=#000000][FONT=monospace]###########################################################################################

    An error has been detected

    ###########################################################################################

    Fatal Error: Failed located hard disk

    ###########################################################################################

    Computer will reboot in 1 minute.

    ###########################################################################################[/FONT][/COLOR]

    I did a bit of digging around this error, and found that it normally arises due to the use of an SATA hard drive, without IDE emulation being used in the BIOS (source: [url]http://www.fogproject.org/wiki/index.php?title=SATA_Support[/url]) and/or the SATA device not being plugged in to the first SATA port (reference: [url]http://www.tomshardware.co.uk/forum/250028-32-sata-hard-drive-detected-bios-setup[/url], although note that this is not my motherboard).

    So I changed the drive to be plugged into SATA port 0, but my BIOS settings were confusing (there was no “legacy” mode, only Enhanced, Combined, Non-combined, Disabled and Auto). Based on the manual (Reference: [url]http://www.nodevice.com/user_manual/gigabyte/Motherboard/ga-g41m-es2l-212153.html[/url]) I tried combined and non-combined modes - neither worked - so I proceeded to try all other options to no avail (Auto, Enhanced etc).

    I then found guidance suggested for a victim of a similar problem - take out the hard drive and put it in a known-fog-compatible machine. So I put the drive in the machine that I’d used for the ubuntu image upload (replacing the existing hard drive, which was also SATA, but 2.5" rather than 3.5").

    I still got the same error.

    TL;DR version:
    I got the “failed to locate hard disk” error. After trying different bios settings (which failed), I put the SATA drive in a machine which is known working with a 2.5" SATA drive, and got the same error. Therefore, I can only conclude it’s either an error FOG hits relating to that specific make / model of hard drive, or relating to the contents of the drive (which is an install of proxmox VE).

    I would appreciate any guidance on this issue. Is this a “genuine problem” with FOG, or is it user error?



  • I actually tried with 3 different sets of hardware - the computer that the drive was initially in, another computer that was untested with FOG (the same issue occurred) and then finally with the computer that was known-working with FOG (initially I didn’t want to open up the working computer to try it in there, but did it anyway out of desperation).

    All three computers were working fine before I began the exercise (i.e. able to boot into their respective operating systems), but only one (the third one) was tested (and was working) with FOG.

    The hardware is very diverse (see below), but all three are 64bit machines.

    Computer 1:
    (has since stopped working for a different reason - coincidental psu failure)
    Gigabyte GA-G41M ES2L mobo
    [B][SIZE=14px][FONT=trebuchet MS][COLOR=#1155cc][FONT=trebuchet MS][COLOR=#1155cc][SIZE=14px][B]INTEL CORE i5 - 2400 3.1GHz QUAD CORE [/B][/SIZE][/COLOR][/FONT][B][SIZE=14px][FONT=trebuchet MS][COLOR=#222222]PROCESSOR[/COLOR][/FONT][/SIZE][/B][/COLOR][/FONT][/SIZE][/B]
    On-board graphics

    Computer 2:
    [SIZE=12px][FONT=arial][COLOR=#1155cc]MSI 990FXA-GD80 AMD 990FX Socket AM3+ ATX Motherboard[/COLOR][/FONT][/SIZE]
    [SIZE=12px][FONT=arial][COLOR=#1155cc]AMD Athlon II X2 260 3.2GHz[/COLOR][/FONT][/SIZE] processor
    [SIZE=12px][FONT=arial][COLOR=#1155cc]SAPPHIRE Radeon HD 7970[/COLOR][/FONT][/SIZE] pcie graphics card x2

    Computer 3: (known working with FOG)
    [SIZE=12px][FONT=Helvetica Neue][COLOR=#000000] Zotac NM10-F-E Intel Atom D525 CPU (1.8GHz) Motherboard (including built-in processor and graphics)[/COLOR][/FONT][/SIZE]

    In any of these machines, inserting the proxmox hard drive caused FOG to fail with the error described above. The drive was originally in computer 1.

    Any thoughts as to what might be causing this?

    Thanks!

    James



  • We’ve used Fog for a few years now and have not seen any issues with SATA drives left in their native mode so I don’t necessarily think it is SATA that is the issue, but something unique to your hardware. Are the affected computers all the same or are you seeing it across several models?


Log in to reply
 

440
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.