Lenovo B590 won't connect to Fog Server



  • Dear All,

    I’ve tried making an image of a Lenovo B590 laptop. When it is booted from the network (this has to be selected from a menu via F12 as the boot order can’t be set to try the NIC first), it successfully gets an address from DHCP but then TFTP fails after a long delay. The screen reads:

    PXE-E32: TFTP open timeout
    TFTP…

    There is quite a delay before TFTP gives up so I don’t know if adjusting the timeout (if possible) will work. Is there anything I need to change? The NIC is a realtek of sorts.

    As it doesn’t go further than this, I can’t auto-register the laptop. I’ve tried creating the client manually using the MAC address hoping to be able to wake it up remotely but this doesn’t work either. I reckon I’ve set the BIOS up accordingly.

    Many thanks,

    Paul.


  • group:cid:13:privileges:mods:members

    Paul, have you tried a different kernel? Sounds like the driver for your Lenovo might not be in the kernel you are using.



  • Yes I tried it with a new Icubes desktop and that worked ok. So far only this Lenovo laptop has caused the problem. As it’s a laptop, I’ve been using the wired connection rather than wi-fi. The laptop used the same network connection as the Icubes machine. It’ll be a while before I can try any more tests as I had to rebuild the Fog server due to a problem I possibly caused when replacing the drive that hold the images.

    Once it’s up and running again, I might try it out on a private network to see what happens.

    Many thanks,

    Paul.



  • Hi Paul

    Does TFTP work with other computers and only this one fails?

    The only time I’ve seen is happen if there is no connectivity to the fog server due to a switch issue or my fog server has gone a little cactus.

    Try rebooting fog server and see if it works, if not, try connecting another computer which you know works with fog into the same port and if that fails as well then your problem is located from that port onwards and not fog.


Log in to reply
 

414
Online

39002
Users

10717
Topics

101762
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.