Fog/Mysql help



  • Hi,

    I just started work at a school district and they had a fog set up in place. The previous IT guy moved the virtual fog server and got it up and running fine. However last week we had a power outage and now I am not always able to get fog web UI. I think part of the problem is that when the old server came up it started the old virtual fog server too. I did search a bit before posting. Most of the suggestions I saw were making sure the password for the mysql users were correct, and after checking them I still have the same problem.

    I noticed the problem when trying to set up new PC’s that we just got. Last Tuesday before the outage I was able to image computers fine. But when I got in today and tried to do a full inventory and install on a PC I get an error “Invalid MAC Address (3)”. I also tried to quick image a few machines and get an error “Database Error : Unable to Proceed!”.

    The Web UI problem is intermittent, and I get “Unable to connect to database.” I’m sorry if my description of the problem is confusing, but please let me know what other information that is needed to help me clear up my problem.



  • Turns out the power outage caused the original (physical) fog server to turn on when the power was restore. I arrive at this conclusion after I removed the network cables form the machine that fog should be on and stopped the another old virtual fog server on another, yet I was still able to PXE boot with fog. After calling the previous tech guy we came to the conclusion that the original fog server had to be on, and it was. It was a combination of miss-information and mother nature. I did find that the original fog servers mysql database was not running and I was unable to start it again. Now the virtual fog server is up and running fine. Thanks for the help and fast responses, sorry wasting your time :D



  • did it get the DHCP and connect to fog?
    also, do the tasks still show up as pending tasks in the task manager?

    take a look at /tftpboot/pxelinux.cfg folder, do those mac address’ have files that start with 01-<mac address> ??



  • Just some more info that might help. The web ui is much slower than usual.

    Also I had queued some PCs to deploy last week and they were able to complete the task. I tried to start a deploy task via the web ui, but when the PC was rebooted it did not start to deploy, I booted form the hard disk.



    1. Yes they are still finding fog. The “Invalid MAC Address (3)” error occurs after I have started a fog job via PXE boot. We have 2 campuses. This is at the 2nd campus. I consider the campus with the physical server with the fog server running out 1st.

    2. The one I’m at (2nd) right now can access the Web UI and the mysql database at [url]http://fogserver/phpmyadmin/[/url]. I will check at the other campus and post again.



  • I guess my first questions would be:

    1. Are clients still booting up and finding the FOG server via PXE?
    2. Can you always ping the fog server? even when you cant get the web ui?

Log in to reply
 

864
Online

38996
Users

10715
Topics

101725
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.