SQL Database doesn't match Web Interface



  • Due to the way we work, once a machine is imaged the hostname changer service setting needs to be disabled.
    I have been doing this two different ways, initially I was using an SQL event setup through PHPMyAdmin running the following every evening:
    [CODE]UPDATE moduleStatusByHost SET msState=0 WHERE msModuleID=‘hostnamechanger’[/CODE]
    I’ve had a few issues with the event scheduler turning itself off, so I’ve since moved to a cronjob running the same command piped into an SQL/bash script.

    This had been working fine, however, I’ve just noticed that if I run the following:
    [CODE]SELECT * FROM moduleStatusByHost WHERE msState LIKE ‘1’[/CODE]
    I get no results returned and actually looking at the moduleStatusByHost table, every msState field is set to 0. However in the web interface, numerous hosts do have this option selected. I’ve even ran:
    [CODE]UPDATE moduleStatusByHost SET msState=0[/CODE]
    Even through the database shows its disabled, the service is definitely enabled for some hosts, if I change the hostname on one of these hosts, Fog renames them back.
    If I disable then re-enable the service through the web interface for a host, then re-run the SQL script to disable it, it works as it should.

    It seems as if the SQL database and the Web interface are out of sync, even though Fog seems to operate as normal with regards to imaging etc.
    Does anyone have any ideas what could cause this?
    Thanks!


Log in to reply
 

401
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.