Cant get fog to work with HP 6300



  • Hi all.

    I have been using fog for a little while now and have just installed the new version, 0.32 running on ubuntu 12.04.

    I have pxe an older pc which has worked fine, although the dhcp took longer than expected, but eventually got into the fog menu, i uploaded an image and thats fine.

    So tried to do the same with a hp 6300 sff and i get it to pxe boot but it will not find the dhcp server, and of course no fog menu

    Any ideas anyone?


  • Senior Developer

    Glad I could be of assistance.



  • We fixed the issue! It was the fact spanning-tree was enabled on our switches but port-fast was not…after changing the config it works like a dream. It also sped up the rest of the devices that were taking ages to obtain DHCP and get to FOG, thanks for your help!


  • Senior Developer

    [quote=“mlnancejr8808, post: 15414, member: 654”]Yes, when the PCs boot to PXE initially they will try to pull DHCP go about 4 dots whatever you want to call them then say PXE-E51- DHCP or proxyDHCP offered…other PCs we have (Dell Optiplex 740 and 755) have no issue. Just dealing with this on the HP Compaq 6300 Pro and I have 6 labs to image by next Wednesday when school starts.[/quote]
    Found this on website:
    [url]http://www.symantec.com/business/support/index?page=content&id=TECH12323[/url]
    [SIZE=4][B][FONT=Arial][SIZE=18px][COLOR=#444444] [/COLOR][/SIZE][/FONT][/B][/SIZE]

    [SIZE=4][B][FONT=Arial][SIZE=18px][COLOR=#444444]Solution[/COLOR][/SIZE][/FONT][/B][/SIZE]

    [SIZE=16px][FONT=Arial][COLOR=#444444]
    This error is usually received when the client booting up via PXE is having difficulty communicating with the DHCP/PXE server. The common troubleshooting steps and/or causes of this problem are as follows:

    1-The PXE client is connected to a managed switch that does not have portfast enabled and/or is running spanning-tree. Portfast will need to be enabled. To read more about what spanning-tree and portfast are, see article 3096, "What is Spanning Tree? What is PortFast?"
    2-The DHCP/PXE servers reside on a different subnet than the PXE client. IP helpers need to be in place. See article 1331, "Configuring PXE to work across VLANs."
    3-Check the DHCP server and verify that the DHCP scope has free IP addresses to lease out (make sure they are not all used up).
    4-If the above steps do not correct the issue, place the DHCP Server, PXE server and a client computer on a hub. Test PXE to see if the same message is received. If the same error message is not received, this is a good indication that there is some factor on the network not permitting the DHCP/PXE protocols to be passed down to the client computer.
    Place a hub between the PXE client and the switch the client is connecting to. If at this point the PXE client works successfully, please review step 1 of this article.
    5-Use TCPView to verify the DHCP ports 67 and 68 ([URL=‘http://www.microsoft.com/technet/sysinternals/utilities/TcpView.mspx’][SIZE=12px][COLOR=#72a826]http://www.microsoft.com/technet/sysinternals/utilities/TcpView.mspx[/COLOR][/SIZE][/URL]). MTFTP Port 69 are showing.
    6-If this problem is still occurring after testing out the above, collect sniffer traces from the DHCP/PXE server(s) and contact Altiris Support Services.
    7-If DHCP server is on the same box as PXE server follow the option to enable 060 scope option. Article ID: 17347 Creating and setting option 060 on a DHCP server
    8-The NIC could be disabled on the Client machine.[/COLOR][/FONT][/SIZE]



  • Yes, when the PCs boot to PXE initially they will try to pull DHCP go about 4 dots whatever you want to call them then say PXE-E51- DHCP or proxyDHCP offered…other PCs we have (Dell Optiplex 740 and 755) have no issue. Just dealing with this on the HP Compaq 6300 Pro and I have 6 labs to image by next Wednesday when school starts.


  • Senior Developer

    If I’m wrong let me know, but you’re saying you’re having problems with the system actually picking up an IP Address when it goes thru PXE boot, or is it after this point that’s the problem?



  • Im having the same issue and I have tried a different kernel but to no avail. Any help would be GREATLY appreciated!!!


  • group:cid:13:privileges:mods:members

    Have you tried a different kernel? i’ve had real good luck with 3.6.9. But that was with all Dell’s.


Log in to reply
 

814
Online

38970
Users

10712
Topics

101667
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.