PXE Problems, out of my depth!



  • Hello All,

    I’ve been having so many problems getting our FOG server to run properly. Apologies for the long post, but I’ve tried everything I can think of and could do with a hand from someone who knows what they’re doing!

    Initially we used WDS and nothing else, so whilst in the testing phase I made a multi-boot menu using PXELinux, to enable me to use FOG when I wanted, and WDS to keep things running in the meantime.

    That all worked fine, until one day my Ubuntu server decided to run some updates, did a reboot and from that day on PXE booting to the FOG server never worked again, I was getting this error:

    TFTP boot : 10.105.5.205 pxelinux.0
    pxechain : PXENV_RESTART_TFTP [0001]
    pxechain : PXENV_UDP_OPEN [0001]

    boot :

    And it would stay with that error message all day if I let it. I’m a complete n00b when it comes to Linux, so after a bit of Googling and tinkering, I gave up and did a fresh install of Ubuntu and FOG. I disabled updates and all worked well again.

    Until yesterday, when I rebooted the FOG server and PXE booting broke again. I could cry.

    But that’s just one problem. I now have another problem.

    I’ve decided to completely bin-off WDS, so I shut down the WDS server (which had the PXELinux boot menu on it) and changed option 66 and 67 on the DHCP server to point to the FOG server. Now it just seems all my computers are completely ignoring DHCP. I PXE boot them and they just sit there with this error:

    PXE-E32: TFTP open timeout.

    But they also do that if the option 66 and 67 aren’t configured at all, although they’re managing to pick up an IP fine.

    I’m really stuck now, so any help would be MUCH appreciated - I don’t want to rebuild my FOG server again!



  • Didn’t look like it was running, but this lovely thread:

    http://fogproject.org/forum/threads/tftp-issues-but-fixable.779/

    fixed the problem! Thanks for your help :)



  • Check tftp is running from a client windows computer by doing following:

    1. Enable tftp client in windows control panel Windows Features
    2. Open a command prompt and type [B]tftp ServerIP get pxelinux.0[/B]
      You should get Transfer successful

    If not then something wrong with tftp on server.


Log in to reply
 

456
Online

38716
Users

10544
Topics

99830
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.