Can not mount NFS share



  • I have added additinal storage to my FOG server. I did this by using an NFS share. The FOG server can see the additinal storage and I am able to write to it with the FOG user from the fog server.The NFS server is mounting a 6tb directory under /images and the new FOG server directory is /mnt/images

    I have made sure there is an .mntcheck file in the /mnt/images directory and the /mnt/images/dev directory. I did not have many useful images so I did not copy the old directory over I just left it and change the path. When I try to upload an image I receive the error that can not mount NFS volume permission denied. Any help is greatley appreciated

    Thanks



  • [quote=“thomas Bollig, post: 12433, member: 4211”]Thanks again for the info. Here is a little more info for you
    My etc/export on the FOG server is

    /mnt/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /mnt/images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

    and on the NFS server
    /images 10.32.3.27/22 (rw,sync,no_root_squash,)
    /mnt/images 10.32.3.27/22 (ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /mnt/images/dev 10.32.3.27/22 (rw,sync,no_wdelay,no_root_squash,insecure)

    Fog Server Permission on /mnt/images
    drwxrwxrwx 2 nobody nobody 37 May 30 07:06 dev
    -rw-r–r-- 1 nobody nobody 0 May 29 11:58 mntcheck
    [root@fog ~]#

    NFS Server permissions on /images
    drwxrwxrwx 2 fog root 37 May 30 09:06 dev
    -rw-r–r-- 1 fog root 0 May 29 13:58 mntcheck
    -rwxrwxrwx 1 fog root 0 May 29 12:46 .mntcheck
    drwxrwxrwx 4 fog root 29 May 29 12:11 .Trash-0[/quote]

    Also there is not authentication needed to access the nfs



  • Thanks again for the info. Here is a little more info for you
    My etc/export on the FOG server is

    /mnt/images *(ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /mnt/images/dev *(rw,sync,no_wdelay,no_root_squash,insecure)

    and on the NFS server
    /images 10.32.3.27/22 (rw,sync,no_root_squash,)
    /mnt/images 10.32.3.27/22 (ro,sync,no_wdelay,insecure_locks,no_root_squash,insecure)
    /mnt/images/dev 10.32.3.27/22 (rw,sync,no_wdelay,no_root_squash,insecure)

    Fog Server Permission on /mnt/images
    drwxrwxrwx 2 nobody nobody 37 May 30 07:06 dev
    -rw-r–r-- 1 nobody nobody 0 May 29 11:58 mntcheck
    [root@fog ~]#

    NFS Server permissions on /images
    drwxrwxrwx 2 fog root 37 May 30 09:06 dev
    -rw-r–r-- 1 fog root 0 May 29 13:58 mntcheck
    -rwxrwxrwx 1 fog root 0 May 29 12:46 .mntcheck
    drwxrwxrwx 4 fog root 29 May 29 12:11 .Trash-0



  • Hi,

    thomas the information with ftp was something additional and will not fix the permission denied problem.
    Also your nfs share has to be accessible without any credentials.

    Greetz X23



  • Thanks for your help! I will fire up an ftp server on the NFS machine. Is it possible to just use a[FONT=Tahoma]nonymous login on the ftp…this is in a private network. Of course I can set up the correct authentication. [/FONT]

    [FONT=Tahoma]I am of course German Volga\German :D [/FONT]
    [FONT=Tahoma] [/FONT]



  • Hi,

    you need two exports @ your additional nfs share, check /etc/exports @ your main fog installation,
    maybe then things went clear.

    Is it allowed for the fog ip to connect to the nfs share? It’s possible to define ranges of ip’s who can or not.

    Also if you are using an alternative nfs share where is not fog installed as a storage node you will also need to install a ftp server on the same machine.

    At the moment the image is finished it will be moved from /images/dev/whatever to /images/imagename this happens via ftp, this is a depricated thing because it could also be done directly via nfs but actually its done by ftp.
    [QUOTE][B]KNOWN ISSUE[/B] You will get an error “Ftp connection to storage server has failed” at the end of uploading images though. You will have to manually rename and move the file from the dev directory to the directory below.
    If your NFS server supports ftp as well, enable ftp on it too with the username and password specified in the storage server settings and this message will go away.
    Hopefully someone will re-write POST_Stage2.php to change this at some point as if you already have the NFS share mounted why do we do this bit with ftp?
    [/QUOTE]
    [url]http://fogproject.org/forum/threads/how-to-setup-a-fog-storage-node-without-installing-fog.4294/[/url]
    [url]http://www.fogproject.org/wiki/index.php/FOGUserGuide#Advanced_Installations[/url]

    Have you tried to manually mount the share on another machine?

    Finally… Bollig… are you a german?

    Greetz X23


Log in to reply
 

479
Online

39.3k
Users

11.0k
Topics

104.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.