DHCP Help



  • Alright guys, I changed the IP address of my FOG server, and I was doing it by memory. I edited something that I didn’t have too, and I am kind of stuck. I thought that I had it figured out, but looks like something still may not be right…Can someone look over this config and see if it looks right?

    IP Address of FOG Server: 10.255.255.10
    Subnet Mask: 255.255.255.224
    Gateway: 10.255.255.1

    dhcpd.conf:

    [CODE]# DHCP Server Configuration file.

    see /usr/share/doc/dhcp*/dhcpd.conf.sample

    This file was created by FOG

    use-host-decl-names on;
    ddns-update-style interim;
    ignore client-updates;
    next-server 10.255.255.10;

    subnet 10.255.255.0 netmask 255.255.255.224 {
    option subnet-mask 255.255.255.224;
    range dynamic-bootp 10.255.255.15 10.255.255.30;
    default-lease-time 21600;
    max-lease-time 43200;
    option domain-name-servers 212.95.4.31;
    option routers 10.255.255.1;
    filename “pxelinux.0”;
    }[/CODE]

    I tried putting the subnet mask in dhcpd.conf of 255.255.255.254 and it said it was not within range…After I put it as 255.255.255.0 it went through, and computers can actually boot through PXE, however when I go to full inventory, quick image, or anything else that I have tried, it takes a while, and then it hangs @ Attempting to send inventory…

    but it never asks me for values to fill out for some reason…something with the ip address somewhere isn’t right, and I am wondering if it because of something in the dhcpd.conf…idk…I am at a loss…everything else is working.



  • oops, nevermind…I changed the subnet mask under eth0 because I had a typo, but it didn’t accept the change…stupid Ubuntu haha…got it going now!


Log in to reply
 

436
Online

38998
Users

10717
Topics

101752
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.